XAMPP 1.7.4 -- Joomla error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP 1.7.4 -- Joomla error

Postby geethupendra » 14. February 2011 17:54

Hello Team,

after installed 1.7.4, i get errors in all joomla installation (1.5.22).. please find the detail................



Strict Standards: Non-static method JLoader::import() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\joomla\import.php on line 29
Strict Standards: Non-static method JLoader::register() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\loader.php on line 71
Strict Standards: Non-static method JLoader::import() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\joomla\import.php on line 32
Strict Standards: Non-static method JLoader::register() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\loader.php on line 71
Strict Standards: Non-static method JLoader::load() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\loader.php on line 161
Strict Standards: Non-static method JLoader::register() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\loader.php on line 138
Strict Standards: Non-static method JRequest::clean() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\joomla\import.php on line 33
Strict Standards: Non-static method JRequest::_cleanArray() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\joomla\environment\request.php on line 463
Strict Standards: Non-static method JRequest::_cleanArray() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\joomla\environment\request.php on line 464
Strict Standards: Non-static method JRequest::_cleanArray() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\joomla\environment\request.php on line 465
Strict Standards: Non-static method JRequest::_cleanArray() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\joomla\environment\request.php on line 466
Strict Standards: Non-static method JRequest::_cleanArray() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\joomla\environment\request.php on line 467
Strict Standards: Non-static method JRequest::_cleanArray() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\joomla\environment\request.php on line 468
Strict Standards: Non-static method JLoader::import() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\joomla\import.php on line 35
Strict Standards: Non-static method JLoader::register() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\loader.php on line 71
Strict Standards: Non-static method JLoader::import() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\joomla\import.php on line 38
Strict Standards: Non-static method JLoader::register() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\loader.php on line 71
Strict Standards: Non-static method JLoader::import() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\joomla\import.php on line 39
Strict Standards: Non-static method JLoader::register() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\loader.php on line 71
Strict Standards: Non-static method JLoader::load() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\loader.php on line 161
Strict Standards: Non-static method JLoader::register() should not be called statically in D:\xampp\htdocs\smtflanka\libraries\loader.php on line 138


This is fue lines of the errors, it displaying widely...

please help me some one..... I try to do the PHP.INI edit but couldn't sort the matter... :?

thanks
geeth
geethupendra
 
Posts: 3
Joined: 14. February 2011 17:45

Re: XAMPP 1.7.4 -- Joomla error

Postby Altrea » 14. February 2011 21:56

or try a newer Joomla Release
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6471
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: XAMPP 1.7.4 -- Joomla error

Postby geethupendra » 15. February 2011 09:16

Joomla Current version is 1.6..(no problem with 1.6 version)

But 1.5 range last update was 1.5.22-> all of the sites is using 1.5.22 ...

1.5.22 can migrate to 1.6.0 but modules/articales and other tools can't migrate...

Any idea about that....

thanks
geeth
geethupendra
 
Posts: 3
Joined: 14. February 2011 17:45

Re: XAMPP 1.7.4 -- Joomla error

Postby Altrea » 15. February 2011 10:45

That is a great question for a Joomla Board or the module developers
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6471
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: XAMPP 1.7.4 -- Joomla error

Postby geethupendra » 15. February 2011 11:47

Hello All,

At last i found this , in the XAMPP 1.7.4 --> PHP directory just edit the php.ini (error reporting area) 8)

Code: Select all
error_reporting = E_ALL & ~E_NOTICE


thanks
geeth
geethupendra
 
Posts: 3
Joined: 14. February 2011 17:45

Re: XAMPP 1.7.4 -- Joomla error

Postby lecaro » 09. April 2011 00:01

Please help!!!!!!!!!!!!!!!!!!!!!

I need run joomla in xampp 1.7.4

i don't want retunrd to older version... or move to anothers aplicatiosn like wamp

The problems is with xampp 1.7.4

Same i have problems with the .exe erros over windows 7

sorry by my english

Creo que ha sido una mala compilacion esta version de xampp, por favor revisenla bien!!!

gracias!!!
lecaro
 
Posts: 1
Joined: 08. April 2011 23:34

Re: XAMPP 1.7.4 -- Joomla error

Postby Sharley » 09. April 2011 00:50

lecaro wrote:I need run joomla in xampp 1.7.4

i don't want retunrd to older version... or move to anothers aplicatiosn like wamp

The problems is with xampp 1.7.4

Same i have problems with the .exe erros over windows 7
What version of Joomla are you trying to install in XAMPP 1.7.4?


You could try uninstalling the XAMPP 1.7.4 installer version that you used by using the uninstall instructions in the readme file or on the XAMPP for Windows Home Page.

Next download the zip version and extract the xampp folder to the root of a drive or partition, for example to the C:\ drive so you end up with C:\xampp and then run the setup_xampp.bat file in this xampp folder - running the bat file is essential.

Now go to http://localhost and set your language and test your XAMPP installation by trying the demos and the access to phpMyAdmin that you will need to create a Joomla database also you can set any security passwords you need by going to the Security pages.

When you are happy that XAMPP is working as it should then and only then try and install and run Joomla.

If you follow the above instructions and Joomla fails to work then double check the Joomla installation instructions and if you feel you installed Joomla correctly but still it fails then it may be that the version of Joomla you are trying to install is not compatible with XAMPP 1.7.4 and so try an older version of Joomla then try again as a process of elimination.

All Joomla download and pdf installation instructions from here with a language selector at the top right of this page:
http://www.joomla.org/download.html

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP 1.7.4 -- Joomla error

Postby earthrat » 29. May 2011 21:25

I get a real charge out of reading these forums and find that answers are given from people who dont even know how to spell Joomla! correctly let alone know how to work with it.

Regardless of what wole is saying, rather I have NO idea what he is saying? geethupendra is correct and what you need to do is change the following line in the php.ini file:

Line 516: error_reporting = E_ALL | E_STRICT

TO

Line 516: error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

Save that and restart Apache and you should be good to go with installing and working with Joomla! on XAMPP 1.7.4
earthrat
 
Posts: 5
Joined: 29. May 2011 21:18

Re: XAMPP 1.7.4 -- Joomla error

Postby Altrea » 29. May 2011 22:44

I'm really tired of answers like yours.

1st: you tell someone to change something without any explaination what exactly this change will do.
2nd: php.ini is the very central configuration file of your php development environment. Maybe there are people out there who uses other scripts at the same environment with Joomla and where suppressing notices and deprecated messages is not the thing they wish.
3rd: supressing the messages don't work with Joomla versions prior 1.5.15.
4th: Joomla can work with PHP 5.3 since Joomla 1.5.15 but only the core of Joomla! Not every Joomla module is yet able to work on PHP 5.3.

If you want to lecture someone how to answer the right way, you should answer the right way too!
To just throw out a possible solution without any explaination is not the right way. Nobody will learn anything from that.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6471
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: XAMPP 1.7.4 -- Joomla error

Postby earthrat » 30. May 2011 00:17

My bad, I thought it would be obvious since I was referencing geethupendra's post you would know we are talking about the php.ini file.

FYI: Joomla! 1.5.14 (Not 1.5.15) and below DOES NOT work with PHP 5.3 at all and 1.5.14 and above with error reporting set to STRICT mode will not work, hence the reason for this thread. Besides the fact that we are talking about a testing environment here I fail to see the argument about suppressing the message and since there are more ways to enable reporting of errors and warnings, suppressing it here is not all inclusively a bad thing or something that is going to hurt a thing! Really all it does to change this is set it to the way it was in XAMPP 1.7.3 and unless you are a developer it has no bearing on the functionality of the CMS.

You claim the answer I gave was not clear so Google it and find out, really it is not at all difficult to do. Since geethupendra was asking for a solution my answer did much more to reply to that than yours "or try a newer Joomla Release" when in fact if you would have read his post he was using the latest release of Joomla! 1.5. Don't even suggest 1.6 since it has no business being out of beta let alone using it as a production environment. Since it's life span is over in 2 months with the release of 1.7 and then the release of 1.8 or 1.9 or 2.0 (who knows what is going on?) set out in early 2012 there is no call to make a mad dash for it anyway.

You are correct that only the core is proven to work at all with PHP 5.3 (IF you make the changes I suggested) and like me I imagine that is the goal for testing with a tool such as XAMPP to see what extensions will and will not work with it.

BTW, my solution is not a "possible" solution it IS a solution and my lecture as you so kindly call it was not directed at you since you did not offer anything of value to the conversation anyway. I replied to this thread to help others make it work, not delve into the far reaches of why it works.
earthrat
 
Posts: 5
Joined: 29. May 2011 21:18

Re: XAMPP 1.7.4 -- Joomla error

Postby mibrant » 18. July 2011 23:41

Thanks earthrat. Your solution is better than unistall xampp and trying to install an older version. But I see the risk in just suppressing warning messages. But I can live with that for now.

Joomla 1.6 has become stable, but many important adons is still not ready, the same to say about language files for different components and plug-ins. When you work with Xampp you want to mimic your ISP server. And they can have different settings.

This said, I want to point out that it is a mistake to let Xampp only work with the latest Joomla version. You need a more conservative approach to adapt to the programs and serves used on production sites. I think that at least 6 months is needed before and general migration to joomla 1.6 is possible. Until then I am stuck with Joomla 1.5 and need an ISP that let me continue to use Joomla 1.5.

When the time to upgrade joomla comes, I want to test the new 1.6 site in Xampp first. For this reason xampp needs to handle both 1.5 and 1.6
mibrant
 
Posts: 1
Joined: 18. July 2011 23:17

Re: XAMPP 1.7.4 -- Joomla error

Postby earthrat » 19. July 2011 00:20

Actually 1.7 is scheduled for release tomorrow. I am not having any problem running 1.5 sites on my install and the only issue you will have is with extensions. To that end if the extension does not work with the latest version you are at risk of using an extension that is insecure and not worth using anyway.
earthrat
 
Posts: 5
Joined: 29. May 2011 21:18

Re: XAMPP 1.7.4 -- Joomla error

Postby Altrea » 19. July 2011 05:05

mibrant wrote:I want to point out that it is a mistake to let Xampp only work with the latest Joomla version.
[...]
When the time to upgrade joomla comes, I want to test the new 1.6 site in Xampp first. For this reason xampp needs to handle both 1.5 and 1.6

But thats not a mistake of XAMPP but of the users choosen the wrong XAMPP version. You should choose that XAMPP Version which fits your requirements. If you want to use Joomla 1.5 up to Joomla 1.7 than you take Joomlas technical requirements and see, that maybe a XAMPP Version with PHP 5.2.4+ is the best solution, and thats not XAMPP 1.7.4 but XAMPP 1.7.1 which comes with PHP 5.2.9 and is the last XAMPP release with PHP 5.2.
After that you try to set the settings and configuration of Apache, PHP and MySQL the way you can work with it the best (error_reporting, Modules, and so on).

The other possibility is to use more than one XAMPP installation on your computer. XAMPP is very portable and so it's no problem to have more than one instance of it.

Short: YOU are the developer. It is one task of a developer to configure his/her development environment that way he/she can be as efficient as possible.

XAMPP can show you one way, but it can't fit all needs and requirements everywhere in the world.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6471
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: XAMPP 1.7.4 -- Joomla error

Postby earthrat » 19. July 2011 05:43

Altrea, is there anything special that needs to be done to run multiple versions of XAMPP?
earthrat
 
Posts: 5
Joined: 29. May 2011 21:18

Re: XAMPP 1.7.4 -- Joomla error

Postby Altrea » 19. July 2011 06:28

A few small things to notice:

- use the XAMPP zip versions, not the installer
- create for every instance their own folder in the root of your HDD (e.g. c:\xampp171\, c:\xampp173\ ...)
- don't use the svc (Windows Service) checkboxes in the XAMPP control panel
- you can only start one XAMPP instance at the same time (you can change the ports of the other instances to run multiple instances at the same time, but that can produce complications with some webapplications which just can run be used with port 80)

That way i run a few instances from XAMPP 1.5.13 up to XAMPP 1.7.5b
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6471
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests