Problems with mod_perl

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems with mod_perl

Postby Bruno2011 » 30. January 2011 06:05

All my .cgi and .pl scripts works fine with xampp 1.7.3
because I can setup xampp to disable mod_perl.

I can`t disable mod_perl in the new verison 1.7.4 of xampp,
son every time I try to use my scripts, it comes with following error:
Can't locate konfiguration.dat in @INC (@INC contains: blah blah blah blah blah

In my script, I have the following line:
require "konfiguration.dat";

What should I do ?
Bruno2011
 
Posts: 1
Joined: 30. January 2011 05:54

Re: Problems with mod_perl

Postby Sharley » 30. January 2011 07:01

Bruno2011 wrote:I can`t disable mod_perl in the new verison 1.7.4 of xampp...
...what should I do?
Take a big stick and give 1.7.4 a good whacking. :D


Yes, 1.7.3 setup_xampp.bat file made life a lot easier.

Open \xampp\apache\conf\httpd.conf file in your text editor and look for this line
Code: Select all
# Perl settings
Include "conf/extra/httpd-perl.conf"
Change it by adding the comment out character
Code: Select all
# Perl settings
# Include "conf/extra/httpd-perl.conf"
Save the file and restart Apache.
Check that your text editor saves the file with the .conf ext not a .txt extension as is common with Windows notepad.

Now it should be disabled.

Make sure that your script's first line (shebang) is the full path to perl for example
Code: Select all
#!"C:\xampp\perl\bin\perl.exe"


Good luck and best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests