Apache being scuppered by NetNanny?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache being scuppered by NetNanny?

Postby BigPaws » 17. January 2011 15:33

Hi all,

Bit of a newb. Had apache running for a good few months, no problems. Installed Net nanny yesterday and now things grind to a halt. apache starts ok, but when trying to view any of my pages, the server crashes. The windows error codes points to httpd.exe, the module at fault being cwalsp.dll - which I believe is to do with content watch. So chances are it's net nanny giving the beef here?

apache error logs -

[Mon Jan 17 14:24:13 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Jan 17 14:24:13 2011] [notice] Digest: done
[Mon Jan 17 14:24:13 2011] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Jan 17 14:24:13 2011] [notice] Server built: Nov 11 2009 14:29:03
[Mon Jan 17 14:24:13 2011] [notice] Parent: Created child process 5320
[Mon Jan 17 14:24:20 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Jan 17 14:24:20 2011] [notice] Digest: done
[Mon Jan 17 14:24:20 2011] [notice] Child 5320: Child process is running
[Mon Jan 17 14:24:20 2011] [notice] Child 5320: Acquired the start mutex.
[Mon Jan 17 14:24:20 2011] [notice] Child 5320: Starting 150 worker threads.
[Mon Jan 17 14:24:20 2011] [notice] Child 5320: Starting thread to listen on port 443.
[Mon Jan 17 14:24:20 2011] [notice] Child 5320: Starting thread to listen on port 80.
[Mon Jan 17 14:24:20 2011] [notice] Child 5320: Starting thread to listen on port 443.
[Mon Jan 17 14:24:20 2011] [notice] Child 5320: Starting thread to listen on port 80.


Any suggestions? Anyway round this apart from binning netnanny?

Cheers
BigPaws
 
Posts: 1
Joined: 17. January 2011 15:27

Re: Apache being scuppered by NetNanny?

Postby Sharley » 18. January 2011 01:31

Your error.log file looks normal - no errors.

Not familiar with NetNanny as I am my own net nanny and seriously if you want to run a web server then you also have to be your own net nanny - after all you will become a server administrator once you are running your own web server.

Is there any configurations in NetNanny to perhaps configure not to nanny port 80 and port 443 as Apache httpd.exe requires exclusive use of these ports?

Try running \xampp\xampp-portcheck.exe and see if NetNanny has commandeered port 80 and 443 before trying to start Apache in the XAMPP Control Panel - all ports should be free before attempting to start Apache and MySQL.

Finally if NetNanny won't play fair then bin it.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: lse123 and 38 guests