fehlende http erweiterung

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

fehlende http erweiterung

Postby torwald » 07. May 2010 10:36

Hallo,

ich versuche gerade ein "open enventory"unter Xampp zum laufen zu bringen. Allerdings bekomme ich ständig die Fehlermeldung:
Die Erweiterung http ist für open enventory erforderlich und ist nicht installiert.


In der FAQ von Open Enventory steht als Voraussetzungen:
Als Server arbeitet ein Apache-Webserver mit PHP5 und einer MySQL-Datenbank. Alles kann unter Windows (z.B. Xampp) oder Linux betrieben werden.


Ich verwende die Xampp 1.7.2 Version, mit Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0 sowie MySQL-Client-Version: 5.1.37 mit PHP Erweiterung: mysqli.

Wenn ich die FAQ von Open Enventory richtig verstehe sollte es kein Problem sein es zum laufen zu bringen. Nichts desto trotz erscheint immer die oben beschrieben Fehlermeldung. Bedeutet das, ich habe bei der Installation von Xampp einen Fehler gemacht, oder ist das eine "untypische" Erweiterung und ich muss diese lediglich nachinstallieren?

Vielen Dank im Voraus

Torwald
torwald
 
Posts: 1
Joined: 07. May 2010 10:17

Re: fehlende http erweiterung

Postby chemFelix » 31. August 2010 10:40

Hallo Torwald,

eine passende DLL kann unter http://downloads.php.net/pierre/ heruntergeladen werden. Dort muß man die passende Architektur auswählen, vermutlich php_http-5.3-svn20091125-vc9-x86.zip , und dann die Datei in xampp\php\ext . Dann die php.ini um die Zeile extenstion=php_http.dll ergänzen, sofern noch nicht geschehen. Nach einem Neustart des Apache sollte es klappen.

Schöne Grüße

Felix

P.S.: Hättest mir ruhig eine Mail schreiben können :-) , dann hätte ich dir das direkt gesagt (werde die INSTALL mal updaten).
chemFelix
 
Posts: 2
Joined: 31. August 2010 08:57

Re: fehlende http erweiterung

Postby Nobbie » 31. August 2010 10:47

chemFelix wrote:Dort muß man die passende Architektur auswählen, vermutlich php_http-5.3-svn20091125-vc9-x86.zip


Wenn überhaupt - es ist gut möglich, dass keine DLL passend zum Xampp PHP ist. Ich würde deswegen auf Xampp verzichten und die komplette PHP Installation von o.g. Link benutzen (in einer nativen Apache Umgebung plus MySQL). Das ist meistens einfacher zu konfigurieren als ein kompletter Austausch der PHP Version unter Xampp.
Nobbie
 
Posts: 6585
Joined: 09. March 2008 13:04

Re: fehlende http erweiterung

Postby chemFelix » 04. November 2012 23:58

Hallo zusammen,

ein kleines Update: ich habe die Software mit dem neuesten Release auf Pear/HTTP2 umgestellt (und die entsprechenden Bibliotheken dazugepackt), d.h. dieses Hindernis sollte dauerhaft ausgeräumt sein.

LG, Felix
chemFelix
 
Posts: 2
Joined: 31. August 2010 08:57


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 18 guests