SSL will nicht funktionieren

Alles, was den ProFTPD betrifft, kann hier besprochen werden.

SSL will nicht funktionieren

Postby gammlo » 15. March 2010 05:20

Hi,
meine proftpd.conf sieht so aus:
Code: Select all
# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName         "ROOTSERVER"
ServerType         standalone
DefaultServer         on

# Port 21 is the standard FTP port.
Port            46
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask            022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances         30

# Set the user and group that the server normally runs at.
User            nobody
#Group            nogroup

# Normally, we want files to be overwriteable.
<Directory /opt/lampp/htdocs/*>
  AllowOverwrite      on
</Directory>

# only for the web servers content
DefaultRoot ~

# nobody gets the password "lampp"
# commented out by lampp security
#UserPassword nobody wRPBu8uXXXXXX
UserPassword nobody kJ47aXXXXXX

# nobody is no normal user so we have to allow users with no real shell
RequireValidShell off

# nobody may be in /etc/ftpusers so we also have to ignore this file
UseFtpUsers off

AllowForeignAddress on

TimeoutIdle 0
UseReverseDNS off
IdentLookups off

# Uncomment this if you would use TLS module:
TLSEngine                    on
TLSLog                          /opt/lampp/var/proftpd/tls.log
TLSProtocol                    SSLv23
TLSOptions                    NoCertRequest
TLSRSACertificateFile               /opt/lampp/share/openssl/certs/proftpd.cert.pem
TLSRSACertificateKeyFile          /opt/lampp/share/openssl/certs/proftpd.key.pem
TLSVerifyClient                    off
TLSRequired on


/opt/lampp/var/proftpd/tls.log dort steht:
Mar 15 05:09:47 mod_tls/2.2.2[18442]: using default OpenSSL verification locations (see $SSL_CERT_DIR environment variable)
Mar 15 05:09:47 mod_tls/2.2.2[18442]: TLS/TLS-C requested, starting TLS handshake
Mar 15 05:09:48 mod_tls/2.2.2[18442]: TLSv1/SSLv3 connection accepted, using cipher DHE-RSA-AES128-SHA (128 bits)
Mar 15 05:09:48 mod_tls/2.2.2[18442]: Protection set to Private
Mar 15 05:09:49 mod_tls/2.2.2[18442]: starting TLS negotiation on data connection
Mar 15 05:09:49 mod_tls/2.2.2[18442]: warning: client-initiated session renegotiation detected, aborting connection

So siehts im FTP Programm aus:
http://www.abload.de/image.php?img=ftp_1ec4k.jpg

Nachdem ich bestätigt habe kommt dann:
http://www.abload.de/image.php?img=ftp_2qd8m.jpg

Den Befehl wurde auch korrekt ausgeführt:
/opt/lampp/bin/openssl req -new -x509 -days 365 -nodes -out /opt/lampp/share/openssl/certs/proftpd.cert.pem -keyout /opt/lampp/share/openssl/certs/proftpd.key.pem

Ich habe den Befehl jetzt noch einmal eingegeben und überall "Server" eingetippt. Nun siehts so im FTP Client aus:
http://www.abload.de/img/ftp_4pd56.jpg

Nun kommt folgender Fehler:
http://www.abload.de/img/ftp_3ofrf.jpg

Habe Filezilla nochmal neugestartet, dann den Server ausgewählt, das Zertifikat bestätigt und dann kam wieder dieser Fehler: http://www.abload.de/image.php?img=ftp_2qd8m.jpg

Wenn ich den ganzen kram:
Code: Select all
# Uncomment this if you would use TLS module:
TLSEngine                    on
TLSLog                          /opt/lampp/var/proftpd/tls.log
TLSProtocol                    SSLv23
TLSOptions                    NoCertRequest
TLSRSACertificateFile               /opt/lampp/share/openssl/certs/proftpd.cert.pem
TLSRSACertificateKeyFile          /opt/lampp/share/openssl/certs/proftpd.key.pem
TLSVerifyClient                    off
TLSRequired on


aus der proftpd.conf rausnehme und bei filezilla unter Servertyp FTP anstatt FTPES einstelle funktioniert alles. Habe den Server und meinen Rechner auch schon mal neugestartet. Bei einem Freund kommt die gleiche Meldung. Nutze Filezilla 3.2.7.1, früher gings aber mal. Da beim Server die Festplatte kaputt war musste alles neu gemacht werden und nun funktioniert es nicht mehr.

Was ist da los?
gammlo
 
Posts: 16
Joined: 31. May 2009 01:20

Return to ProFTPD

Who is online

Users browsing this forum: No registered users and 0 guests