Mysql Configuration problem too slow

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mysql Configuration problem too slow

Postby vassili » 16. September 2009 15:06

Hi i'm newbie here, i would like to know what would be the cause of these problem..
i have xampp 1.7.2 version installed on my system, heres my local server specs
Intel E8400 3ghz dualcore wolfdale
4gb High Performance DDR2 Ram
640gb Black Power Western digital
Windows Vista Ultimate 32bit

heres the problem,
- i have 521,771,15 total count in rows in my table, when i try to execute the data, i got 20secs delayed and sometimes my Database got a message "NOT Responding", i think there was a problem with my mysql configuration to handle this large data, if anyone here knows how to resolve this issue please let me know :)

my sql file is 70mb with a total count of 521K record of count in rows.. anyway heres my configuration in my system

Code: Select all
# Example MySQL config file for medium systems.
# This is for a system with little memory (32M - 64M) where MySQL plays
# an important part, or systems up to 128M where MySQL is used together with
# other programs (such as a web server)
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is @localstatedir@) or
# ~/.my.cnf to set user-specific options.
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
#user       = your_username
#password   = your_password
host        = .
port      = 3306
socket      = "MySQL"

# Here follows entries for some specific programs

# The MySQL server
basedir                 = "D:/www/server/xampp/mysql/"
datadir                 = "D:/www/server/xampp/mysql/data/"
port                  = 3306
socket                  = "MySQL"
key_buffer              = 16M
max_allowed_packet      = 1M
table_cache             = 64
sort_buffer_size        = 512K
net_buffer_length       = 8K
read_buffer_size        = 256K
read_rnd_buffer_size    = 512K
myisam_sort_buffer_size = 8M

default-time-zone       = "UTC"

log_error           = "D:/www/server/xampp/mysql/data/mysql.err"
pid_file            = ""
general_log         = 0
general_log_file    = "D:/www/server/xampp/mysql/data/mysql.log"
slow_query_log      = 0
slow_query_log_file = "D:/www/server/xampp/mysql/data/mysql-slow.log"

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!

# Disable Federated by default

# Replication Master Server (default)
# binary logging is required for replication
#log-bin = mysql-bin

# binary logging format - mixed recommended
#binlog_format = mixed

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id = 1

# Replication Slave (comment out master section to use this)
# To configure this host as a replication slave, you can choose between
# two methods :
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
#    the syntax is:
#    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#    where you replace <host>, <user>, <password> by quoted strings and
#    <port> by the master's port number (3306 by default).
#    Example:
#    MASTER_USER='joe', MASTER_PASSWORD='secret';
# OR
# 2) Set the variables below. However, in case you choose this method, then
#    start replication for the first time (even unsuccessfully, for example
#    if you mistyped the password in master-password and the slave fails to
#    connect), the slave will create a file, and any later
#    change in this file to the variables' values below will be ignored and
#    overridden by the content of the file, unless you shutdown
#    the slave server, delete and restart the slaver server.
#    For that reason, you may want to leave the lines below untouched
#    (commented) and instead use CHANGE MASTER TO (see above)
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id       = 2
# The replication master for this slave - required
#master-host     = <hostname>
# The username the slave will use for authentication when connecting
# to the master - required
#master-user     = <username>
# The password the slave will authenticate with when connecting to
# the master - required
#master-password = <password>
# The port the master is listening on.
# optional - defaults to 3306
#master-port     = <port>
# binary logging - not required for slaves, but recommended
#log-bin         = mysql-bin

# Point the following paths to different dedicated disks
tmpdir           = "D:/www/server/xampp/tmp/"
#log-update      = "D:/www/server/xampp/tmp/mysql"

# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir            = "D:/www/server/xampp/mysql/data/"
innodb_data_file_path           = ibdata1:10M:autoextend
innodb_log_group_home_dir       = "D:/www/server/xampp/mysql/data/"
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
innodb_buffer_pool_size         = 16M
innodb_additional_mem_pool_size = 2M
# Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size            = 5M
innodb_log_buffer_size          = 8M
innodb_flush_log_at_trx_commit  = 1
innodb_lock_wait_timeout        = 50

max_allowed_packet = 16M

# Remove the next comment character if you are not familiar with SQL

key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M


Thank you in advance :)
Posts: 2
Joined: 16. September 2009 14:20

Re: Mysql Configuration problem too slow

Postby vassili » 17. September 2009 03:49

any inputs???
Posts: 2
Joined: 16. September 2009 14:20

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 93 guests