xampp 64 bit

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp 64 bit

Postby michaelpanic » 26. December 2008 17:31

Install 64bit versions of Apache, PHP and MySQL on Windows 64bit

Currently no official 64bit versions of Apache and PHP exists for Microsoft Windows. Only MySQL supports officialy 64bit Windows. If you have a 64bit version of Windows (2003/XP/Vista) and want to keep your system pure 64bit here is the solution! In this guide I will show you how to install and set up Apache 2.2 x64 web server, PHP 5.2 x64 and MySQL 5.0/5.1 x64 on Windows 2003/XP/Vista 64bit using unofficial binaries. Althought this setup has been tested successfully on Windows Vista 64bit Home Premium, I am not responsible for any damages may occur to your computer by this guide. Proceed at your own risk.

Download needed software
Download unofficial binaries for Apache x64 from blackdot.be:
http://www.blackdot.be/?inc=apache/binaries
Current version (November 2008): httpd-2.2.10-win64.zip

Download PHP x64 from fusionxlan.com:
http://www.fusionxlan.com/PHPx64.php
Current version (September 2008): 5.2.5

Download latest official MySQL 64bit binaries for Windows:
http://dev.mysql.com/downloads/mysql/

Install Apache 64bit
Create a folder inside your C drive and named it something like apache64. Unzip the contents of the Apache zip package you previously downloaded to folder: C:/apache64.
Edit Apache configuration file C:/apache64/conf/httpd.conf and change paths to match your system.

ServerRoot "C:/apache64"
ServerName localhost:80
DocumentRoot "C:/apache64/htdocs"
<Directory "C:/apache64/htdocs">
DirectoryIndex index.html, index.htm, index.php
ScriptAlias /cgi-bin/ "C:/apache64/cgi-bin/"

If you want to set up virtual hosts uncomment (remove the "#" symbol) the line bellow and edit the hosts.conf file respectively. Setting up virtual hosts on Windows.
#Include conf/extra/httpd-vhosts.conf

Uncomment the following line to load extension mod_rewite needed by Elxis SEO PRO. Also uncomment any other lines you wish to load the corresponding Apache extensions.
LoadModule rewrite_module modules/mod_rewrite.so

Open the Windows command prompt (Start -> Run/Search -> cmd) and navigate to folder C:/apache64 (CD C:\apache64). Execute the following commands:

bin\httpd.exe -k install
bin\httpd.exe -k start

Your Apache should work. Open bin folder and double click the ApacheMonitor.exe file. An icon will be displayed in your Windows taskbar. From there you can start/stop/restart Apache easily. We set the Document root to C:/apache64/htdocs, so this is the folder where you should put your web files (Elxis CMS for example). Open your browser and go to http://localhost/ to ensure Apache runs.

Install PHP 64bit
Create a folder inside your C drive and named it "php". Unzip the contents of the PHP zip package you previously downloaded and copy the contents of the "php-5.2.5 (x64)" (or what ever version you downloaded) to folder: C:/php. We will install PHP as an Apache module. Open your Apache configuration file (C:/apache64/conf/httpd.conf) to tell apache to load the PHP module. Under the existing LoadModule directives add the following:
LoadModule php5_module "C:/php/php5apache2_2.dll"
AddType application/x-httpd-php .php

Also add these lines to tell Apache where PHP is located:
# configure the path to php.ini
PHPIniDir "C:/php"

Copy the following files to your Widnows system folder (C:/Windows/system32):
C:/php/php5ts.dll
C:/php/php5isapi.dll
C:/php/php5apache2_2.dll
C:/php/ext/php_mysql.dll

Copy php.ini-dist to the same folder and rename it as php.ini. Open this file to edit PHP configuration parameters.
extension_dir = "C:/php/ext/"
allow_url_fopen = Off
Load at least the following PHP extesnions by removing the "#" symbol in front of each line:
extension=php_gd2.dll
extension=php_mysql.dll
extension=php_oci8.dll (if you have Oracle database installed)
extension=php_pgsql.dll (if you have postgre database installed)
extension=php_zip.dll

Set sendmail from e-mail address:
sendmail_from = me@example.com

Some settings for MySQL:
mysql.default_port = 3306
mysql.default_host = localhost

Set the session save path to a writable (by anyone) folder in your computer. You can set this to any existing path you wish (For example C:/tmp).
session.save_path = "C:/tmp"

Restart Apache to test if your PHP is working properly.

Install MySQL 64bit
This is the easiest part of the overall procedure as we have downloaded an official 64bit msi package from MySQL. Just double click it to run the installer. Install MySQL as a service.

Finish
Unless I forgotten something :-) your system is ready. You have a pure 64bit WAMP system, congratulations! You can now copy Elxis at C:/apache64/htdocs and run the Elxis installation wizard. If you wish to set up virtual hosts follow this guide: Setting up virtual hosts on Windows.


Written by Ioannis Sannos (datahell),
September 12, 2008
Last updated: November 15, 2008
michaelpanic
 
Posts: 1
Joined: 26. December 2008 17:23

Re: xampp 64 bit

Postby karthickhock » 16. May 2009 08:34

Hi,
I have tried to install the apache as per ur notes. But i Coudlnt install it in cmd, it threw the error : "(OS 5)Access is denied. : Failed to open the WinNT service manager"
Please help what can i do for this..?

Thanks :)
karthickhock
 
Posts: 1
Joined: 16. May 2009 07:47

Re: xampp 64 bit

Postby bosniamaj » 04. July 2009 14:49

I have the same problem man, and no idea how to solve it
bosniamaj
 
Posts: 3
Joined: 04. July 2009 14:42

Re: xampp 64 bit

Postby knyspel » 06. July 2009 16:28

You should click the right mouse button on httpd.exe and cmd.exe and select Run as Administrator.

If that does not work disable UAC (User Account Control)
1. Start > Control Panel
2. User Accounts
3. Click "Turn User Accounts Control on or off" Link.
4. Uncheck "User Account Control" Box
5. Click OK
6. Restart Windows
And try again
knyspel
 
Posts: 1
Joined: 06. July 2009 15:46

Re: xampp 64 bit

Postby bosniamaj » 06. July 2009 16:43

knyspel wrote:You should click the right mouse button on httpd.exe and cmd.exe and select Run as Administrator.

If that does not work disable UAC (User Account Control)
1. Start > Control Panel
2. User Accounts
3. Click "Turn User Accounts Control on or off" Link.
4. Uncheck "User Account Control" Box
5. Click OK
6. Restart Windows
And try again


Thanks, I made it work, but it is weird though. It says in xampp status page that my php and mysql are deactivated, but they work :shock:
bosniamaj
 
Posts: 3
Joined: 04. July 2009 14:42

Re: xampp 64 bit

Postby ojiepermana » 25. November 2009 05:14

hai all...
please help me i found a massage error

C:\apache64\bin>httpd.exe -k start

(OS 10013)An attempt was made to access a socket in a way forbidden by its acces
s permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
ojiepermana
 
Posts: 1
Joined: 25. November 2009 05:08


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests