Mysql has been okay, but suddenly wont start

Alles, was MySQL betrifft, kann hier besprochen werden.

Mysql has been okay, but suddenly wont start

Postby Jeggs » 21. April 2009 10:09

Anyone know why this could happen please??...could it be a problem with the port?
Thanks
Jeggs
 
Posts: 6
Joined: 09. April 2009 15:48
Location: Near London, England

Re: Mysql has been okay, but suddenly wont start

Postby Wiedmann » 21. April 2009 10:17

could it be a problem with the port?

This depends on the startup error message, if MySQL can't startup.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Mysql has been okay, but suddenly wont start

Postby Jeggs » 21. April 2009 10:43

Thanks.

It just comes up 'Busy'..........I cant see any error messages, is there a log ?
Jeggs
 
Posts: 6
Joined: 09. April 2009 15:48
Location: Near London, England

Re: Mysql has been okay, but suddenly wont start

Postby Wiedmann » 21. April 2009 10:44

is there a log ?

In the MySQL datadir is a *.err file.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Mysql has been okay, but suddenly wont start

Postby Jeggs » 21. April 2009 10:56

Thanks, found it.

This seems to be the reoccurring error:

090421 10:41:16 [ERROR] Fatal error: Can't open and lock privilege tables: File '.\mysql\host.MYD' not found (Errcode: 2)
Jeggs
 
Posts: 6
Joined: 09. April 2009 15:48
Location: Near London, England

Re: Mysql has been okay, but suddenly wont start

Postby Wiedmann » 21. April 2009 10:58

File '.\mysql\host.MYD' not found

And did you have this file or not?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Mysql has been okay, but suddenly wont start

Postby Jeggs » 21. April 2009 11:02

Wiedmann wrote:
File '.\mysql\host.MYD' not found

And did you have this file or not?


I haven't a clue what that file is to be honest. Mysql was working OK, then just wouldn't start yesterday. But I don't know what that file is, sorry.
Jeggs
 
Posts: 6
Joined: 09. April 2009 15:48
Location: Near London, England

Re: Mysql has been okay, but suddenly wont start

Postby Jeggs » 21. April 2009 11:38

Thanks Wiedmann, with your help I have rectified the problem by searching om google.

I backed up my databases and reinstalled xampp, and now it is working fine. I'm thinking maybe I lost the file .\mysql\host.MYD when I ran a disk cleaner recently.

Thanks for your help :wink:
Jeggs
 
Posts: 6
Joined: 09. April 2009 15:48
Location: Near London, England

Re: Mysql has been okay, but suddenly wont start

Postby Vinoj(Voo) » 19. November 2010 04:56

Hey this is easy to fix. This is happening because you got delete your host.MYD file, most of the time because it is an empty file.( in my computer it is always 0) to fix this open your my.ini (inside mysql installation) and find your "datadir"

In my wamp installation, it is datadir=C:/programming/wamp/bin/mysql/mysql5.1.36/data
and my standalone mysql installation it is datadir="C:/Documents and Settings/All Users/Application Data/MySQL/MySQL Server 5.1/Data/"

Anyway m not a xampp user sorry for that. Go to that data directory and go to mysql folder inside it. and inside that find any MYD file. We have to duplicate any MYD file. For example (db.MYD) ,, duplicate it, change its name to host.MYD. and then open newly created host.MYD and clear all the content inside it. Nw mysql should work. :)

HOpe this will help you. :D
Vinoj(Voo)
 
Posts: 1
Joined: 19. November 2010 04:41

Re: Mysql has been okay, but suddenly wont start

Postby Ron Barker » 06. July 2011 13:53

Vinoj(Voo)

You just saved my life and my wiki. Thank you very much.

Kind regards
Ron Barker
 
Posts: 1
Joined: 06. July 2011 13:48

Re: Mysql has been okay, but suddenly wont start

Postby praveen34 » 09. June 2013 16:17

Thanks for the solution.

It is really helped me.

I struggled hours for the problem "Error: #2002 - The Server Is Not Responding (Or The Local Mysql Server'S Socket Is Not Correctly Configured)" and tried many approaches. But finally solved with the above solution.
praveen34
 
Posts: 1
Joined: 09. June 2013 16:02
XAMPP Version: 5.5.19
Operating System: Windows 7


Return to MySQL

Who is online

Users browsing this forum: No registered users and 4 guests