trouble getting xampp to work...

Problems with the Solaris version of XAMPP, questions, comments, and anything related.

trouble getting xampp to work...

Postby qmqmqm » 24. March 2009 16:55

I already have Apache on a remote Solaris box before installing xampp. When I type in the ip address in the web browser address bar I get:

"If you can see this, it means that the installation of the Apache web server software on this system was successful..."

I went ahead and installed xampp 0.8.2 under /opt/xampp. However when I start xampp, I get:
Starting XAMPP for Solaris 0.8.2...
XAMPP: An Apache daemon is already running.
XAMPP: Starting MySQL...
XAMPP: A FTP daemon is already running.
XAMPP for Solaris started.

And when I type in the ip address in the web browser address bar again I get the same page as before, and I do not seem to get the default yellow-themed xampp homepage.

Could anyone inspire me why this is, and how to navigate to the xampp page?

Thanks,

Tom
qmqmqm
 
Posts: 3
Joined: 24. March 2009 16:48

Re: trouble getting xampp to work...

Postby Wiedmann » 24. March 2009 17:47

I already have Apache on a remote Solaris box before installing xampp.
...
XAMPP: An Apache daemon is already running.

You must stop this other Apache, if you want start Apache from XAMPP.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: trouble getting xampp to work...

Postby qmqmqm » 24. March 2009 18:15

Thanks for your reply Wiedmann.

Do you know hoow to stop it, or even uninstall it?

Thanks,

Tom
qmqmqm
 
Posts: 3
Joined: 24. March 2009 16:48

Re: trouble getting xampp to work...

Postby qmqmqm » 24. March 2009 18:45

doing apachectl stop did not work.

And I tried to kill -9 the processes, it says "not owner":
#ps -ef | grep pache
webservd 8346 1 0 17:38:09 ? 0:00 /usr/apache2/bin/httpd -k start
webservd 8349 1 0 17:38:09 ? 0:00 /usr/apache2/bin/httpd -k start
webservd 8348 1 0 17:38:09 ? 0:00 /usr/apache2/bin/httpd -k start
root 8548 28940 0 17:42:02 pts/1 0:00 grep pache
webservd 8351 1 0 17:38:16 ? 0:00 /usr/apache2/bin/httpd -k start
webservd 8350 1 0 17:38:09 ? 0:00 /usr/apache2/bin/httpd -k start
webservd 8347 1 0 17:38:09 ? 0:00 /usr/apache2/bin/httpd -k start

Any ideas how I can get rid of the running apaches? Or is xampp albe to use the existing apache?

Ultimately my goal is to develop a web application inside of xampp and being able to navigate to the web application using a web browser.

Any advise is greatly appreciated!

Tom
qmqmqm
 
Posts: 3
Joined: 24. March 2009 16:48


Return to XAMPP for Solaris

Who is online

Users browsing this forum: No registered users and 1 guest