Access violation at address 10002593

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Postby jaqqjazz » 06. March 2008 16:58

I have the same problem, but the solution to alter my.ini setup via the mySQLAdmin tool doesn't work because the tool doesn't stay up long enough. It dies every error message!
jaqqjazz
 
Posts: 1
Joined: 06. March 2008 16:55

Postby peoplefriend » 01. April 2008 01:20

Hi, I've also got the "Access violation at address 10002593" popups.

The solution was - just like others wrote here, too - to change the wrong user / password in the my.ini file.

By default the values are
user=root
password=

You can use notepad and edit the my.ini-file
or if you want to use the mySQLAdmin, you can open it by using the small icon (trafic light) down in the right corner of your screen next to your Clock. (Right click the icon and click on 'Show me' in the contextmenu). It will not disapear again. So you can change the password on the "my.ini Setup"-Tab. It is a littel tricky because first you have to remove most of the popups of the error-message.

After this you should run this url
http://127.0.0.1/security/index.php
Here you'll find the topic "The MySQL admin user root has NO password" to get the answer of how to change the password for root.

Thanks to all the other's who posted the solution with the my.ini file. After nearly one week I was glad to find this hint.
peoplefriend
 
Posts: 1
Joined: 01. April 2008 00:17

Postby Mainzelmann1 » 01. April 2008 05:26

Great security approach indeed.
Sure you are working alone in your network?

Sagt mal, ist das ein Satireforum hier?
Mainzelmann1
 
Posts: 4
Joined: 07. February 2008 21:30

Same problem, different solution...

Postby mikael » 11. July 2008 07:16

I also had the error. I am using XAMPP, and loving it! It occurred after I set up a wrong account name and password. After reading this forum, I went to the my.ini file and instead of removing the root password, I just removed the entire user and pass fields.

I don't have any problems like that.. is that a problem? Am I just leaving winmysql admin wide open?

The problem now, possibly unrelated, is with winMySql admin. I can start mySql (not as a service), and then when I click admin..., it installs mysql as a service and turns it off. I cannot get it to stay on as a service, and then when i uninstall it as a service, it returns to the running state it was in before i clicked admin..
mikael
 
Posts: 1
Joined: 11. July 2008 07:04

WinMySqlAdmin Closes abruptly

Postby linda.k » 13. July 2008 03:44

I cannot find how to change the user and passcode as indicated. when i go into the console and try to edit settings for mysql, the admin opens and then closes quickly. Has anyone seen this? Is there a way around this to set the user name and passcode?
linda.k
 
Posts: 1
Joined: 13. July 2008 02:47

Re: Access violation at address 10002593

Postby annoyingBug » 30. January 2009 15:02

Since leaving the password blank is a bandaid-fix at best (since it's really insecure)- I present you with what
you have to do to get rid of the annoying pop-up while still having a password:

REAL SOLUTION:

1.Open up WinMySQL (if it instantly closes the window - rightclick the trayicon and select "Show Me").
2.Goto "my.ini setup". and move the two lines "user=root" and "password=pass" from where they are initially (red) to
up to the [mysqld] section (green). ("moving" means copy&pasting those lines and deleting the old ones in case I wasn't clear enough)

[mysqld]
basedir=C:/xampp/mysql
#bind-address=localhost
datadir=C:/xampp/mysql/data
#language=C:/xampp/mysql/share/your language directory
#slow query log#=
#tmpdir#=
#port=3306
user=root
password=pass

#set-variable=key_buffer=16M
[WinMySQLadmin]
Server=C:/xampp/mysql/bin/mysqld-nt.exe
user=root
password=pass


3. Click "Save Modification".

Strangely enough that's all you have to do. When you just copy those two lines from the 2nd section to the first one
you get rid of the popup and yet still retain a password.

Original source:
http://www.eurostern24.de/xampp-access- ... ibmysqldll
annoyingBug
 
Posts: 1
Joined: 30. January 2009 14:48

Re: Access violation at address 10002593

Postby Izzy » 30. January 2009 15:32

WinMySQLAdmin is useless and deprecated and should not be used or clicked on in the XAMPP Control Panel in the first place - use phpMyAdmin or search for an alternative mentioned many times on the forum.

MySQL in XAMPP uses the my.cnf file in the mysql\bin folder and does not contain a user/pass as this is stored in the MySQL database duly encrypted.

A forum search for access violation will also reveal many fixes for this WinMySQLAdmin and the best solution is simply to delete the my.ini file and never run WinMySQLAdmin again and to remove the shortcut that may have been created from the Windows startup menu.

If you accidentally clicked on the Admin... button in XCP or double clicked on the file in the mysql\bin folder then In the Task Bar right click on the traffic light icon and select Win NT> and remove the service and Shut down the tool will end it's stay and the error messages.

Also if you want a another quick way to get rid of it simply use the Task Manager and end the process.

BTW this is a very old thread and there are more relevant and up to date topics on this subject found using the forum search facility.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Access violation at address 10002593

Postby S0krates » 12. July 2010 14:59

Thanks my problem has been solved.

S0
S0krates
 
Posts: 2
Joined: 24. December 2007 18:44

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests