Apache could not be started

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache could not be started

Postby Elvan » 13. December 2008 11:59

Hey there, lots

I'm trying to run Xampp on my computer, not for actual site publishing but more a way to learn.
I follow this tutorial, because it's the best way to avoid errors, and in the very beginning it says I have to manually activate the Apache, by opening the apache_start.bat

so far so good, but far from started yet. the commandprompt gives me an error which indicates that I'm already using my sockadress for some other application.
I will try to get a as god as possibble translation below.

Code: Select all
Every socketadress <protocol/networkadress/port> can normally only be used once. :make_sock: could not bind to adress 0.0.0.0:80
Unable to open logs

Apache could not be started


If anyone knows how and/or where to change this in a safe way (Idon't like messing with my computer settings) I would be thankfull.
Elvan
 
Posts: 2
Joined: 13. December 2008 11:41

Re: Apache could not be started

Postby Wiedmann » 13. December 2008 12:55

an error which indicates that I'm already using my sockadress for some other application.

You can use e.g. xampp-portcheck, netstat or tcpview to find the (web-) server which is already running on your system.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache could not be started

Postby Elvan » 13. December 2008 15:24

Thanks alot, I scanned for the port and found out Skype was using it (skype uses random free ports) so I closed it down, started the server and opened skype again and now it works.
Elvan
 
Posts: 2
Joined: 13. December 2008 11:41

Re: Apache could not be started

Postby Wiedmann » 13. December 2008 15:31

and found out Skype was using it

Somewhere is the Skype settings you can disable the usage of port 80.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache could not be started

Postby rokhard » 13. December 2008 20:03

I'm having the same problem, but when I use portscan, it says apache is on 80. I've uninstalled and reinstalled xampp. Is it possible that there is a remnant of apache using the port? I dont know how to find it, if so.
rokhard
 
Posts: 5
Joined: 13. December 2008 19:59

Re: Apache could not be started

Postby rokhard » 13. December 2008 20:17

I finally found my solution. I had to uninstall IIS using control panel/add remove programs/add or remove windows components. Thank God I still have a little hair I didnt pull out yet!
rokhard
 
Posts: 5
Joined: 13. December 2008 19:59

Re: Apache could not be started

Postby sayedbhu » 15. December 2008 08:17

Skype did it again! it won't let the apache server to start cuz it probably was hogging the 80 port.
sayedbhu
 
Posts: 1
Joined: 15. December 2008 08:12

Re: Apache could not be started

Postby Sharley » 15. December 2008 08:28

sayedbhu wrote:Skype did it again! it won't let the apache server to start cuz it probably was hogging the 80 port.
Go to Tools>Options>Connections in Skype and un-tick Use port 80 and 443...blah blah and add a port number in Use port 55555 for incoming connections for example, but use a port number you feel good about. ;)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests