Error message that opens over & over & over upon sta

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error message that opens over & over & over upon sta

Postby TAGilliam » 14. November 2008 19:40

Please help. I successfully have XXAMP running on my system and have no problems with the Joomla installation. However, two days ago I was trying to find the MYSql database and opened the Control Panel and double clicked on MYSql Admin ... The following error message popped up and keeps opening over & over again (it won't close and the only way to stop it is to open the Windows Task Manager and end the program). It now opens every time I reboot and does the same thing.

Access violation at address 10009F40 in mode 'LIBMYSQL.dill'. Read of address 0000000. Admin driver 351 not found.

How can I stop this? I obviously have no knowledge at all with XAMPP ... I just got lucky getting it to install and work with no problems!

Thanks.

Tami
TAGilliam
 
Posts: 4
Joined: 12. August 2008 19:57

Postby glitzi85 » 14. November 2008 20:04

Remove the Shortcut from the Startup-Folder in your Start-Menu.

glitzi
User avatar
glitzi85
 
Posts: 1813
Joined: 05. March 2004 23:26
Location: Dahoim

Postby TAGilliam » 14. November 2008 20:17

Thank you so much glitzi85, that solved the problem.
TAGilliam
 
Posts: 4
Joined: 12. August 2008 19:57

Postby pocketchalker » 14. November 2008 22:17

I just did the same thing.....although, when I clicked the admin for mysql I set up a new password. Now mine get's caught in the same loop with the same error.

I don't have anything in my start menu start up folder.

I'm pretty much dead in the water to work on my localhost or my server.

Next idea?

Doug
pocketchalker
 
Posts: 7
Joined: 14. November 2008 22:13

Postby glitzi85 » 14. November 2008 22:48

pocketchalker wrote:I don't have anything in my start menu start up folder.

Somewhere it has to be (if it comes up after Reboot). Look in C:\Document and Settings\%USERNAME%\Start Menu\Programs\Startup for an Shortcut to WinMySQLAdmin. Check the folders of the following users:

Your Username
Administrator
All Users

If you can not find anything there, go to Start -> Run and enter msconfig. Check all Tabs for something that could be related to WinMySQLAdmin.

What OS do you have?

glitzi
User avatar
glitzi85
 
Posts: 1813
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Sharley » 14. November 2008 23:13

Here is another possible solution related to passwords if there is no entries in your startup folders.

Essentially you need to go to the my.ini setup in WinMySQLAdmin change the my.ini by removing the password.

1. Start WinMySQLAdmin
3. click the "my.ini setup" tab
4. find the line with the password
5. delete the second occurrence of "password" (after the "=" sign)
6. click save modifications

The error pop ups should stop.

BTW WinMySQLAdmin is deprecated and should not be used for any meaningful purpose - only a curiosity now and perhaps the link in the XAMPP CP should really be changed to a link to phpMyAdmin.

Use the preferred GUI phpMyAdmin instead for all things MySQL related or search these forums for a possible alternative from the MySQL web site.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby pocketchalker » 14. November 2008 23:21

This is gonna sound so rookie like....but how do I start

WinMySQLAdmin?

Is that going to be

http://localhost/xampp/ ?

update...

Duh...No...

I'll be back
Last edited by pocketchalker on 14. November 2008 23:24, edited 1 time in total.
pocketchalker
 
Posts: 7
Joined: 14. November 2008 22:13

Postby Sharley » 14. November 2008 23:23

Easiest solution is to start it from the XAMPP Control Panel - click on Admin next to the MySQL button, you may then have to right click on the traffic lights icon in the system tray and select Show me.

This will also start MySQL as a service and would need to be stopped in the CP by removing the tick in the Svc box if not required.
Last edited by Sharley on 14. November 2008 23:29, edited 1 time in total.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby pocketchalker » 14. November 2008 23:26

Ok...


I found the startup in the msconfig....killed it and rebooted.

Started up xampp and clicked the admin on the sql and it goes into the loop again

Now what?
pocketchalker
 
Posts: 7
Joined: 14. November 2008 22:13

Postby pocketchalker » 14. November 2008 23:28

Here's something else I'm not totally understanding....

Running things as a service?

What's the difference? I can run sql not as a service and all is ok... until click admin, then it switches it to a service, shows me the large popup of settings but before I can click anything it pops off and goes into the loop and shows it in service mode. Then I have to kill it through the processes
pocketchalker
 
Posts: 7
Joined: 14. November 2008 22:13

Postby pocketchalker » 14. November 2008 23:32

glitzi85 wrote:What OS do you have?

glitzi


XP SP3
pocketchalker
 
Posts: 7
Joined: 14. November 2008 22:13

Postby pocketchalker » 14. November 2008 23:38

Ok....got the password deleted and the popups stopped....

The reason I got into this mess was because I"m trying to make my localhost writable. I'm connecting to my host with FZilla but as an anonymous user. I know I need to log in as admin but somethings goofy with the password. How do I reset it?

Thanks for the help
I do appreciate it.
Doug
pocketchalker
 
Posts: 7
Joined: 14. November 2008 22:13

Postby pocketchalker » 14. November 2008 23:44

I think I'm in the right area but a little lost....

phpMyAdmin/database/jos_users...

Now what?
----------------------------------------------------


Image
pocketchalker
 
Posts: 7
Joined: 14. November 2008 22:13

Postby Sharley » 15. November 2008 00:00

Use the traffic light icon to Hide and Win NT>Shut down this tool to close it not the useual X in the top Windows title bar. Then remove the tick in the Svc box in the CP.

Check your startup folders again for any WinMySQLAdmin entries and remove.

Once all clear try not to use this deprecated admin tool again - or at least follow the above methods for controlling it.

pocketchalker wrote:Running things as a service?
What's the difference?
The difference between running as a service and not running as a service is, as a service it will start on booting the PC, running not as a service you would start MySQL manually from the CP or the bat files in the XAMPP folder.

pocketchalker wrote:...somethings goofy with the password. How do I reset it?
If you want to change the MySQL password then use the Security page in the XAMPP Welcome page at http://localhost then click on this link http://localhost/security/xamppsecurity.php

If FileZilla click on the FileZilla link in the Welcome page for some possible help.

pocketchalker wrote:phpMyAdmin/database/jos_users...
Now what?
AFAIK this should be from within Joomla as the passwords will be encrypted when placed in the database by Joomla.
Try and find in the Joolma config where you would add and/or change the user's passwords.

To view individual users select Browse from the top menu when in the page you have in your image above.

Doug wrote:The reason I got into this mess was because I"m trying to make my localhost writable. I'm connecting to my host with FZilla but as an anonymous user. I know I need to log in as admin but somethings goofy with the password. How do I reset it?
We seem to have slipped off topic now - perhaps to continue with this you may wish to start a new thread. ;)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests