New XAMPP version for Linux, Windows, and Mac OS X

Announcements and news about XAMPP and the Apache Friends project.

New XAMPP version for Linux, Windows, and Mac OS X

Postby Oswald » 12. February 2008 18:57

In all versions we updated Apache to 2.2.8, PHP4 to 4.4.8 and phpMyAdmin to 2.11.4. The Linux and Mac OS X versions contain also updated Perl (5.10.0) and MySQL (5.0.51a) releases.

Get the downloads and more details on the specific platforms XAMPP project page.
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby MiCerv » 26. February 2008 18:23

Do you know something about the run time bug in XAMPP 1.6.6.

I am trying to run PBooks on XAMPP 1.6.6 but it looks like something in XAMPP is broken.

http://www.pbooks.org/wiki/PBooks_Insta ... and_Ubuntu

XAMPP Problems

XAMPP version 1.6.6. cannot run PBooks due to a basic bug in their setup. I don't have the time to diagnose it properly, but I believe it has something to do with PHP, XSL, and threading.

[Tue Feb 26 11:03:01 2008] [notice] child pid 12174 exit signal Segmentation fault (11)

It's too bad because it fails on a very basic XSL transformation.


http://www.pbooks.org/forums/viewtopic.php?pid=101#p101

I installed xampp and have diagnosed the problem as a segmentation fault. Fortunately, the problem isn't caused by PBooks, but I have no idea what the problem is in the Xampp setup. I believe it has something to do with using the php module on the apache worker mpm - while php is threadsafe, its extensions are not.
MiCerv
 
Posts: 9
Joined: 15. December 2007 22:38

Postby Oswald » 26. February 2008 18:33

Hi MiCerv!

Thanks for pointing at that issue. I'm not the Windows expert and forward your post to our Windows guru Kay. He's currently in charge of XAMPP's Windows version and he should be the one who know most about this problem.

Greetings
Oswald

PS: I know there is an Windows 1.6.6a release out for some days, maybe this version fixes these problems...
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby MiCerv » 26. February 2008 19:10

Hello Oswald !

I itself personally have installed XAMPP on Ubuntu Linux in /opt.

I have just now prooved my XAMPP Logs in /opt/lampp/logs/error_log and
i have the segmentation faults also.

Remember i am using XAMPP for LINUX.

Here a example

[Tue Feb 26 12:14:59 2008] [notice] child pid 8657 exit signal Segmentation fault (11)
[Tue Feb 26 12:14:59 2008] [notice] child pid 8665 exit signal Segmentation fault (11)
[Tue Feb 26 12:15:31 2008] [notice] child pid 8682 exit signal Segmentation fault (11)
[Tue Feb 26 12:22:35 2008] [warn] child process 8662 still did not exit, sending a SIGTERM
[Tue Feb 26 12:22:35 2008] [warn] child process 8663 still did not exit, sending a SIGTERM
[Tue Feb 26 12:22:35 2008] [warn] child process 8664 still did not exit, sending a SIGTERM
[Tue Feb 26 12:22:35 2008] [warn] child process 8681 still did not exit, sending a SIGTERM
[Tue Feb 26 12:22:35 2008] [warn] child process 8683 still did not exit, sending a SIGTERM
[Tue Feb 26 12:22:37 2008] [warn] child process 8662 still did not exit, sending a SIGTERM
MiCerv
 
Posts: 9
Joined: 15. December 2007 22:38

Postby MiCerv » 26. February 2008 19:13

If you want itself to proove it here is how to setup PBooks

http://www.pbooks.org/svn/pbooks/misc_p ... nk/INSTALL
MiCerv
 
Posts: 9
Joined: 15. December 2007 22:38

Postby Oswald » 26. February 2008 20:21

Hi MiCerv!

I found the problem - an outdated XSLT library - and put a new XAMPP version together. You can get it here: http://www.apachefriends.org/en/xampp-beta.html

There is also an upgrade package (xampp-linux-upgrade-1.6.6-1.6.6a.tar.gz around 164KB) which you can use to upgrade your 1.6.6 installation.

Thanks a million for reporting the problem, I hope it's solved now.

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby MiCerv » 26. February 2008 23:54

Hello Oswald !

PBooks load now without any problems on XAMPP !

For some reason however i am still getting in the error_log File
"SIGTERM" Warnmessages together with a SIGTERM SHUTDOWN !

[Tue Feb 26 23:28:19 2008] [warn] child process 9352 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:20 2008] [warn] child process 9353 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:20 2008] [warn] child process 9354 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:20 2008] [warn] child process 9355 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:20 2008] [warn] child process 9356 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:20 2008] [warn] child process 9361 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:20 2008] [warn] child process 9362 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:20 2008] [warn] child process 9434 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:21 2008] [warn] child process 9352 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:21 2008] [warn] child process 9353 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:21 2008] [warn] child process 9354 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:21 2008] [warn] child process 9355 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:21 2008] [warn] child process 9356 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:21 2008] [warn] child process 9361 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:21 2008] [warn] child process 9362 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:21 2008] [warn] child process 9434 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:23 2008] [warn] child process 9434 still did not exit, sending a SIGTERM
[Tue Feb 26 23:28:25 2008] [error] child process 9434 still did not exit, sending a SIGKILL
[Tue Feb 26 23:28:26 2008] [error] could not make child process 9434 exit, attempting to continue anyway
[Tue Feb 26 23:28:26 2008] [notice] caught SIGTERM, shutting down


Thank you a lot for your fast and very professional fix
You are doing a great Job !
MiCerv
 
Posts: 9
Joined: 15. December 2007 22:38

Postby Oswald » 27. February 2008 08:12

Hi MiCerv!

Great. :)

But concerning the SIGTERM warnings I've no idea. On my system anything runs well:

Code: Select all
[Wed Feb 27 07:06:44 2008] [notice] Apache/2.2.8 (Unix) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8e PHP/5.2.5 mod_apreq2-20051231/2.6.0 mod_perl/2.0.2 Perl/v5.10.0 configured -- resuming normal operations
[Wed Feb 27 07:07:34 2008] [notice] caught SIGTERM, shutting down


Does anyone else get these SIGTERM warings during Apache's shutdown?

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby MiCerv » 27. February 2008 17:52

Oswald wrote:Does anyone else get these SIGTERM warings during Apache's shutdown?


Google search show more than 19'300 results.

http://www.google.ch/search?q=child+pro ... rt=10&sa=N

together with xampp 575 search results

http://www.google.ch/search?hl=de&q=xam ... uche&meta=

I am wondering if this could be maybe related to the programms that are installed in htdocs.

I simple pure install of xampp should answer this question.

I will report back if i have this error messages with a pure xampp install.

Till later MiCerv.
MiCerv
 
Posts: 9
Joined: 15. December 2007 22:38

Do you have a plan to release x64 version?

Postby hanpedro » 03. March 2008 03:54

Do you have a plan to release x64 version?

On x64 machine, I have errors and apache freezing sometimes.
So, I am waiting for x64 version of xampp.
hanpedro
 
Posts: 125
Joined: 09. February 2005 06:03
XAMPP Version: 5.6.3
Operating System: SCientific Linux 6.1 x86

Postby ligaard » 06. March 2008 17:37

The 1.6.6a packages solves my libxslt problem, see http://community.apachefriends.org/f/viewtopic.php?p=116644.

Thank you for this wonderful piece of software :D
ligaard
 
Posts: 3
Joined: 13. February 2008 20:12

Postby ivanusto » 22. May 2008 02:59

Hi, Oswald,

Would you upgrade xampp with PHP 5.2.6 ?
User avatar
ivanusto
 
Posts: 4
Joined: 22. May 2008 02:56
Location: Taipei, Taiwan

Yes please upgrade php

Postby bmcgehee » 13. June 2008 14:47

Please upgrade php or tell us idiots how to do it manually.

thanks!
bmcgehee
 
Posts: 1
Joined: 13. June 2008 14:44

Postby north » 27. October 2008 15:51

Does anyone know how to get the XAMPP 1.6.6a packages for Linux? I have encountered a problem with the libxslt and I would like to use 1.6.6a rather than trying to update to a newer version due to other modules that need to be recompiled.

It does not appear that the 1.6.6a packages are available on sourceforge. Any thoughts on why they are not there or where they may be?

north
north
 
Posts: 3
Joined: 27. October 2008 15:42

Postby ivanusto » 01. December 2008 05:16

Hi, Oswald,

Would you upgrade xampp with Apache 2.2.10 ?
User avatar
ivanusto
 
Posts: 4
Joined: 22. May 2008 02:56
Location: Taipei, Taiwan

Next

Return to Announcements and news

Who is online

Users browsing this forum: No registered users and 0 guests