Problem with PHP5 XSLTProcessor in 1.6.6 (worked in 1.6.5a)

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Problem with PHP5 XSLTProcessor in 1.6.6 (worked in 1.6.5a)

Postby ligaard » 13. February 2008 20:20

When using the XSLTProcessor's importStylesheet() function in 1.6.6, then is get a popup asking if I want to download. This is wierd, since the function does not output anything!

The problem only happens if there are XPath expressions with constraints on attribute values.

I have four small files reproducing the error, shown here: http://www.daimi.au.dk/~ligaard/2008/02/13/problem-with-xampp-166-and-xsltprocessors-importstylesheet-if-constraints/.

Has anybody else has had these problems?

As mentioned in Subject, it works in Xampp 1.6.5a.

PS: Is this place is the right place to ask? :roll:
ligaard
 
Posts: 3
Joined: 13. February 2008 20:12

Postby ligaard » 06. March 2008 17:36

This is fixed in the 1.6.6a packages (which has an updated libxslt). See also http://community.apachefriends.org/f/viewtopic.php?t=28493.
ligaard
 
Posts: 3
Joined: 13. February 2008 20:12


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 13 guests