Can't install XAMPP on Vista. Port 80 already in use

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't install XAMPP on Vista. Port 80 already in use

Postby joejoefla » 22. February 2008 22:00

Hi everyone,

I currently run Vista Home Premium with no other webserver software instaleld on the machie. I have the firewall completely off and run ESET NOD32 antivirus.

What's happening now is when I try to install xampp everything goes fine until apache tries to install itself as a service. This is when I get an error stating "Port 80 or 443 is already in use. Installation failed!" I'm trying to host a webserver locally and view the webpage locally by accessing http://localhost and

What's strange is I tried to scan my loopback and didn't find port 80 open. I haven't tried to install this on XP but I have high certainty that it's something with my PC and Vista.

Thanks for the help all.
Posts: 1
Joined: 22. February 2008 21:17

Postby Izzy » 23. February 2008 00:05

When Logged into Vista as an administrator, right click on .\xampp\xampp-portcheck.exe select to 'run as administrator' and this little tool will tell you what is using the ports that XAMPP needs exclusively - they should be Free or occupied by one of XAMPP's modules.

The culprits are usually IIS (a Windows web server running by default) and or Skype and possibly some other IM software.

You will need to configure this other software to use alternative ports or prevent them from loading as a service in the first place, or else XAMPP's modules will not be able to function as intended.
Posts: 3344
Joined: 25. April 2006 17:06

Postby kbishop » 27. February 2008 20:47

Or you can go into DOS and do a netstat -ano and hit enter. Then scroll up and see what PID # is using port 80. Then, open up your Task Manager (Ctl, Alt, Dlt) and go to the Services tab. Compare your PID # from DOS to that in the Services tab to figure out which is occuring. Mine also was the Default Web Site that I had to stop.

Acutally, now that I think about it, my default web site didn't show up in Services either. To find out, right click Computer and go to Manage. Once in there, go down to Services and Applications and expand Internet Information Services (IIS) Manager. Expand that until you see the Web Sites folder. Click on that and it will tell you if Default Web Site is running or not. If it's running, right click on it and hit stop. Hope this helps!!!
Posts: 2
Joined: 27. February 2008 18:40

Re: Can't install XAMPP on Vista. Port 80 already in use

Postby mdgnavyf » 24. August 2009 01:00

I've spent hours on this. Just bought new Toshiba Laptop.

TURN OFF SKYPE !!!!!!!!!!!!!!!!!!!
Posts: 1
Joined: 24. August 2009 00:56

Re: Can't install XAMPP on Vista. Port 80 already in use

Postby Izzy » 24. August 2009 01:16

mdgnavyf wrote:I've spent hours on this. Just bought new Toshiba Laptop.

TURN OFF SKYPE !!!!!!!!!!!!!!!!!!!
No need to disable Skype just change the ports that it uses.

Skype uses ports 80 and 443 by default.

You can alter that behavior by going to:

Use port 80 and 443 as alternative for incoming connections

You will have to decide a different port to use for incoming connections before Skype lets you save your changes.

Use ports between 49152 through 65535.

Some others have had success by starting Apache before starting Skype then Skype has to use ports other than 80/443.
Posts: 3344
Joined: 25. April 2006 17:06

Re: Can't install XAMPP on Vista. Port 80 already in use

Postby kekkaishi » 23. December 2010 14:22

if u have sql server 2008 r2 installed, sql server reporting service may use port 80. u might first wanna stop it through service manager.
Posts: 1
Joined: 23. December 2010 14:16

Re: Can't install XAMPP on Vista. Port 80 already in use

Postby cluesmayhem » 15. April 2011 16:38

I've got solution from website it worked (thanks to aulia rahman)
Basically to do is like this:
1. locate httpd.conf, example is D:\xampp\apache\conf\httpd.conf
A. look for words “Listen 80″ and change into “Listen 8080″
B. look for words “ServerName localhost:80″ and change into “ServerName localhost:8080″
C. Save the file
2. locate httpd-ssl.conf, example is D:\xampp\apache\conf\extra\httpd-ssl.conf
A. look for words ““Listen 443″ and change into ““Listen 4499″
B. look for words “<VirtualHost _default_:443>″ and change into “<VirtualHost _default_:4499>″
C. look for words “ServerName localhost:443″ and change into “ServerName localhost:4499″
D. Save the file
3. then start the XAMPP control panel, should be worked,
4. if you want to access localhost, the new link is localhost:8080/, example you want open phpmyadmin, then http://localhost:8080/phpmyadmin/
Posts: 1
Joined: 15. April 2011 16:25

Re: Can't install XAMPP on Vista. Port 80 already in use

Postby Sharley » 16. April 2011 02:58

That solution is posted in these forums hundreds of times and is found by Advanced forum searching.

That solution is fine if you always want to add the port number at the end of the domain name, but the correct solution is to take control of the situation by locating what is using the ports that XAMPP requires for it's servers and then disable the conflicting servers (Listeners) so you don't have this conflict.

You can use the built in xampp-portcheck.exe file in older versions or use this little free non install app. currports from here. which is the backbone of the previous versions port check utility:

However if you have ascertained what the conflicting listener is and have decide you simply can't be changing it's ports then by all means have the inconvenience associated with having to add the port number to the URI that Apache will read.

BTW port 8080 will conflict with Apache Tomcat if you want to be able to use this XAMPP Java feature.
User avatar
AF Moderator
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.14
Operating System: Win 7 Pro 32bit/XP Pro SP3

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 28 guests