Perl und Apache

Alles, was Perl betrifft, kann hier besprochen werden.

Perl und Apache

Postby TheDarkFreak » 12. February 2008 13:06

Hallo alle zusammen,

kann mir hier vlt. einer helfen? Ich bin langsam am verzweifeiln. Ich bekomme PERL und Apache nicht zusammen am laufen *cry*

Kann mir vlt. einer seine Config auschnitte schicken oder soetwas?

Ich habe jetzt das Module CGI geladen:
LoadModule cgi_module modules/mod_cgi.so


Dann habe ich eine Scriptweiterleitung auf den Ordner cgi-bin erstellt:
ScriptAlias /cgi-bin/ "D:/Webserver/Apache Server/cgi-bin/"


die Directory Direktive erstellt:
<Directory "D:/Webserver/Apache Server/cgi-bin">
AllowOverride None
Option ExecCGI
Order allow,deny
Allow from all
</Directory>


Wenn ich nun in meinen Browser http://192.168.2.60/cgi-bin/printenv.pl eintippe bekomme ich den Error Code 500!

Was kann ich noch tun? Ich bin hier echt am verzweifeln *cry*

Vielen dank im vorraus für eure hilfe!
mfg TDF
Das Leben ist ein scheiß Spiel, hat aber eine super Grafik!
TheDarkFreak
 
Posts: 52
Joined: 01. July 2007 10:22

Postby Wiedmann » 12. February 2008 13:13

Wenn ich nun in meinen Browser http://192.168.2.60/cgi-bin/printenv.pl eintippe bekomme ich den Error Code 500!

Was kann ich noch tun?

Ins "error.log" deines Apachen schauen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby TheDarkFreak » 12. February 2008 13:42

okay anderes Problem...
Der Server startet nun nicht mehr und in den Logs wird darübern icht berichtet.

BZW. die Logs werden nicht erstellt, da ich sie gelöscht habe (Shutdown_Löschen_Booten bootet nicht =( )


Okay ich mache es jetzt anders.
Ich haue jetzt alles aus meiner Config raus was mit Perl zu tun hat. Und versuche es dann neu.

Könnt ihr mir denn sagen, wie ich das machen muss?
Da ich das noch NIE gemacht habe kriege ich das auch nicht hin...
SQL und PHP kann ich mittlerweile im Schlaf installieren, weil ich es schon 100mal gemacht habe =(


Bitte helft mir!


EDIT:
Ist Perl als Modul leichter zu installieren?
Last edited by TheDarkFreak on 12. February 2008 15:19, edited 1 time in total.
Das Leben ist ein scheiß Spiel, hat aber eine super Grafik!
TheDarkFreak
 
Posts: 52
Joined: 01. July 2007 10:22

Postby TheDarkFreak » 12. February 2008 15:14

Okay neues Update, meine Config schaut nun so aus:


LoadModule cgi_module modules/mod_cgi.so

ScriptAlias /cgi-bin/ "D:/Webserver/Apache Server/cgi-bin/"
<Directory "D:/Webserver/Apache Server/cgi-bin">
AllowOverride None
Options +ExecCGI -Includes
Order allow,deny
Allow from all
</Directory>


AddHandler cgi-script .cgi .pl .exe .bat



Wenn ich nun http://192.168.2.60/cgi-bin/printenv.pl in den Browser eingebe, zeigt er mir den Quellocode von der Datei an:

Code: Select all
#!perl
##
##  printenv -- demo CGI program which just prints its environment
##

print "Content-type: text/plain\n\n";
foreach $var (sort(keys(%ENV))) {
    $val = $ENV{$var};
    $val =~ s|\n|\\n|g;
    $val =~ s|"|\\"|g;
    print "${var}=\"${val}\"\n";
}


Eine Fehlermeldung erhalte ich auch nicht...
Habe Apache runtergefahren die Log gelöscht, Apache hochgefahren, auf die Datei zugegriffen, und die Log hier reinkopiert.
Code: Select all
[Tue Feb 12 15:16:50 2008] [notice] Apache/2.2.6 (Win32) PHP/5.2.5 configured -- resuming normal operations
[Tue Feb 12 15:16:50 2008] [notice] Server built: Sep  5 2007 08:58:56
[Tue Feb 12 15:16:50 2008] [notice] Parent: Created child process 3840
[Tue Feb 12 15:16:50 2008] [notice] Child 3840: Child process is running
[Tue Feb 12 15:16:50 2008] [notice] Child 3840: Acquired the start mutex.
[Tue Feb 12 15:16:50 2008] [notice] Child 3840: Starting 64 worker threads.
[Tue Feb 12 15:16:50 2008] [notice] Child 3840: Starting thread to listen on port 80.




Bin ich jetzt einen Schritt weiter?
Das Leben ist ein scheiß Spiel, hat aber eine super Grafik!
TheDarkFreak
 
Posts: 52
Joined: 01. July 2007 10:22

Postby Wiedmann » 12. February 2008 16:15

zeigt er mir den Quellocode von der Datei an:

Das ist mir gerade nicht so klar...

#!perl

Wo ist denn dein Perl installiert? Bzw., befindet sich die "perl.exe" im System PATH?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby TheDarkFreak » 12. February 2008 22:42

Zitat:
zeigt er mir den Quellocode von der Datei an:

Das ist mir gerade nicht so klar...

Zitat:
#!perl


:shock: :shock: :shock:
Ähm wie meinst du das?


Die Perl.exe sollte drin sein...
Guck mal bitte ich bin mir nicht sicher...

http://robertoonline.ro.funpic.de/tut_bilder/path.JPG
Das Leben ist ein scheiß Spiel, hat aber eine super Grafik!
TheDarkFreak
 
Posts: 52
Joined: 01. July 2007 10:22

Re: Perl und Apache

Postby jan_ » 24. November 2009 10:31

Ich versuche mich zum ersten Mal an der Integration von Perl in Apache und bekomme das leider nicht zum laufen.

httpd.conf:
Code: Select all
AddHandler cgi-script .cgi .pl
ScriptAlias /cgi-bin/ "/var/www/cgi-bin"

<Directory "/var/www/cgi-bin">
   AllowOverride None
   Options None
   Order allow,deny
   Allow from all   
</Directory>


cgi Module habe ich wie folgt aktiviert:
Code: Select all
$sudo a2enmod cgi
Your MPM seems to be threaded. Selecting cgid instead of cgi.
Module cgid already enabled
$sudo a2enmod cgid
Module cgid already enabled


/var/www/first.pl:
Code: Select all
#!/usr/bin/perl
print "Content-type: text/html\n\n";
print "Hello, World.";


Aufruf im Browser führt zu einer not found Fehlermeldung:
Code: Select all
Not Found
The requested URL /cgi-bin/cgi_var.pl was not found on this server.


Apache error.log:
Code: Select all
[Tue Nov 24 11:57:20 2009] [error] [client 172.16.182.1] script not found or unable to stat: /usr/lib/cgi-bin/cgi_var.pl
[Tue Nov 24 11:57:20 2009] [error] [client 172.16.182.1] File does not exist: /var/www/favicon.ico, referer: http://172.16.182.128/cgi-bin/cgi_var.pl
[Tue Nov 24 12:08:48 2009] [notice] caught SIGTERM, shutting down


Bitte um Hilfe!
Danke
jan_
 
Posts: 1
Joined: 24. November 2009 10:15


Return to Perl

Who is online

Users browsing this forum: No registered users and 0 guests