Access violation at address 10002593

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Access violation at address 10002593

Postby S0krates » 24. December 2007 19:01

Hallo Freunde, ich brauch unbedingt mal eure Hilfe. Ich hab grad XAMPP unter Windows Vista (32Bit) installiert. Es läuft auch alles soweit, Apache ist da, bis auf folgendes: Wenn ich auf das Control Panel gehe und bei MySql auf "Admin" klicke, geht die box kurz auf und wieder zu und dann geht es rund auf meinem desktop, denn dann kommt permanent diese Warnung hoch: Access violation at address 10002593 in module 'LIBMYSQL.dll' Read of address 0000000.

Was ist das und wie kann ich das abstellen? Ist extrem nervig, es kommt nun nach jedem booten. Ich bin kein Experte auf diesem Gebiet und hoffe mir kann jemand helfen. ich wäre wirklich sehr dankbar.

Das komische ist, die Datenbank läuft eigentlich, das Ganze tritt nur auf wenn ich in den Admin-Bereich der Datenbank will. Dann kommt dieser komische Mysql Admin 1.4 hoch (dieses Ampel-Icon) und sendet permanent diese Fehlermeldung. Ich wäre wirklch für Hilfe dankbar, denn ich weiß nicht woran es liegen könnte und müsste ja so das ganze Wampp wieder deinstallieren.

S0
S0krates
 
Posts: 2
Joined: 24. December 2007 18:44

Same here

Postby DVerhaaff » 26. December 2007 23:12

Sorry for not replying in German, I can read and write it but not good enough to express my problems. I'll probably confuse you all if I attempt that.

I've got the same problem, installed XAMPP in Windows 2000 and everything ran just fine.
Then on the next reboot of the sytem I'm getting the darn "access violation at address 10002593 in module 'LIBMYSQL.dll'. Read of address 00000000" message popping up over and over again.
Even when I stop the MySql service in the XAMPP panel the messages keep on coming about one every 4 seconds.
I right-click the traffic-light in the list of running programs and choose "shutdown this tool" and everything works fine again after starting up the MySql service in the XAMPP control panel.

Anybody have any clue as to what can be wrong?
I'd like to be able to use my server computer without having to go through all that trouble after each startup.
DVerhaaff
 
Posts: 1
Joined: 26. December 2007 22:56

Bei mir auch

Postby battpaul » 29. December 2007 18:39

Habe das auch, unter XP SP2. Scheint ein Bug zu sein. Einzige Möglichkeit, die ich sehe ist, mysql nicht als Service zu betreiben und das Admin Tool nicht zu benutzen.
-Paul
battpaul
 
Posts: 1
Joined: 29. December 2007 17:54

Postby bambam » 29. December 2007 18:52

Here the same error, and i'm also having windows 2000 (UK/USA languige) with service pack 4

I have done all windows updates

It's a clean windows install + only Xampp installer
bambam
 
Posts: 1
Joined: 29. December 2007 18:47

Postby angel-girl » 30. December 2007 19:02

I am having the same problem. Thanks for the tip on clicking the stoplight, I wouldn't have been able to get it to stop otherwise. I have gone so far as to uninstall xampp, and it still persisted. The stoplight stopped it for now, but I'm wondering if it will happen again next time I restart. This is annoying.
angel-girl
 
Posts: 1
Joined: 30. December 2007 18:59

Postby s-byte » 31. December 2007 17:39

LÖSUNG:
Im Autostart (Start-Programme-Autostart) einfach den Link auf winmysqladmin löschen.
Fertig.
s-byte
 
Posts: 3
Joined: 31. December 2007 17:21

Same "access violation" of 10002593 in mysql

Postby tracyleerose » 02. January 2008 04:20

Has anyone found the solution for this?

Mine only stops this violation dialog from popping up when I shut down mysql from the console.


Help,
Tracy (tracy.rose@comcast.net)
tracyleerose
 
Posts: 2
Joined: 02. January 2008 04:16

Postby asafadi » 03. January 2008 13:19

This is ridiculous!

I'm also having the same exact problem (so I won't go into detail). I'm using Windows Vista Ultimate (64-bit).

Please help! If one of our German friends finds the answers, I'd REALLY appreciate a translation.


Thank you!
asafadi
 
Posts: 3
Joined: 03. January 2008 13:10
Location: Charlotte, NC, USA

access violation of 10002593 in mysql

Postby faqltet » 03. January 2008 20:25

s-byte wrote solution :)


START >> PROGRAMS >> AUTOSTART and remove WinMySQLAdmin :)

It works! I had same problem, now it's gone!
faqltet
 
Posts: 1
Joined: 03. January 2008 20:21
Location: P O L A N D

Postby tracyleerose » 04. January 2008 00:40

Bummer as this doesn't help me. I have nothing left in the Autostart (msconfig) after unchecking it....nor was anything in the 'Startup' folder. I'm still getting the "LIBMYSQL" read at address 00000000.

Thanks for trying. This package looks so smooth that I'm hoping we find a fix. :?
tracyleerose
 
Posts: 2
Joined: 02. January 2008 04:16

Postby burrows1980 » 06. January 2008 15:38

Has anyone found out why this is creating a problem?

Had the same problem on mine. Would like to know whats causing it, and what effects its having on MySQL if any?

Thanks in advance,

Gaz
burrows1980
 
Posts: 2
Joined: 06. January 2008 15:35
Location: North Wales (UK)

Postby LeMirque » 07. January 2008 17:59

Bei mir wurde das Problem auch nicht gelöst auf diese Weise. Noch jemand irgendeine andere Idee, woran das liegen könnte? Autostart is sauber. :(
LeMirque
 
Posts: 2
Joined: 07. January 2008 17:45

Postby LeMirque » 07. January 2008 18:46

Merkwürdig. Das Problem hat sich anscheinend von selbst gelöst... :?: :?:

Das einzige, was ich gemacht habe, seitdem der Fehler auftrat, war dieses "dumprep" aus dem Systemstart zu nehmen.
Ich als "noob" weiß aber nicht, ob da ein Zusammenhang besteht. Dachte nur, es kann ja nicht schaden, das mal mitzuteilen ;-)

Falls es jemand ausprobieren will, so kann man dieses dumprep-Dingsi ausschalten:

"Used in connection with memory dumps - you can disable these by - right clicking on My Computer, selecting Properties and then the Advanced tab. Click on the Settings button in 'Startup and Recovery'. In the bottom pane - under 'Write debugging information' - click on the down arrow and then select 'None' - "

(Oder auf deutsch: systemsteuerung -> system -> erweitert -> Einstellungen zu "Starten und wiederherstellen" -> Debuginformationen speichern -> "Keine" auswählen)



Kann irgendjemand, der sich auskennt, bestätigen oder dementieren, dass der von mir gemutmaßte Zusammenhang besteht?

mfg,
LeMirque
LeMirque
 
Posts: 2
Joined: 07. January 2008 17:45

Postby djpentz » 08. January 2008 18:45

I posted this on another thread, but repeating it here. Sorry, I don't know German at all, so I'm replying in English. :-)

I think I've found the solution. Ignore the dialog box popping up every 10s or so, and open up winmysqladmin. There's a tab 'my.ini Setup'. Go there.

You'll find the contents of the my.ini file in a textarea and at the bottom it indicates:

user=root
password=password

Now this is the first time I've installed XAMPP, so I don't know what it did before but I noticed MySQL installs with a default of 'root' and NO password. You can test this by removing the password so that your entries now say:

user=root
password=

And then click the Save Modifications button. This *should* stop the popups. If it does you've got 2 options:

1. Leave it like that and continue with root and no password (which I think is bad)
2. Leave winMySQLAdmin like it is, and rather go and change MySQL to have root and password of 'password'. At any rate there should be SOME password.

- Darryl Pentz
djpentz
 
Posts: 2
Joined: 08. January 2008 18:21

Postby burrows1980 » 08. January 2008 20:56

Top Banana!

Give that man a prize! finally no more stupid windows!!

Cheers Darryl,

Gaz
burrows1980
 
Posts: 2
Joined: 06. January 2008 15:35
Location: North Wales (UK)

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests