Deutscher Zeichensatz

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Deutscher Zeichensatz

Postby Maurizio » 09. September 2003 15:00

Um eine deutsche Sortierreihenfolge zu erhalten,
startet man mysqld mit --default-character-set=latin_de.

http://www.mysql.de/doc/de/German_character_set.html

Wie bitte kann ich das bei XAMPP für Linux realisieren?
Maurizio
 

Postby Oswald » 16. September 2003 14:01

Hallo Maruizio!

Am einfachsten ist es, wenn Du es in die Konfigurationsdatei von MySQL schreibst.

Also die Datei /opt/lampp/etc/my.cnf um folgende Zeile erweiterst:

set-variable = default-character-set=latin1_de

Und zwar nicht an einer beliebigen Stelle sondern genau dort wo auch schon ein paar Zeilen mit set-variable stehen (Zeile 30-35). Da irgendwo hinzufügen.

Nach dem Ändern, dann MySQL neu starten.

Achtung: Es heisst latin1_de und nicht nur latin_de! (Ist tatsächlich ein Fehler in der MySQL-Doku)

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Maurizio » 17. September 2003 16:00

Hallo Kai,

habe exakt diesen Eintrag in der my.cnf hinzugefügt (ja, habe auch latin1_de geschrieben :wink:) und MySQL neu gestartet.
Leider klappt es aber immer noch nicht :(

Habe übrigens XAMPP 1.2 für Linux laufen - kann es hier dran liegen?
Maurizio
 

Postby Oswald » 17. September 2003 16:24

Huhu Maurizio!

Hast Du es auch in die /opt/lampp/etc/my.cnf eingetragen und nicht in irgend eine andere my.cnf?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Maurizio » 18. September 2003 11:02

Und nochmal Hallo,

habe es exakt in dieser my.cnf eingetragen (Zeile 36: set-variable = default-character-set=latin1_de).
MySQL habe ich auch neu gestartet.

Habe fast die Befürchtung, dass MySQL hierzu neu kompiliert werden muss :?:
Maurizio
 

Postby Oswald » 18. September 2003 11:12

Hallo Maurizio!

Ich habs grad mal ausprobiert. Bei mir geht es einwandfrei. Die Zeile rein in die my.cnf und er sortiert die Umlaute richtig. Zeile raus und er sortiert die Umlaute nach 'z' ein. Perfecto!

Ich habs mit der Demo-CD-Verwaltung vom XAMPP getestet. Einfach folgende Interpreten reingesetzt:

Hämmer
Hadmer
Haffner

Mit der Zeile sortiert er so:

Hadmer
Hämmer
Haffner

Ohne die Zeile so:

Hadmer
Haffner
Hämmer

Genau wie man es erwartet.

Wie sieht es denn bei Dir aus?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Maurizio » 07. October 2003 09:06

Olá,

da bin ich nochmal. Bin unerwartet und spontan zwei Wochen in Urlaub gewesen - daher konnte ich mich so lange nicht melden.

However: Dir korrekte Sortierung funktioniert immer noch nicht. Trage ich die entsprechende Zeile in die my.cnf sortiert er bei mir, wie bei Dir ohne die Zeile. Es macht also keinen Unterschied ob die Zeile in der my.cnf eingetragen ist oder nicht :(
Maurizio
 

Postby Oswald » 07. October 2003 09:57

Huhu Marurizio!

Hey, ich hoffe Dein Spontanurlaub war bestens. Hätt ich auch gerne! ;)

Okay, kannst Du mein Beispiel mit der Demo CD-Verwaltung bitte mal bei Dir probieren? Oder kannst Du hier mal das SELECT-Statement posten, das bei Dir nicht funktioniert? Mit dem CREATE der Tabelle? Dann kann ich es hier auch mal ausprobieren.

Aber wie gesagt: Bei mir funktioniert es genau wie in der Anleitung von MySQL beschrieben. An MySQL wird es also nicht liegen! ;)

Kannst Du bitte mal ps -aux | egrep mysql aufrufen und die Ausgabe hier posten!

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Maurizio » 07. October 2003 13:57

Hmmm... das ist interessant:

Mit der Demo CD-Verwaltung funktioniert die Sortierung einwandfrei. Nur unsere hinzugefügte DB sortiert nicht richtig. Habe immer PHPMyAdmin genutzt um die Sachen zu testen; Tabellentypen sind jeweils auch identisch. Scheint wohl ein Datenbankproblem zu sein - nur wo? :shock:

ps aux | egrep mysql gibt folgendes aus:

Code: Select all
root     10060  0.0  0.2  4692 1232 pts/0    S    14:20   0:00 /bin/sh /opt/lampp/bin/mysqld_safe --datadir=/opt/lampp/var/mysql --pid-file=/opt/lampp/var/mysql/lx12.pid
nobody   10085  0.0  3.5 25068 18048 pts/0   S    14:20   0:00 [mysqld]
nobody   10086  0.0  3.5 25068 18048 pts/0   S    14:20   0:00 [mysqld]
nobody   10087  0.0  3.5 25068 18048 pts/0   S    14:20   0:00 [mysqld]
nobody   10522 10.3  3.5 25068 18048 pts/0   S    14:53   0:06 [mysqld]
nobody   10535  8.5  3.5 25068 18048 pts/0   S    14:54   0:00 [mysqld]
nobody   10536 42.0  3.5 25068 18048 pts/0   S    14:54   0:00 [mysqld]
root     10538  0.0  0.0  3776  496 pts/0    S    14:54   0:00 /bin/grep -E mysql
Maurizio
 

Postby Oswald » 07. October 2003 14:09

Hallo Maurizio!

Seltsam...

Kannst Du hier mal das SELECT-Statement posten oder mir mailen, das bei Dir nicht funktioniert? Mit dem CREATE der Tabelle? Dann kann ich es hier auch mal ausprobieren.

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Maurizio » 08. October 2003 13:07

Hallo,

erstmal Danke für das schnelle Feedback per Mail!

Ich bin mit meinem Latein so langsam aber sicher auch mehr als am Ende :(
Wurde die CD-Datenbank irgendwie anders erstellt (mit einer anders kompilierten SQL-Version etc.) oder wurde beim "bauen" des XAMPP-Paketes entwas entscheidendes gemacht? Mittlerweile kann es ja wer-weiß-woran liegen - die Suche nach der Nadel im Heuhaufen also ;)

Trotzdem vielen Dank für Deine ganzen Bemühungen!
Maurizio
 


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 0 guests