Apanatschi unter Windows->Xampp / Fehler bei Installation

Hier geht es um XAMPP AddOns wie z. B. das Apache-Konfigurations-Tool Apanatschi. Irgendwelche Probleme damit oder Fragen dazu? Dann ist hier genau der richtige Ort um nachzufragen.

Apanatschi unter Windows->Xampp / Fehler bei Installation

Postby dslthomas » 11. November 2007 19:40

Hallo!

Ich habe windows Xp und den Xampp installiert (aktuelle Version) Dann wollte ich Apanatschi installieren und die Installation schlägt fehl mit der Meldung dass er keine Verbindung zur Datenbank bekommt. Die eingegebenen Zugangsdaten für die Datenbank sind aber Korrekt. Daran kann es nicht liegen. Im Schritt 2 kommen vorher folgende Fehlermeldungen:

Code: Select all
apanatschi/config.php wurde erstellt....
httpd.conf wurde in apanatschi/backups gesichert....

Warning: fopen(apache/conf/httpd.conf) [function.fopen]: failed to open stream: No such file or directory in F:\xampp\htdocs\apanatschi\make_install.php on line 56

Warning: fwrite(): supplied argument is not a valid stream resource in F:\xampp\htdocs\apanatschi\make_install.php on line 57

Warning: fclose(): supplied argument is not a valid stream resource in F:\xampp\htdocs\apanatschi\make_install.php on line 58

Warning: fopen(apache/conf/httpd.conf) [function.fopen]: failed to open stream: No such file or directory in F:\xampp\htdocs\apanatschi\make_install.php on line 56

Warning: fwrite(): supplied argument is not a valid stream resource in F:\xampp\htdocs\apanatschi\make_install.php on line 57

Warning: fclose(): supplied argument is not a valid stream resource in F:\xampp\htdocs\apanatschi\make_install.php on line 58

Warning: fopen(apache/conf/httpd.conf) [function.fopen]: failed to open stream: No such file or directory in F:\xampp\htdocs\apanatschi\make_install.php on line 56

Warning: fwrite(): supplied argument is not a valid stream resource in F:\xampp\htdocs\apanatschi\make_install.php on line 57

Warning: fclose(): supplied argument is not a valid stream resource in F:\xampp\htdocs\apanatschi\make_install.php on line 58
apanatschi.conf wurde erstellt und erfolgreich in die httpd.conf eingebunden....

Schritt 2 SQL Strucktur erstellen


Bis dann im Schritt 3 lediglich der Hinweis kommt:

"Keine Verbindung möglich!"

Kann mir jemand nen Tipp geben wie ich Apanatschi zum laufen bekomme?

Danke
Denke nie gedacht zu haben denn das denken der Gedanken ist gedankenloses denken!
dslthomas
 
Posts: 6
Joined: 11. November 2007 19:34

Postby Scory » 11. November 2007 19:58

Ich kenne apanatschi nicht, aber irgendwo in der Installation hast Du einen relativen anstelle eines absoluten Pfadnamens angegeben und darüber stolpert das Script:

Warning: fopen(apache/conf/httpd.conf) [function.fopen]: failed to open stream: No such file or directory in


Die Angabe "apache/conf/httpd.conf" ist relativ zum Apanatschi-Verzeichnis falsch, denn richtigerweise müßte dort ungefähr so etwas stehen:

Code: Select all
c:/programme/xampp/apache/conf/httpd.conf


Die anderen Meldungen sind Folgefehler.

Grüße
Scory
Scory
 

Postby dslthomas » 11. November 2007 20:21

Ok, Danke - ich werd das gleich mal nachschauen und gegebenenfalls die Lösung Posten wenn ich es beheben kann.
Denke nie gedacht zu haben denn das denken der Gedanken ist gedankenloses denken!
dslthomas
 
Posts: 6
Joined: 11. November 2007 19:34

Postby dslthomas » 11. November 2007 22:19

Also die ersten Fehlermeldungen aus Schritt 2 habe ich weg bekommen indem ich folgende Zeile in der make_install.php abgeändert habe:

Original:
Code: Select all
#### httpd.conf nach /apanatschi/backups kopieren ####

$datei = $xampp_path."apache/conf/httpd.conf";
@copy($datei,$xampp_path."apanatschi/backups/httpd.conf");
echo "httpd.conf wurde in $xampp_path apanatschi/backups gesichert.... <br>";


geändert:

Code: Select all
#### httpd.conf nach /apanatschi/backups kopieren ####

$datei = "C:/xampp/apache/conf/httpd.conf";
@copy($datei,$xampp_path."apanatschi/backups/httpd.conf");
echo "httpd.conf wurde in $xampp_path apanatschi/backups gesichert.... <br>";


Jetzt klappt aber der SXchritt 3 noch nicht - die Verbindung zur Datenbank - da kommt immer noch die Meldung "Keine Verbindung möglich!" wo und wie kann ich diesen Fehler beheben?

Danke[/code]
Denke nie gedacht zu haben denn das denken der Gedanken ist gedankenloses denken!
dslthomas
 
Posts: 6
Joined: 11. November 2007 19:34

Postby dslthomas » 11. November 2007 23:47

Also nach langem hin und her hat er zwar die Datenbank angelegt und auch die apanatschi.conf richitg gesetzt, aber das ganze will einfach nicht laufen. Wenn ich den apanatisch wie beschrieben im Browser öffne, so erhalte ich das Login-Fenster. Wenn ich dann den Benutzernamen und das Passwort eintrage und auf "Login" klicke - so komme ich wieder zur selben Maske. Ich kann mich noch so oft versuchen einzuloggen - er bringt mir immer wieder die Login-Maske. Ich habe also keinen Zugriff auf das Administrationsmenü.

Die Daten in der config.php habe ich manuell eingetragen weil diese nicht automatisch erfolgt sind. Ebenfalls der Documentenroot in der apanatschi.conf mußte per Hand eingetragen werden weil der Apache sonst nicht neu startet.

Hat vielleicht jemand nen Tipp wie ich das ganze doch noch zum laufen bekomme?
Denke nie gedacht zu haben denn das denken der Gedanken ist gedankenloses denken!
dslthomas
 
Posts: 6
Joined: 11. November 2007 19:34

Postby Scory » 12. November 2007 13:45

Wo hast Du denn dieses Apanatschi her? Ich finde nur hier eines:

http://addons.xampp.org/project/7.html

Dort steht aber auch geschrieben:

Edit: Funktioniert nur bis XAMPP for Win32 1.4.9

Ist das daher, oder hast Du etwas anderes gefunden? Sicherlich wirst Du einiges anpassen müssen, wenn Du das benutzen willst, aber ob Du das alleine hinbekommst, wage ich eigentlich zu bezweifeln.

Grüße
Scory
Scory
 

Postby dslthomas » 12. November 2007 16:22

Scory wrote:Wo hast Du denn dieses Apanatschi her? Ich finde nur hier eines:

http://addons.xampp.org/project/7.html

Dort steht aber auch geschrieben:

Edit: Funktioniert nur bis XAMPP for Win32 1.4.9

Ist das daher, oder hast Du etwas anderes gefunden? Sicherlich wirst Du einiges anpassen müssen, wenn Du das benutzen willst, aber ob Du das alleine hinbekommst, wage ich eigentlich zu bezweifeln.

Grüße
Scory


Na toll! Sicher hab ich das von dort - aber anscheinend ist lesen ne schwäche von mir! Manchmal bin ich so blöde! Und ich habe die halbe Nacht gebastelt - Einträge die fehlten habe ich nachgepflegt - die Pfadangaben geändert - ich war so glücklich als erst mal die apanatschi.conf erstellt war und ich zumindest Apanatschi aufrufen konnte!

Na ja, wie schon gesagt - wer lesen kann ist klar im Vorteil! :-)

Gibts denn ein Toll mit dem ich die Vhost verwalten kann? Soweit ich mich "reingelesen" habe :-) scheint webmin auch nicht richtig unter Windows zu laufen!? - Wäre für nen Tipp sehr dankbar und ich verspreche das nächste mal richtig zu lesen :-)
Denke nie gedacht zu haben denn das denken der Gedanken ist gedankenloses denken!
dslthomas
 
Posts: 6
Joined: 11. November 2007 19:34

Postby Scory » 12. November 2007 17:02

Das einfachste ist eigentlich, die notwendigen vhost-Einträge selbst mit einem Editor zu schreiben. Xampp liefert Apache2 so aus, dass es ein separates File im Ordner "extra" gibt mit dem Namen httpd-vhosts.conf, welches man anpassen kann. Das wird dann auf Wunsch durch httpd.conf inkludiert.

Das ist doch einfach genug - und wenn Du nicht weißt, was Du dort eintragen mußt, kannst Du einerseits mal die Doku lesen und andererseits hier fragen. Besser ist es sowieso, wenn man die Dinge versteht, die man da macht, statt irgendwelche Frontends zu benutzen, die im Zweifelsfall auch noch nicht alles richtig machen.

Grüße
Scory
Scory
 

Postby dslthomas » 12. November 2007 19:17

Scory wrote:Das einfachste ist eigentlich, die notwendigen vhost-Einträge selbst mit einem Editor zu schreiben. Xampp liefert Apache2 so aus, dass es ein separates File im Ordner "extra" gibt mit dem Namen httpd-vhosts.conf, welches man anpassen kann. Das wird dann auf Wunsch durch httpd.conf inkludiert.

Das ist doch einfach genug - und wenn Du nicht weißt, was Du dort eintragen mußt, kannst Du einerseits mal die Doku lesen und andererseits hier fragen. Besser ist es sowieso, wenn man die Dinge versteht, die man da macht, statt irgendwelche Frontends zu benutzen, die im Zweifelsfall auch noch nicht alles richtig machen.

Grüße
Scory


Ja, Du hast recht, wenn mans einfach selbst erstellt, ist es weniger umständlich!

Ich habe folgende Vhost angelegt:

<Directory "F:/xampp/scggay">
Options -FollowSymLinks -SymLinksIfOwnerMatch
DirectoryIndex index.html index.htm index.php index.php3 index.php4 index.php5 index.cgi index.pl
<IfModule mod_access.c>
Allow from all
</IfModule>
<IfModule mod_authz_host.c>
Allow from all
</IfModule>
php_admin_flag engine on
<Files ~ "\.shtml$">
deny from all
</Files>
<Files ~ "\.(wml.*|wbmp)$">
deny from all
</Files>
</Directory>
<VirtualHost *:80>
ServerAdmin info@nordigspace.de
DocumentRoot F:/xampp/scggay/html
ServerName scggay.homeip.net
ServerAlias www.scggay.homeip.net
ScriptAlias /cgi-bin/ F:/xampp/scggay/html/cgi-bin/
ErrorLog F:/xampp/scggay/log/error_log
CustomLog F:/xampp/scggay/log/access_log common
php_admin_value open_basedir F:/xampp/scggay/html/:F:/xampp/scggay/phptmp/:F:/xampp/scggay/files/:F:/xampp/scggay/atd/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir F:/xampp/scggay/phptmp/
php_admin_flag magic_quotes_gpc On
</VirtualHost>
Code: Select all

Gibts da was zu beanstanden oder ist das so OK? Ich gebe zu, ich hab vom Linux-Server abgeguckt :-)
Denke nie gedacht zu haben denn das denken der Gedanken ist gedankenloses denken!
dslthomas
 
Posts: 6
Joined: 11. November 2007 19:34


Return to XAMPP AddOns

Who is online

Users browsing this forum: No registered users and 2 guests

cron