RELEASE: Apanatschi für Linux 0.1a (Webinterface)

Hier geht es um XAMPP AddOns wie z. B. das Apache-Konfigurations-Tool Apanatschi. Irgendwelche Probleme damit oder Fragen dazu? Dann ist hier genau der richtige Ort um nachzufragen.

Postby tobiasr » 14. August 2007 13:30

Ich habe mir die Datei noch nicht genau angesehen gehabt.
Ja sie machen mich auch stutzig nur ich weis nicht was sie bedeuten.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby DJ DHG » 14. August 2007 13:55

tobiasr wrote:Ich habe mir die Datei noch nicht genau angesehen gehabt.
Ja sie machen mich auch stutzig nur ich weis nicht was sie bedeuten.


Warum hast du die Datei dann angelegt?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tobiasr » 14. August 2007 14:26

Ne ich schaue schon mal rein nur heute habe ich das noch nicht gemacht.
Angelegt habe ich sie ja auch nicht.
Sie ist ja Standard mäßig schon drin.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby DJ DHG » 14. August 2007 14:52

tobiasr wrote:Angelegt habe ich sie ja auch nicht.
Sie ist ja Standard mäßig schon drin.


Wäre mir neu, zumindest in der 0.1a. Im sql-dump steht nichts.
Und eine andere Version habe ich bis jetzt nicht veröffentlicht.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tobiasr » 14. August 2007 14:54

Das ist die XAMPP Error Log habe ich doch geschrieben.
Die /opt/lampp/error/error_log.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby DJ DHG » 14. August 2007 15:05

tobiasr wrote:Das ist die XAMPP Error Log habe ich doch geschrieben.
Die /opt/lampp/error/error_log.


Da haben wir aneinander vorbei geschrieben. Ich rede von der folgender Datei:

Code: Select all
/opt/.htaccess


mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tobiasr » 14. August 2007 15:14

Die htaccess Datei sollte nicht dahin.
Ich habe sie gelöscht.
Jetzt starte ich mal meine PC neu und schaue weiter.

Edit nach dem neustart von apanatschi ist der Fehler immer noch.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby DJ DHG » 14. August 2007 15:30

tobiasr wrote:Die htaccess Datei sollte nicht dahin.
Ich habe sie gelöscht.
Jetzt starte ich mal meine PC neu und schaue weiter.

Edit nach dem neustart von apanatschi ist der Fehler immer noch.


Auch aus Apanatschi gelöscht? Sonst kommt die immer wieder, vorausgesetzt, die wurde damit erstellt.
error_log?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tobiasr » 14. August 2007 15:40

Error_log
die wirst du ja jetzt nicht mehr brauchen

Es geht wieder.
Habe noch eine htaccess Datei gefunden, gelöscht und es geht wieder danke für die Hilfe. :D
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Re: RELEASE: Apanatschi für Linux 0.1a (Webinterface)

Postby Boule » 16. August 2007 22:53

@Dj DHG
Super Sache das Apanatschi. Das Kochrezept zur Installation ist klasse und gut nachvollziehbar.
ProFTPd funktioniert mit dem angegebenen Benutzer und dem Passwort .... das Webinterface jedoch nicht.
Nach der Eingabe http://localhost:1000 kommt die Maske hoch. Eingabe von nobody und lampp -> produziert Warnungen: Access denied for user 'apanatschi'@'localhost'

Habe dann in der MySQL-Datenbank herumgespielt und das Passwort vom FTP-User in den Webuser übernommen...... half aber auch nichts.

Gibt es eine Idee, wie das Problem umgangen werden kann?
*****************************
Webinterface
User: nobody
Pass: lampp

User: nobody
Pass: lampp
*****************************

Mit dem separaten Front-end-Modul zu ProFTPd hatte ich ähnliche Schwierigkeiten im Zugang. Der voreingestellte User 'Administrator' ohne Passwort wurde nicht akzeptiert und das Programm sprang zurück in die Eingabemaske.... Wahrscheinlich die gleiche Ursache.

Gruß von Boule und herzlichen Dank für die Entwicklung beider Programme.


...... Stunden später.
Mir dämmerte es. Musste in der config.inc.php die Zugangsdaten für die MySQL-Datenbank von 'apanatschi' und das pwd von '123456' auf meine Daten ändern.
Jetzt kommen schon mal keine Warnmeldungen mehr. Aber die Zugangsdaten werden immer noch nicht akzeptiert.

..... und nach wenigen Stunden Schlaf (den Dj DHG ins Nachtgebet eingeschlossen)
die Prozedur von Anfang an wiederholt (diesmal mit richtigen Eingaben). Whow .... Jubel .... Es tut. Jetzt gehe ich mal in die Testphase.
Boule
 
Posts: 1
Joined: 16. August 2007 19:03

Previous

Return to XAMPP AddOns

Who is online

Users browsing this forum: No registered users and 1 guest

cron