Zugrif nur von Server PC

Alles, was den ProFTPD betrifft, kann hier besprochen werden.

Zugrif nur von Server PC

Postby tobiasr » 18. July 2007 20:58

Hi ich habe mir Gestern die Aktuelle Xampp Version für Linux auf meinem PC (Suse 10.2) Installiert.
Wenn ich nun per FTP auf den Server zugreifen will geht das nur von Server PC aus, also wenn ich in den Browser (vom Server) meine Netzwerk-IP ftp://192.168.178.23 eingebe kann ich mich einloggen und sehe den Inhalt von dem FTP Ordner.
Wenn ich nun von einem anderen PC, ftp://192.168.178.23 eingebe kann der Browser keine Verbindung aufbauen.
Wenn ich die Internetseite also http://192.168.178.23 sehe ich die Webseite.
Was kann habe ich falsch gemacht, oder was kann ich ändern.


Edit: Auch wenn das nicht in dieses Forum passt, kann mir einer sagen wie ich Xampp beim Hochfahren von PC Automatisch starte?
Oder ich einen Link auf den Desktop mache mit dem ich XAMPP starten/stappen kann?
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby Stepke-DSL » 19. July 2007 15:39

tach auch

das mit dem xampp starten steht meines wissens in der doku

zu deinem ftp-problem:

versuch mal ftp://USER:PASS@192.168.178.23

oder noch einfacher ein ftp-programm, z.b. filezilla

host: 192.168.178.23
user: USER
pass: PASS

versuch es mal...
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
XAMPP Version: 5.6.3
Operating System: Win XP Pro SP3 + SuSe Linux

Postby tobiasr » 19. July 2007 16:06

ich habe es schon mit SmartFTP versucht, aber danke für den tipp.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby DJ DHG » 19. July 2007 16:25

Moin Moin!

Firewall?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tobiasr » 19. July 2007 21:17

Wenn es die Firewall ist, wo kann ich sie denn für den Port ausschalten?
Ich nutzte Linux Suse 10.2
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby DJ DHG » 20. July 2007 07:51

Ich denke mal mit Yast(2).

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tobiasr » 20. July 2007 08:14

ich finde in der Liste kein FTP.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby Stepke-DSL » 23. July 2007 10:44

hmmmm, kannst du nicht direkt die Ports angeben, die nicht geblockt werden sollen? bei FTP wären das Port 20 und 21
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
XAMPP Version: 5.6.3
Operating System: Win XP Pro SP3 + SuSe Linux

Postby tobiasr » 23. July 2007 10:48

ich glaube nein, oder ich bin zu blöd.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby DJ DHG » 23. July 2007 10:58

Wenn es an der Firewall nicht liegen sollte, versuche es mit
folgender Zeile in der proftpd.conf

Code: Select all
Defaultserver on


mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tobiasr » 23. July 2007 11:01

Bei mir stand es so DefaultServer on, ist das anders?
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby Bonez » 24. July 2007 07:35

poste doch einfach mal deine Proftpd.conf und ist der Proftpd gestartet.
Bonez
 
Posts: 1
Joined: 12. July 2007 08:23

Postby tobiasr » 24. July 2007 08:15

Das ist die Proftp.conf:
ServerName "Xampp - ProFTPd Server"
ServerType standalone
Defaultserver on
Port 21
Umask 022
MaxInstances 30
User nobody
#Group nogroup
Defaultroot ~
RequireValidShell on

# Systemnachrichten
AccessGrantMsg "Willkommen auf meinem Xampp Server"
AccessDenyMsg "Zugriff verweigert"

# loginversuche bevor verbindung getrennt werden soll
MaxLoginAttempts 3


# Timeout Einstellungen
TimeoutStalled 120 # Sekunden, wielange eine Verbindung ohne "Datentransfer" bestehen darf
TimeoutIdle 120 # Sekunden, wielange eine Idle Verbindung bestehen darf
TimeoutLogin 30 # max Zeit fuer Anmeldung


# es duerfen datein ueberschrieben werden
<Directory />
ListOptions "-a"
AllowOverwrite on
</Directory>

#wenn der login laenger als 10 sec. dauert auskommentieren!
#UseReverseDNS off
#IdentLookups off


#Resume erlauben
#Bitte beachten, dass hiddenstor" nicht aktiviert sein darf (ist per Default deaktiviert).
AllowOverwrite on
AllowRetrieveRestart on
AllowStoreRestart on


# keine systemuser benutzen
UseFtpUsers off

# root login verbieten
RootLogin off

# Maximale Anzahl von User, die den selben Account gleichzeitg nutzen koennen
MaxClientsPerUser 1 "Sorry, nicht mehr als 1 Client pro Nutzer"


# <datenbank>@<host> <user> <passwort>
SQLConnectInfo apanatschi@localhost apa meinpasswort

###########################################################################################################
# ab hier nichts mehr aendern! #
###########################################################################################################
SQLAuthenticate users*
SQLAuthTypes crypt
SQLUserWhereClause "enabled = '1'"
SQLUserInfo ftp_users userid passwd uid gid homedir shell

SQLLog PASS updatecount
SQLNamedQuery updatecount UPDATE "count=count+1 WHERE userid='%u'" ftp_users
SQLLog PASS lastlogin
SQLNamedQuery lastlogin UPDATE "last_login=now() WHERE userid='%u'" ftp_users
SQLLog RETR dlbytescount
SQLNamedQuery dlbytescount UPDATE "dl_bytes=dl_bytes+%b WHERE userid='%u'" ftp_users
SQLLog STOR ulbytescount
SQLNamedQuery ulbytescount UPDATE "ul_bytes=ul_bytes+%b WHERE userid='%u'" ftp_users


SQLLog RETR,STOR transfer
SQLNamedQuery transfer INSERT "'%u', '%f', '%b', '%h', '%a', '%m', '%T', now()" ftp_transfer



Natürlich habe ich den Prftp gestartet, wenn du den 1. Beitrag gelesen hättest wüsstest du es auch.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27


Return to ProFTPD

Who is online

Users browsing this forum: No registered users and 2 guests