RELEASE: Apanatschi für Linux 0.1a (Webinterface)

Hier geht es um XAMPP AddOns wie z. B. das Apache-Konfigurations-Tool Apanatschi. Irgendwelche Probleme damit oder Fragen dazu? Dann ist hier genau der richtige Ort um nachzufragen.

RELEASE: Apanatschi für Linux 0.1a (Webinterface)

Postby DJ DHG » 15. June 2007 23:26

RELEASE: Apanatschi für Linux 0.1a

Moin liebe Freunde der Apachefriends,

heute habe ich es endlich geschafft, ein „lauffähige Version“
von Apanatschi zusammen zustellen. Es war harte Arbeit, die
nun schon mehrere Wochen in Anspruch genommen hat, manche
sprechen auch von Jahren :wink:

Für alle die sich fragen, was ist das denn schönes? Es ist
der Versuch, eine auf Xampp zugeschnittene
Webadministrationsoberfläche zur Verfügung zu stellen. Da es
auf Entwickler ausgerichtet, stellt es keine alternative zu
Confixx, pd-Admin, SysCP, Plesk etc. da. Obwohl man es dazu
wahrscheinlich auch missbrauchen könnte.

Ein Paar Bilder dazu:
Shot 1
Shot 2
Shot 3
Shot 4
Shot 5


Derzeit befindet sich Apanatschi noch in der Alphaphase, es
ist also Vorsicht geboten!



Was kann Apanatschi?

- Apanatschi ist logingesichert
- Aktualisieren von Webalizer - Statistiken
- Starten und Stoppen des Apachen und ProFTPd (Derzeit kein MySql, da Apanatschi es als Backend verwendet)
- Neustarten und Reloaden von Mysql, ProFTPd und Apache
- php.ini in verschiedenen Versionen speicherbar
- Es kann derzeit leider nicht zwischen PHP 4 und PHP 5 hin und her geschaltet werden, da Apanatschi auf PHP 5 basiert!
- ProFTPd User Monitor, Traffic-Übersicht, Benutzerverwaltung (De/-Aktivierbar)
- Apache: Virtualhost und Htaccess Verwaltung (De/-Aktivierbar)
- Systeminfomationen wie: Eingeloggte Benutzer, Runlevel, Uptime, Kernel Version, Ram Verbrauch, ......






Zur Installation:

Für die Installation werden Root-Rechte benötigt!


Ladet das Archiv von hier runter und entpackt es mit:
Code: Select all
tar xvfz apanatschi4linux-0.x.x.tar.gz -C /opt

Achtung! Hierbei wird die proftpd.conf durch die von Apanatschi
ersetzt! (Denkt also vorher an das Backup!)

Öffnet phpmyadmin (http://localhost/phpmyadmin) und legt eine neue Datebank
mit dem Namen apanatschi an. Klickt auf "importieren" und wählt den
Mysql-Dump, mit dem Button "Durchsuchen" aus, er liegt unter
Code: Select all
/opt/lampp/apanatschi/tmp/apanatschi.sql

Dann legt (unter Rechte) einen neuen User an, wobei der Name egal ist. Achtet darauf,
dass der User folgende Rechte besitzt: SELECT, INSERT, UPDATE
und DELETE. Als „host“ wird „localhost“ angegeben!

Nun navigiert nach
apanatschi -> php_ini -> Einfügen.

Schreibt in die Felder folgende Werte:
id: Bleibt leer
name: Sowas wie "default" oder "unsicher" (Nur EIN Wort!)
status: 1
ini In das Textfeld kopiert ihr eure php.ini aus /opt/lampp/etc/php.ini
description Hier ist Platz für eine kurze Beschreibung (Optional)

Auf "Ok" klicken, damit die neuen Daten übernommen werden.

Der Browser kann jetzt geschlossen werden.


Dann öffnet /opt/lampp/etc/proftpd.conf mit einem Editor eurer Wahl
und geht zur Zeile 55, die bis jetzt noch so aussieht.
Code: Select all
SQLConnectInfo         apanatschi@localhost mysqlusername 123456


Erklärung:
<Mysql Datenbank>@<Der Mysql Rechner> <Mysql Benutzername> <Dessen Passwort>

Passt den Benutzernamen und das Passwort entsprechend euer Eingaben beim
Anlegen des MySql-Benutzernamens an. Der Mysql-Datenbankname bleibt! (apanatschi)
Abspeichern und schließen.

Öffnet die /opt/lampp/apanatschi/conf/config.inc.php und passt die
Variablen $user an $pwd an euren MySQL-User an!
Abspeichern und schließen.

Jetzt öffnet die /opt/lampp/etc/httpd.conf und löscht alle vorhandenen Virtualhosts.
Anschließend fügt ganz unten folgendes ein:

Code: Select all
NameVirtualHost *

# Damit „localhost“ weiterhin auf /opt/lampp/htdocs/ zeigt.
<Virtualhost *>
ServerName localhost
ServerAlias localhost
ServerAdmin webmaster@localhost
DocumentRoot /opt/lampp/htdocs
ScriptAlias /cgi-bin/ /opt/lampp/cgi-bin/
<Directory /opt/lampp/htdocs/>
Options +Indexes +Includes
</Directory>
</Virtualhost>


include /opt/lampp/apanatschi/conf/vhost.conf



Abspeichern und schließen.

Jetzt öffnet die Datei /etc/hosts und fügt folgendes ein.
Code: Select all
#apanatschistart
127.0.0.1       localhost
#apanatschistop

Achtet darauf, dass nach dem "#apanatschistop" eine Neue Zeile (Einmal Enter!) beginnt!


Damit ist die Konfiguration abgeschlossen.
Jetzt noch schnell
/opt/lampp/lampp stop
/opt/lampp/lampp stopssl
/opt/lampp/lampp start
/opt/lampp/lampp startapanatschi
/opt/lampp/lampp startapanatschi-daemon

und im Browser http://127.0.0.1:1000 aufrufen.

Benutzer und Passwörter:

Webinterface
User: nobody
Pass: lampp

ProFTPd
User: nobody
Pass: lampp


Feedback ist natürlich sehr willkommen!

Have fun!

DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Probleme mit ProFtpD

Postby Catweazel » 24. June 2007 13:47

Hallo DJ DHG,

erstmal vielen Dank für deine Arbeit.

Habe alles so gemacht wie in der Anleitung steht.

Ein paar Fragen sind bei mir aufgekommen.
1. Warum die httpd.conf editieren? Bei mir stehen keine VirtualHosts drin (Xampp 1.6.2 frisch installiert, Linux, Debian)
2. Warum den Include von '/opt/lampp/apanatschi/conf/vhost.conf' ? Die ist leer.

Zum Problem.
Wie oben erwähnt läuft XAMPP auf Linux. Der wird von einem XP-PC aus administriert.
Wenn ich User für ProFtpD anlege sind die auch da und können sich z.B. per FileZilla vom WinPC aus einloggen. Dort dürfen die User aber nichts schreiben, kopieren vom XAMPP geht, aber drauf geht halt nicht. Welche Berechtigungen habe ich vergessen zu setzen?
EDIT: Habe 'chown nobody.root /opt/lampp/htdocs/Verzeichnis' gemacht und schon funktioniert es.

2. Problem: Die Oberfläche sind bei mir völlig anders aus. Anscheinend werden die Grafiken nicht angezeigt. Zum Beispiel die grünen Punkte für die laufenden Dienste.

Frage:
Läuft Apanatschi nach einem reboot automatisch mit XAMPP an?
Wenn nicht wo muss ich
/opt/lampp/lampp startapanatschi
/opt/lampp/lampp startapanatschi-daemon
einbauen?

Verbesserungsvorschlag:
Die User die angelegt worden sind (Apanatschi und ProFtpD) auch bearbeiten können. Immo muss der User erst komplett gelöscht und dann wieder angelegt werden wenn was nicht stimmt. Aber ich nehme an das ist eh schon in deinem Hinterkopf.
_________
Catweazel
User avatar
Catweazel
 
Posts: 7
Joined: 08. October 2005 14:05

Postby DJ DHG » 24. June 2007 20:59

Hallo Catweazel!

Vielen Dank für das umfangreiche Feedback!

1. Warum die httpd.conf editieren? Bei mir stehen keine VirtualHosts drin (Xampp 1.6.2 frisch installiert, Linux, Debian)
2. Warum den Include von '/opt/lampp/apanatschi/conf/vhost.conf' ? Die ist leer.


Falls Virtualhosts bereits definiert worden sind, kann Apanatschi die
nicht verwalten, deswegen sollten die auch vorher entfernt werden.
Werde ich in der neuen Version in der Readme berücksichtigen!

Der "Include" zeigt auf eine leere Datei, dass ist richtig. Schließlich sind
ja noch keine Virtualhosts über Apanatschi erstellt worden.
Erst wenn einer über Apanatschi erstellt wird, landet der in der besagten Datei.

2. Problem: Die Oberfläche sind bei mir völlig anders aus. Anscheinend werden
die Grafiken nicht angezeigt. Zum Beispiel die grünen Punkte für die laufenden Dienste.


Wenn du Firefox benutzt, werden Grafiken von localhost "geblockt"?
Könntest du mir davon einen Screenshot zukommen lassen?

Frage:
Läuft Apanatschi nach einem reboot automatisch mit XAMPP an?


Wenn du
Code: Select all
/opt/lampp/lampp startapanatschi
/opt/lampp/lampp startapanatschi-daemon

einmal ausgeführt hast, wird die beiden bei jedem Start autom. wirder
mit gestartet.

Verbesserungsvorschlag:
Die User die angelegt worden sind (Apanatschi und ProFtpD) auch bearbeiten können.
Immo muss der User erst komplett gelöscht und dann wieder angelegt werden wenn was
nicht stimmt. Aber ich nehme an das ist eh schon in deinem Hinterkopf.

Richtig, steht auf meiner Todo. :wink:

Vielen Dank nochmals, für das Ausprobieren!

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Screens

Postby Catweazel » 24. June 2007 21:17

Hallo DJ DHG,

danke für die schnelle Antwort.

Einmal Firefox

und IE7

Hoffe die Bilder sind nicht zu groß fürs Forum.
_________
Catweazel

P.S.: Bemerke gerade das auf der Systeminformations-Seite alle drei Einträge von Swap mit 0 MB angezeigt werden.
P.P.S.: Währe es nicht nützlich den Plattenplatz auch mit anzuzeigen?
Last edited by Catweazel on 29. September 2007 13:29, edited 3 times in total.
User avatar
Catweazel
 
Posts: 7
Joined: 08. October 2005 14:05

Re: Screens

Postby DJ DHG » 24. June 2007 22:38

Catweazel wrote:[...]Xampp 1.6.2 frisch installiert, Linux, Debian[...]


In dieser Konstellation hab ich es gerade nochmal selbst Ausprobiert (Debian Etch und Sarge)
ohne Probleme.

Ich kann das irgendwie nicht nachvollziehen :(
Erläutere mal dein Vorgehen bei der Installation.
IE7 unter Linux?

Catweazel wrote:Hoffe die Bilder sind nicht zu groß fürs Forum.


Schönder wäre es, wenn es einfach Links sind. Schmerzt nicht so,
wenn die Bilder irgendwann mal das zeitliche Segen :wink:

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Catweazel » 25. June 2007 07:18

Guten Morgen DJ DHG,

auf die Idee mit den Links hätte ich auch selber kommen können, ist geändert.

Zu dem IE und FF. Mein XAMPP läuft unter Debian und der PC dafür steht im Keller. Die Bilder sind aber von einem WinXP-PC aus dem Büro. Also mit localhost:1000 zugreifen geht nicht. Zusätzlich hängt der Server im orangenem Netz hinter der Firewall. Mit den Seite von XAMPP, phpMyAdmin oder den Testseiten von XAMPP habe ich keine Probleme. Weder unter IE noch FF.
Ich sehe mir mal den PHP-Code von dir an. Habe zwar fast keine Ahnung von PHP, aber wozu gibt es das WWW. Vielleicht finde ich ja was. Und dümmer werde ich davon bestimmt auch nicht.
Alphaversionen laufe halt nun mal nicht überall gleich richtig :D
_________
Catweazel
User avatar
Catweazel
 
Posts: 7
Joined: 08. October 2005 14:05

Postby DJ DHG » 25. June 2007 14:30

http://community.apachefriends.org/f/viewtopic.php?p=103506
Hier Schreibst du, du hättest einfach "drüber-entpackt".
Installiere Xampp nochmal sauber und versuche es erneut.

Ich bleibe aber dennoch am Ball :wink:

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Alles neu gemacht

Postby Catweazel » 25. June 2007 22:10

Hallo DJ DHG,

habe XAMPP und Apanatschi komplett gelöscht.
XAMPP mit tar ....... entpackt, gestartet und /lampp security durchgeführt.
Apanatschi mit tar entpackt und deine Anleitung komplett nochmal durchgeführt.

Gleiches Ergebnis wie vorher. Keine Bilder im IE wie im FF. :?
_________
Catweazel
User avatar
Catweazel
 
Posts: 7
Joined: 08. October 2005 14:05

Neue Erkenntnisse

Postby Catweazel » 04. July 2007 21:47

Hallo DJ DHG,

habe mal auf meiner Linuxpartition Debian 4.0 mit KDE alles von meinem Webserver herüberkopiert und zum laufen gebracht.
Wenn Apanatschi dann aufgerufen wird funktioniert alles. Also die Grafiken kommen alle, wenn ich die Seite per localhost:1000 aufrufe.
So, da aber mein Webserver natürlich nicht mit localhost:1000 sondern mit 192.168.111.150:1000 aufgerufen wird, kommen die Grafiken nicht.
Der Weg der Daten läuft so: Win/Linux-Browser -> Switch -> FireWall -> WebServer -> Apanatschi

Hmm, wenn ich ProFTP mal anhalte, wird im Statusfenster ein roter Punkt angezeigt. Starte ich ihn wieder, roter Punkt weg aber kein Grüner. Komisch.
Webalizer wird auch keine Statistik angezeigt. Muss mal nachsehen wie das unter Linux per localhost aussieht.

Bis denne
_________
Catweazel
User avatar
Catweazel
 
Posts: 7
Joined: 08. October 2005 14:05

Postby michikkk » 09. July 2007 14:52

HEY

HERZLICHEN DANK kann ich da nur sagen.

Wir versuchen den ****** FTPd seit tagen zu konfigurieren, mit dem interface brauchte ich 10 min.

Nochmals herzlichen Dank.
michikkk
 
Posts: 1
Joined: 09. July 2007 14:50

3 Probleme

Postby Stepke-DSL » 12. July 2007 16:14

Tach,

Gleich zur Sache:

Problem1:

Es kommt keine htaccess Passwortabfrage, obwohl ene .htaccess in diesem Ordner liegt.

Hier mal ein Schnippsel von der httpd.conf:

Code: Select all

#<Directory />
#    Options FollowSymLinks
#    AllowOverride All
#    Order deny,allow
#    Deny from all
#</Directory>

NameVirtualHost *

<Virtualhost *>
   ServerName localhost
   ServerAlias localhost
   ServerAdmin ich@server.de
   DocumentRoot /opt/lampp/htdocs
   ScriptAlias /cg-bin/ /opt/lampp/cgi-bin/
   <Directory /opt/lampp/htdocs/>
      Options +Indexes +Includes FollowSymLinks
      AllowOverride All
   </Directory>
</Virtualhost>

include /opt/lampp/apanatschi/conf/vhost.conf



Problem2:

Es läuft kein PHP mehr, außer bei Apanatschi, nicht in den htdocs und auch nicht in den VHosts...

Problem3:

Wenn ich eine htaccess über das Apanatschi-Interface erstellen möchte kommt immer, dass nicht alle Felder ausgefüllt wären, obwohl alle Felder ausgefüllt sind.


Wie kann ich diese Probleme lösen???

MfG Stepke
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
XAMPP Version: 5.6.3
Operating System: Win XP Pro SP3 + SuSe Linux

Postby Stepke-DSL » 12. July 2007 17:42

So, mit einer neuen httpd.conf habe ich fast alle Probleme gelöst.

Nurnoch ein Problem:

meine .htaccess wird ignoriert... Warum?

edit:

In der httpd.conf ist überall AllowOverride auf All gesetzt...
Auch beim VHOST habe ich AllowOverride auf All gesetzt.
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
XAMPP Version: 5.6.3
Operating System: Win XP Pro SP3 + SuSe Linux

Postby DJ DHG » 12. July 2007 19:02

Moin Stepke-DSL!

Was steht denn in der error_log, zum jeweiligen Zeitpunkt?

@Catweazel

Dein Problem, konnte ich bis jetzt, immer noch nicht nach vollziehen :(
Aber versuche es mal mit
Code: Select all
EnableSendfile Off

in der httpd.conf

Dann könntest du noch in der
Code: Select all
/opt/lampp/apanatschi/conf/apa_httpd.conf

folgende Zeile mit aufnehmen.
Code: Select all
ErrorLog /opt/lampp/logs/apanatschi_error_log

Vllt. kommt dabei was rum?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Stepke-DSL » 12. July 2007 19:58

In den errorlogs steht nichts drin.

Die .htaccess wird einfach ignoriert, als ob ich AllowOverride auf None stehen hätte...

Und das obwohl ich in der httpd.conf und bei dem virtuellen Host überall AllowOverride auf All stehen habe.

hier mal ein Schnippsel von dem virtuellen Host:

Code: Select all

AllowOverride All
Options -indexes FollowSymLinks +includes
DirectoryIndex index.html index.php
# etc.




Hier noch ein teil aus der httpd.conf:

Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride All
    #XAMPP
    #Order deny,allow
    #Deny from all
</Directory>

NameVirtualHost *

<Virtualhost *>
   ServerName localhost
   ServerAlias localhost
   ServerAdmin admin@server.de
   DocumentRoot /opt/lampp/htdocs
   ScriptAlias /cgi-bin /opt/lampp/cgi-bin/
   <Directory /opt/lampp/htdocs/>
      Options +Indexes +Includes FollowSymLinks
      AllowOverride All
   </Directory>
</Virtualhost>

include /opt/lampp/apanatschi/conf/vhost.conf


Hoffe, dass es jetzt besser verständlich ist.

Ansonsten muss ich sagen, Apanatschi ist eine verdammt geniale Sache!!! Respeckt!

MfG
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
XAMPP Version: 5.6.3
Operating System: Win XP Pro SP3 + SuSe Linux

Postby Stepke-DSL » 13. July 2007 15:54

So, Asche über mein Haupt, habe den Fehler gefunden...

Hatte in dem Virtuellen Host:

Code: Select all
Order allow,deny
Allow from all


Da kann das ja nicht funktionieren... :oops:

Man bin ich ein Drops!

Trotzdem danke für eure Fürsorge. ;-)

Wie gesagt, geiles Interface!

Aber mal eine andere Frage: Müssen die Dateien unbedingt in dem Ordner apanatschi/vhost/abc.wasweissich.de/
stehen, oder können die auch in /opt/lampp/htdocs/abc/
stehen, und wenn ja, was muss ich da ändern, dass der Virtuelle Host auf den htdocs-Ordner zugreift?

MfG Stepke
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
XAMPP Version: 5.6.3
Operating System: Win XP Pro SP3 + SuSe Linux

Next

Return to XAMPP AddOns

Who is online

Users browsing this forum: No registered users and 4 guests