mysql 4.1?

Was sollte alles noch in XAMPP rein? Was kommt definitiv bald? Was kommt so bald wie möglich, dauert nur noch etwas? Was kommt wahrscheinlich nicht rein?

mysql 4.1?

Postby The_Dragon » 29. October 2004 07:16

Hi @ all,

um gleich mal mit der Tür ins Haus zu fallen.
Wann wird die mysql Version 4.1. in das Xampp Paket integriert?
Laut dieser Meldung http://www.heise.de/newsticker/meldung/52603 ist nun endlich die Produktionsversion verfügbar, die solch nützliche und lang erwartete Funktionalitäten wie Subselects und SSL Verschlüsselung zwischen Client und Server unterstützt. Leider klappt es mit den Views nur immer noch nicht.
Ansonsten erstmal ein dickes Lob an die Entwickler, Xampp ist wirklich klasse! :D
The_Dragon
 
Posts: 2
Joined: 27. October 2004 14:56

Postby Oswald » 29. October 2004 07:51

Hallo Dragon!

Inzwischen machen wir es so, dass wir solange mit einer neuen XAMPP-Version warten bis 2 der großen Komponenten von XAMPP in neuen Versionen vorliegen. Wir hatten es ursrpünglich so gemacht, dass wir bei jeder neuen Version auch eine neue XAMPP-Version herausgebracht haben, konnten das aber nicht durchhalten. Für uns ist es zu viel Arbeit geworden und auch "die Benutzer" haben sich beschwert, dass es zu viele XAMPP-Updates gäbe.

Nur bei großen Sicherheitsproblemen machen wir in der Regel auch sofort eine neue Version.

Aber um Deine Frage konkret zu beantworten: Ich tippe mal auf noch 2 Wochen. Hab gerade gestern, dass erste mal MySQL 4.1.7 für XAMPP übersetzt. Werd am Wochenende jetzt erst mal ausgiebig Testen.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby shevegen » 30. October 2004 14:04

<Meine_Meinung>Halte ich auch für sehr sinnvoll. </Meine_Meinung>
User avatar
shevegen
 
Posts: 107
Joined: 08. June 2004 04:52

Postby Wiedmann » 30. October 2004 14:40

Auch noch meinen Senf dazugeben ;-)

die solch nützliche und lang erwartete Funktionalitäten wie Subselects

Auch wenn Subselects hilfreich sein können, gibt es hier zwei Dinge zu bedenken:
- "alte" MySQL Versionen können damit nicht umgehen. Bleibt also die Frage, ob deine Scripts immer da laufen wo auch der neueste MySQL installiert ist.
- Es wird umso wichtiger Script-Parameter die im Query benutzt werden zu prüfen.

und SSL Verschlüsselung zwischen Client und Server unterstützt.

Das gibt es seit MySQL 4.0.

Leider klappt es mit den Views nur immer noch nicht.

Die gibt es ab MySQL 5.0.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP-Wunschzettel

Who is online

Users browsing this forum: No registered users and 3 guests