M$SQL

Was sollte alles noch in XAMPP rein? Was kommt definitiv bald? Was kommt so bald wie möglich, dauert nur noch etwas? Was kommt wahrscheinlich nicht rein?

M$SQL

Postby Fred » 12. February 2003 13:49

Hi,

ich habe WAMPP im Einsatz und mit PHP ein Web-Frontend für eine M$SQL DB geschreiben. Aus Sicherheitsgründen will ich jetzt den Webserver auf Linux laufen lassen, doch da muss bei PHP, um mit M$SQL zu können, ein spezielles Modul 'mitgeconft' werden und das läuft einfach nicht. Daher wäre es super, wenn ihr das noch in den LAMPP einbauen könntet.

Viele Grüße
Fred
Fred
 

Postby Oswald » 12. February 2003 15:32

Hallo Fred!

Die MySQL-Unterstützung ist eigentlich im LAMPP-PHP aktiviert. Oder meinst Du noch irgendein spezielles MySQL-Modul? Wenn ja, welches genau? Ich kenn nur das "normale" MySQL-Modul und das ist bereits drin.

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby boppy » 12. February 2003 16:05

ich denke, dass er (microsoft *g*) MS SQL meint und nicht mySQL
...in diesem Sinne
yours boppy

Interpunktion und Orthographie dieses Beitrags sind frei erfunden.
Eine Übereinstimmung mit aktuellen oder ehemaligen Regeln wäre rein zufällig und ist nicht beabsichtigt.
User avatar
boppy
AF Moderator
 
Posts: 501
Joined: 27. December 2002 02:15
Location: W-E-City

Postby Oswald » 12. February 2003 16:23

Argh... bin ich blind??? Hmm... tja. Dann weiß ich auch erst mal nicht weiter!
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Morpheus » 12. February 2003 16:30

Könnte man nicht erstmal eine ODBC Verbindung zur Datenbank auf dem Windows Rechner herstellen?
Wäre ja mal ein erster Schrit.
Das ein Microsoft Software auf Linux läuft, bezweifle ich stark, da Microsoft die Rechte nicht rausrückt.
Bliebe nur ein Emulator, was aber LAMPP sprengen würde
Morph
Morpheus
 
Posts: 218
Joined: 17. January 2003 20:58

Postby boppy » 12. February 2003 17:04

ich denke (hoffe!) zwar, dass du das bereits gelesen hast, aber dennoch:

http://de3.php.net/manual/en/ref.mssql.php
...in diesem Sinne
yours boppy

Interpunktion und Orthographie dieses Beitrags sind frei erfunden.
Eine Übereinstimmung mit aktuellen oder ehemaligen Regeln wäre rein zufällig und ist nicht beabsichtigt.
User avatar
boppy
AF Moderator
 
Posts: 501
Joined: 27. December 2002 02:15
Location: W-E-City

Postby Fred » 12. February 2003 22:20

Das Problem ist, dass Apache + PHP auf Linux laufen soll und die DB (M$SQL) auf W2K Server läuft.

Apache + PHP auf W2K mit M$SQL läuft ohne Probleme (WAMPP), nur leider nicht auf Linux (LAMPP)

Fred
Fred
 

Postby Oswald » 13. February 2003 00:29

Huhu Fred!

Ich werd voraussichtlich am Wocheende wieder ein bisschen Zeit haben und würd Dir dann mal ein LAMPP mit MS SQL-Unterstützung zusammenstellen. Ich hatte das schon länger vor aber nun endlich auch den Anlass.

Ich würd's Dir (und anderen Interessierte) hier die Download-URL geben und vielleicht kannst Du es dann ja mal bei Dir testen. Ich hab nirgendwo ein MS SQL laufen und bin daher kein wirklich guter Tester. ;)

Ist das ein Deal? ;)

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Fred » 13. February 2003 15:57

Hi Kai,

super, das wäre echt genial! Das mit dem Test geht natürlich klar.

Viele Grüße
Fred
Fred
 

Postby Oswald » 16. February 2003 00:36

Huhu Fred!

Wie versprochen:

http://prdownloads.sourceforge.net/xamp ... z?download

Ein LAMPP mit FreeTDS 0.60.

Wäre toll wenn Du es testen könntest! :)

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Fred » 17. February 2003 09:04

Hallo Oswald,

das ging ja echt super schnell! Danke! Leider bekomme ich Fehler im Start-Script und zwar werden die ganzen start-Befehle (Zeile 49-51) nicht gefunden. Ich bin totaler Linux-Anfänger, vielleicht habe ich auch was ganz einfaches falsch gemacht (bin aber genau der Anleitung gefolgt). Habe das ganze auf RedHat 8.0 laufen (ganz frisch aufgesetzt) und alles was mit LAMPP in Konflikt kommen könnte (apache, ...) habe ich nicht installiert.

Viele Grüße
Fred
Fred
 

Postby Oswald » 17. February 2003 12:56

Huhu Fred!

Wie hast Du LAMPP gestartet? Wirklich so:

/opt/lampp/lampp start

Wie hast Du es installiert? Genau so, wie in der Anleitung beschrieben mit tar xvfz ... oder hast Du es zuerst unter Windows ausgepackt und dann rüberkopiert?

Von so einer Fehlermeldung hab ich jedenfalls bisher nicht gehört und kann mir im Moment auch nicht wirklich eine Ursache vorstellen!!

Liebe Grüße,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Fred » 17. February 2003 13:48

Schuldig! :oops:
(habe lampp direkt im Verzeichnis gestartet)

Jetzt bekomme ich aber
Warning: mssql_connect() [function.mssql-connect]: Unable to connect to server: 192.168.0.2 in /opt/lampp/htdocs/db.inc.php on line 28

Mit wampp läuft es ohne Probleme.

Hast Du eine Idee woran das liegen könnte?

Viele Grüße
Fred
Fred
 

Postby Oswald » 17. February 2003 14:28

Huhu Fred!

Hmm.. wie schon befürchtet ich kann Dir bzgl. MSSQL wenig helfen. Aber hast Du auch in der /opt/lampp/etc/freetds.conf noch irgendwas eingestellt? Beim FreeTDS ist diese Konfiugrations-Datei noch mit dabei und sie sieht so aus, als ob sie auch irgendeine Bedeutung zu haben scheint! ;)

Die Datei /opt/lampp/etc/locales.conf gehört auch noch zu FreeTDS, aber ich denke mal die ist erstmal nicht so wichtig.

Hast Du mal unter http://www.freetds.org/docs.html geschaut, ob es da noch irgendwelche Infos gibt?

Viel Erfolg!
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Fred » 17. February 2003 14:38

Hallo Oswald,

habe gerade entdeckt, dass man den Port noch angeben muss, wenn man von Linux aus die Verbindung aufbaut.

Ich bekomme zwar keine Fehlermeldung mehr - aber funktionieren tuts auch nicht.

Werde noch etwas recherchieren (auf php.net sind noch ein paar Lösungen für freetds probleme) und melde mich dann hier, wenn (?) ich das Problem gelöst habe.

Viele Grüße
Fred
Fred
 

Next

Return to XAMPP-Wunschzettel

Who is online

Users browsing this forum: No registered users and 1 guest

cron