Anderer Mailserver im XAMPP für Win32

Was sollte alles noch in XAMPP rein? Was kommt definitiv bald? Was kommt so bald wie möglich, dauert nur noch etwas? Was kommt wahrscheinlich nicht rein?

Postby Dj Andi » 14. October 2003 10:37

Ich habe jetzt alles mögliche ausprobiert, emals empfangen das läuft aber senden nö. Fehler: 2003.10.14 11:31:31 I {eec} {smtp to mail.gmx.net} Verschicke E-Mail "167-1.msg"
2003.10.14 11:31:31 ERR {eec} SendMail aborted: MAIL FROM: <postmaster@localhost> -> 550 {mp015} Cannot resolve your domain
2003.10.14 11:31:33 I {eec} Mailrouter: Sending InfoMail for , Subject: "[Hamster] Mail-delivery failed!"

Muss ich den outlokexpress eigenglich dafür einrichten ?
Es sollte nur der email versang gemacht werden.
Dj Andi
 
Posts: 58
Joined: 17. May 2003 16:44
Location: NRW

Postby Kristian Marcroft » 14. October 2003 11:03

Hi,

irgendwo im Hamster solltest du deine Maildomain einstellen.
Zur Zeit ist sie localhost...
GMX kann Localhost im Internet nicht finden und blockt somit die mails.
hol dir ne DynDns.org Adresse und trage die als Mail Domain ein. dan sollte es gehen.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Dj Andi » 14. October 2003 18:03

Habe jetzt alles mögliche gesucht aber wo soll ich das eintragen?
Eine mail Domain habe ich ja, bei GMX. Und ne DynDns.org Adresse habe ich auch.
Dj Andi
 
Posts: 58
Joined: 17. May 2003 16:44
Location: NRW

Postby Kristian Marcroft » 14. October 2003 18:18

Hi,

wo und wie du das Einträgst, kann ich dir nicht sagen...
Aber von der Fehlermeldung her sehe ich, das du mali mit der Domain localhost verschickst.. und das geht nicht...

Such mal bei google.de ?

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Dj Andi » 14. October 2003 22:20

ich bin mit meinem latein am ende... :( Ich weis nicht wo das postmaster@localhost wegkommt, also beim hamste ist er nicht eingetragen.
Dj Andi
 
Posts: 58
Joined: 17. May 2003 16:44
Location: NRW

Postby nemesis » 14. October 2003 23:30

schonmal deine php.ini angeguckt? :)
bei mod_php (standard im xampp) ist die config im Apache Verzeichnis
; For Win32 only.
sendmail_from = postmaster@localhost
hab leider/zum Glück!? mich noch nicht mit dem Hamster beschäftigt, aber falls er auch als Pop3 Server dient, leg mal eine Postfach für deine gültige DynDns.org Adresse an und trag es in der php.ini ein!
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt

Postby Straffi » 15. October 2003 10:49

Moin,

ich geh hier mal von einem frischen Hamster aus.
fette Sachen sind so bei gmx
kursive Sachen mit eigenen werten überschreiben


HAMSTER
Einstellungen -> Benutzerverwaltung usw.

->Tab Lokale Benutzer
[Neue Gruppe]
Gruppenname: gmx

-> Tab Mail(...)
[x] Benutzer hat Postfach (POP3 oder IMAP)
[x] E-Mails senden erlaubt
Lokale E-Mail-Adressen: @gmx.de

[OK]

[Neuer Nutzer]
Benutzername: meineadresse

-> Tab Mail(...)
Lokale E-Mail-Adressen: meineadresse@gmx.de

-> Tab Allgemeines
Passwort ändern...

[OK][OK]

Einstellungen -> Mail: ...
-> Tab POP3-Mail...
[Neu]
Servername: pop.gmx.net
[OK]

Benutzer: [bearbeiten]
Benutzername: meineadresse@gmx.de
Passwort...
[OK]

-> Tab SMTP-Mail...
[Neu]
Servername: mail.gmx.net
[x] Anmeldung erforderlich
Benutzer [bearbeiten]
Benutzername: meineadresse@gmx.de
Passwort...
[OK]


PHP.INI
; For Win32 only.
sendmail_from = meineadresse@gmx.de



mfg straffi
User avatar
Straffi
 
Posts: 120
Joined: 07. October 2003 17:48

Postby Dj Andi » 15. October 2003 18:20

Hi!
Jetzt habe ich alles so gemacht wie es da stand und es tauch immer noch "> MAIL FROM:<postmaster@localhost>" auf.
Dj Andi
 
Posts: 58
Joined: 17. May 2003 16:44
Location: NRW

Postby Straffi » 15. October 2003 19:33

Moin,

hast du evtl. die flasche php.ini verändert?

mfg straffi
User avatar
Straffi
 
Posts: 120
Joined: 07. October 2003 17:48

Postby Dj Andi » 16. October 2003 00:07

Jep, es ist die falsche gewesen, jetzt läuft alles.
Danke schon mal dafür.
Jetzt habe erst mal nur noch ein Frage. Muss ich die email jedesmal abholen? Oder kann ich den eintrag "pop.gmx" weg lassen?
Dj Andi
 
Posts: 58
Joined: 17. May 2003 16:44
Location: NRW

Postby Straffi » 16. October 2003 09:58

Moin,

die POP-Sachen brauchst du nur zum empfangen von Mails via GMX.
Wenn du das nicht willst, lässt du den Hamster einfach nur die SMTP-Aufträge ausführen.

Um das zu automatisieren einfach folgendes:

Im Hamster:

Einstellungen -> Benutzerverwaltung und Passworte
-> Tab Passworte
$1,{Leer},{Leer} [Bearbeiten]
Benutzername: meineadresse@gmx.de
Passwort...

Zurück zum Hamster:
Script->Scripte und Module verwalten
->Tab Scripte verwalten
[Neu...]
Scriptname: SendMail

Jetzt kannst du im unteren Teil des Fensters das Script bearbeiten:

Code: Select all

#!load hamster.hsm

AtClear
AtAdd( SendeMail, "00:00", "23:59", "1111111", 60, true )
AtExecute
quit

sub SendeMail
  HamSendMailAuth ("mail.gmx.net", "smtp", "$1", "")
  HamWaitIdle
endsub



[speichern]
[schließen]

Zurück im Hamster:
Einstellungen -> Automatische Abläufe
->Tab Aktionen

Hamster -> Start
Starte (hs2-)Skript: SendMail.hsc
[OK]

Fertig!

Dieses Script schaut rund um die Uhr (00:00 -> 23:59) an jedem Wochentag (1111111)
alle 60 Minuten nach, ob eine ausgehende Mail für "mail.gmx.net" vorhanden ist und verschickt diese.

Das Script wird automatisch bei jedem Hamsterstart gestartet und läuft dann im Hintergrund.


mfg straffi
User avatar
Straffi
 
Posts: 120
Joined: 07. October 2003 17:48

Postby Dj Andi » 16. October 2003 23:12

Hi!

Jetzt läuft alles.:D
Danke für die Hilfe.

Gruß Andreas
Dj Andi
 
Posts: 58
Joined: 17. May 2003 16:44
Location: NRW

Previous

Return to XAMPP-Wunschzettel

Who is online

Users browsing this forum: No registered users and 1 guest