Fehlermeldung - Can't locate CGI/Carp.pm

Alles, was Perl betrifft, kann hier besprochen werden.

Fehlermeldung - Can't locate CGI/Carp.pm

Postby Manni » 07. December 2004 14:33

Hallo Group,
folgendes Problem hab ich. Untere Fehlermeldung hab ich vom xampp error.log . Läuft unter WinXP.

Can't locate CGI/Carp.pm in @INC (@INC contains: .) at *:/*/cgi-bin/upload/upload.cgi line 4.\r,
BEGIN failed--compilation aborted at *:/*/cgi-bin/upload/upload.cgi line 4.\r,
Premature end of script headers: upload.cgi, referer:
----------------

untehen stehend ein kleiner Ausschnitt von den ersten paar Zeilen.

#!*:/*/xampp/perl/bin/perl

# Fehlermeldungen an Browser ausgeben
use CGI::Carp qw(fatalsToBrowser);
# CGI Modul einbinden
use CGI;
-----------------

wo ist das Problem?

danke und Gruß
User avatar
Manni
 
Posts: 31
Joined: 19. July 2003 22:09

Postby Wiedmann » 07. December 2004 14:36

Can't locate CGI/Carp.pm in @INC (@INC contains: .) at *:/*/cgi-bin/upload/upload.cgi line 4.\r,

Du hast das Perl - AddOn nicht installiert. Nur da sind Module dabei.

#!*:/*/xampp/perl/bin/perl

Hier muss auch ein korrekter Pfad hin:
Code: Select all
#!C:/Apachefriends/xampp/perl/bin/perl.exe
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Manni » 07. December 2004 16:41

@Wiedmann

superklasse - danke :-)
User avatar
Manni
 
Posts: 31
Joined: 19. July 2003 22:09


Return to Perl

Who is online

Users browsing this forum: No registered users and 3 guests