XAMPP startet nicht mehr

Alles, was Perl betrifft, kann hier besprochen werden.

Postby Wiedmann » 20. September 2004 10:34

Cannot load /xampp/perl/bin/perl58.dll into sever: Das angegebene Modul wurde nicht gefunden.

Hmmmm, gestern waren wir doch schon soweit das diese Meldung nicht mehr kommt, weil du die entsprechende Zeile geändert hast.

Hast du irgendein /automagisches/ Tool auf dem Rechner was Änderungen auf der Platte beim Neustart rückgängig macht?

Gibt es eine Error-Log wo mann nachschauen kann?

"D:\server\xampp\apache\logs"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby airis » 20. September 2004 10:46

Hmmmm, gestern waren wir doch schon soweit das diese Meldung nicht mehr kommt, weil du die entsprechende Zeile geändert hast.

Die erste Zeile ist wirklich Schnee von gestern, habs der Einfachheit halber nur von oben kopiert, da das Fenster so schnell schließt hab ich gestern einen Screen-Print gemacht und es abgeschrieben. Sorry war ein Fehler von mir.
Im Error-log steht folgendes:
Code: Select all
[Mon Sep 20 11:05:32 2004] [error] Can't load Perl file: D:/1server/xampp/apache/conf/startup.pl for server localhost:0, exiting...

Was wir gestern auch schon hatten.
Denkst Du es ist besser die Version XAMPP und ActivePerl zu wählen?
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Postby Wiedmann » 20. September 2004 11:29

Can't load Perl file: D:/1server/xampp/apache/conf/startup.pl

Wenn das jetzt kein Tippfehler war, dann ist da eine "1" zuviel.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby airis » 20. September 2004 11:40

Tippfehler, sorry
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Postby airis » 20. September 2004 17:12

Hallo Wiedmann,
es läuft alles perfekt.
Habe XAMPP (ZIP-Version) und ActivePerl
Für die Installation von ActicePerl ist es am einfachsten sich das AS Packages herunterzuladen das ganze zu entpacken (nicht nach XAMPP!) und die "installer.bat" aufzurufen. Als Ziel gibt man dann "/xampp/perl/" an. Das vorhanden sollte man aber voher löschen. In deinem Fall wäre es dann das Verzeichnis "D:\server\xampp\perl".
wie Du gesagt hast installiert.
Ab hier läuft XAMPP ohne Probleme und ich habe mich nochmals an das CGI-Script gesetzt.
In der Kopfzeile habe ich nun stehen:
Code: Select all
#!D:\1server\xampp\perl\bin\perl.exe
, nicht wie Dein Vorschlag "/".
Die Pfad-Angaben für infos.pl und data habe ich weggelassen und ab da lief auch das Script.

Ich sage nochmals herzlichen Dank, für die viele Zeit und Mühe die Du mir bei sehr umfangreichen Hilfestellung gegeben hast.

Airis
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Previous

Return to Perl

Who is online

Users browsing this forum: No registered users and 2 guests