XAMPP startet nicht mehr

Alles, was Perl betrifft, kann hier besprochen werden.

XAMPP startet nicht mehr

Postby airis » 19. September 2004 22:52

Sorry hatte zuerst in Perl gepostet!!!!
Hallo Wiedmann,
mein XAMPP startet nach wiedereinstalten des PC's nicht mehr.
Folgende Meldung kommt:
Code: Select all
 
Syntax error on line 1 of D:/server/xampp/apache/conf/perl.conf:
Cannot load /xampp/perl/bin/perl58.dll into sever: Das angegebene Modul wurde nicht gefunden.
Can't start server: Bind on TCP/IP port: No error
040919 23.15.09 Do you already have another mysqld server running on port: 3306?
040919 23.15.09 Aborting
040919 23.15.09 mysql\bin\mysqld.exe: Shutdown Complete
...


Zeile 1 von perl.conf sagt folgendes:
Code: Select all
 LoadFile "/xampp/perl/bin/perl58.dll"


und diese Programmbibliothek ist auch in D:/server/xampp/perl/bin/ vorhanden, keine Ahnung weshalb sie nicht gefunden wird.

Hast Du eine Ahnung was schief läuft.

Viele Grüsse
Airis

[/code]
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Postby Wiedmann » 19. September 2004 23:31

Erstmal vorneweg... hast du MySQL und Apache als Dienst installiert, oder startest du die immer über "xampp_start"?

LoadFile "/xampp/perl/bin/perl58.dll"

Da müssete bei dir eigentlich stehen:
LoadFile "D:/server/xampp/perl/bin/perl58.dll"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby airis » 19. September 2004 23:36

Ich starte über "xampp_start".
Da müssete bei dir eigentlich stehen:
Zitat:
LoadFile "D:/server/xampp/perl/bin/perl58.dll"

nein es beginnt mit "/xampp"
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Postby Wiedmann » 19. September 2004 23:39

nein es beginnt mit "/xampp"

Dann ändere das einfach mal ab.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby airis » 19. September 2004 23:51

hab's geändert, funzt immer noch nicht.
habe nun folgenden Error-Log:
[Mon Sep 20 00:47:02 2004] [error] Can't load Perl file: /xampp/apache/conf/startup.pl for server localhost:0, exiting...

"startup.pl" ist aber vorhanden
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Postby Wiedmann » 19. September 2004 23:56

Nur mal so eine Frage... nach dem einspielen von dem Perl AddOn -ZIP hast du "setup_xampp" aber nochmals ausgeführt und dann den Server neu gestartet?

Can't load Perl file: /xampp/apache/conf/startup.pl for server localhost

Das selbe wie vorher.

Bei dir gibt es die Zeile:
PerlRequire "/xampp/apache/conf/startup.pl"

müsste sein:
Code: Select all
PerlRequire "D:/server/xampp/apache/conf/startup.pl"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby airis » 20. September 2004 00:05

Code:
PerlRequire "D:/server/xampp/apache/conf/startup.pl"

wo kann ich diese Zeile finden?
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Postby Wiedmann » 20. September 2004 00:09

Ist bei mir in der "perl.conf" die 3.Zeile.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby airis » 20. September 2004 00:37

Sorry hat ein´wenig länger gedauert, habe alles nochmal gescheckt und einen Neustart gemacht.
Xampp startet nicht, es kommt jetzt nur noch der Rest aus obiger Meldung:
....Can't start server: Bind on TCP/IP port: No error
040920 1:30:47 Do you already have another mysqld server running on port: 3306?
040920 1:30:47 Aborting
040920 1:30:47 mysql\bin\mysqld.exe: Shutdown Complete
...
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Postby Wiedmann » 20. September 2004 00:50

Ich denke mal das der XAMPP trotzdem läuft (Du bekommst ja auch keinen Prompt, sondern der Cursor blinkt nur). Hast du ein "http://localhost/" getestet?

Die Meldung kommt, weil du vorher nur den Apache beendet hast. MySQL lief aber weiterhin.

Mit "xampp_start" werden aber beide Server gestartet. Der Apache läuft ganz normal hoch, und der MySQL bringt einen Fehler, weil er ja schon läuft.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby airis » 20. September 2004 01:13

habe natürlich alles mögliche ausprobiert, habe auch Apache und MySQL von Hand runtergefahren.
Wenn ich XAMPP über "xampp_start" aufrufe, erscheint das Startfenster mit der bekannten Meldung, das Startfenster schließt dann selbstständig und sonst passiert nichts.
Habe dann den Browser gestartet ("lokalhost")
, gleiche Fehlermeldung. Ebenfalls wenn ich so nur Apache starte.
Beim shutdown über "xampp_stop" kommt folgende Meldung:
Code: Select all
MySQL stop...
Apache killed...
pv: No matching processes found
Attention: Cannot delete the httpd.pid!
mysql\bin\mzsqladmin.exe:connect to server at 'localhost' failed error: 'Can't connect to MySQL server on 'localhost' (10061)
Check that mysqld is running on localhost and that the port is 3306.
You can check this by doing 'telnet localhost 3306'
Apache pid delete ... SHUTDOWN COMPLETE

Irendetwas ist mit MySQL faul, aber was?
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Postby Wiedmann » 20. September 2004 01:26

Hmmm,

Öffne mal den Taskmanager und schau bei "Prozesse" ob es noch Einträge für "Apache.exe" und "mysqld.exe"/"mysqld-nt.exe" gibt. Wenn ja beende diese. Schliesse den Taskmanger wieder.

Mach eine Eingabeaufforderung auf:
Code: Select all
d:
cd \server\xampp
apache_start.bat

Was wird angezeigt?

(Wenn du noch länger auf bist, könnten wir das auch im Chat klären...)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby airis » 20. September 2004 01:47

Code: Select all
D:\>cd\server\xampp

D:\server\xampp>apache_start.bat
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...

D:\server\xampp>

das ist alles, Xampp startet nicht automatisch und von Hand ist es auch nicht möglich.
Bin für den Chat noch nicht eingerichtet, habe gelesen dazu benötigt man einen IRC-Client. Habe bisher noch keinen aus dem Net gezogen, sorry.

Muß langsam auch ins Bett, um 6:30 klinelt der Wecker.
Ich hoffe wir können morgen kontakten.
Bis dann
Airis
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Postby Wiedmann » 20. September 2004 01:55

Eigentlich sieht die Meldung ja gar nicht schlecht aus. Zumindest sieht es so aus als ob der Apache laufen würde... Müsste man dann nur noch einen Browser öffnen und auf "localhost" gehen".

Es würde hier auch einen Webchat geben. Kannst du hier nachlesen:
http://www.apachefriends.org/help.html

Dann aber erst mal eine gute Nacht. Komm gut raus.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby airis » 20. September 2004 10:22

Hi, Wiedmann,

bin zurück und nun kann es wieder los gehen.
Eigentlich sieht die Meldung ja gar nicht schlecht aus. Zumindest sieht es so aus als ob der Apache laufen würde... Müsste man dann nur noch einen Browser öffnen und auf "localhost" gehen".

Tut er aber nicht, es kommt nur das gleiche wie gestern wenn ich über die Eingabeaufforderung gehe erscheint folgendes:
Code: Select all
D:\>cd\server\xampp

D:\server\xampp>apache_start.bat
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...

D:\server\xampp>

und wenn ich dann im Browser "localhost" eingebe kommt ein Fenster mit "DNS Error".

Wenn ich versuche über xampp_start.bat zu gehen erscheint bekanntes Fenster mit folgendem Inhalt:
Code: Select all
Cannot load /xampp/perl/bin/perl58.dll into sever: Das angegebene Modul wurde nicht gefunden.
Can't start server: Bind on TCP/IP port: No error
040922 11:05:32 Do you already have another mysqld server running on port: 3306?
040922 11:05:32 Aborting
040922 11:05:32 mysql\bin\mysqld.exe: Shutdown Complete

Im Task-Manager ist auch nichts zu sehen.
Gibt es eine Error-Log wo mann nachschauen kann?

Airis
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Next

Return to Perl

Who is online

Users browsing this forum: No registered users and 2 guests