Movable Type (Weblog) auf Localhost

Alles, was Perl betrifft, kann hier besprochen werden.

Movable Type (Weblog) auf Localhost

Postby Dreishlaf » 13. June 2004 12:41

Ich habe hier ein riesiges Problem mit einem *.cgi Script vorliegen:

Da ich eine eigene Website in´s Netz stellen möchte, habe ich mich entschieden, ein vorgefertigtes CVS/Blog-System zu nutzen - Movable Type (in CGI) - da ich aber vorher noch das Design anpassen muss usw. will ich die ganze Website erstmal auf dem localhost erstellen und alles testen.

Nun ist aber das Problem, dass ich das Script absolut nicht zum laufen bekomme, was ich auch versuche :(

In der Installationsanweisung wird angegeben, dass man den Server zunächst via mt-check.cgi prüfen soll (ob alle Module da sind usw.) - diese liegt in C:/Xampp/cgi-bin/ und hat den shabang #!C:/Xampp/perl/bin/perl.exe - also so, wie es eigentlich auch sein müsste. Aber beim ausführen meldet der Apache 2.0.49 einen 500 Internal Server Error und im Error.log finde ich dazu folgendes:

[Sun Jun 13 13:32:17 2004] [error] [client 127.0.0.1] Premature end of script headers: mt-check.cgi
[Sun Jun 13 13:32:17 2004] [error] [client 127.0.0.1] Can't locate strict.pm in @INC (@INC contains: .) at C:/Xampp/cgi-bin/mt-check.cgi line 7.\r
[Sun Jun 13 13:32:17 2004] [error] [client 127.0.0.1] BEGIN failed--compilation aborted at C:/Xampp/cgi-bin/mt-check.cgi line 7.\r

Würde man also denken, da fehlt die "strict.pm" - in mt-check.cgi:

use strict;

local $|=1;

my($MT_DIR);
BEGIN {
if ($0 =~ m!(.*[/\\])!) {
$MT_DIR = $1;
} else {
$MT_DIR = './';
}
unshift @INC, $MT_DIR . 'lib';
unshift @INC, $MT_DIR . 'extlib';
}

Eine Datei kann nicht fehlen, da ich mehrere Versionen des CVS mir angesehen habe und nirgendwo is die strict.pm dabei und wenn ich "#" davor setze muss ich noch zwei weitere Funktionen ausklammern, bevor ich überhaupt die HTML Ausgabe des Scripts sehe ... nur ohne Informationen über den Server :(

Was ist zu tun? Ich kenne mich mit CGI absolut nicht aus und brauche daher bitte Eure Hilfe!

Danke,

Ben
Dreishlaf
 
Posts: 2
Joined: 13. June 2004 12:21

Postby Wiedmann » 13. June 2004 13:33

Was ist zu tun? Ich kenne mich mit CGI absolut nicht aus und brauche daher bitte Eure Hilfe!

Installiere das "XAMPP Per1 Addon 1.4.2" von folgerder Seite:
http://www.apachefriends.org/de/xampp-windows.html
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dreishlaf » 13. June 2004 14:02

Also fehlte quasi nur Perl mit seinen eigenen Programm-Bibliotheken? Vielen Dank für die schnelle Antwort ;)
Dreishlaf
 
Posts: 2
Joined: 13. June 2004 12:21


Return to Perl

Who is online

Users browsing this forum: No registered users and 2 guests