How to solve two perls problem?

Alles, was Perl betrifft, kann hier besprochen werden.

How to solve two perls problem?

Postby baijingjiao » 14. February 2010 08:46

I use CentOS 5.3, default installation, there is a perl 5.8.8 at /usr/bin/...;
After I installed Lampp, then there are perls in my system now:
one is perl 5.8.8 at /usr/bin/...
another is perl 5.10.1 at /opt/lampp/bin/...


I installed Bugzilla too, when I was trying to access my Bugzilla using http://localhost/bugzilla/ I got below error information:
Seems the old perl is used (5.8.8), but I need the perl 5.10.1 at /opt/lampp/...
How can I indicate this /opt/lampp/bin/perl to be used by Apache?
--------------------------------below is the error information------------------------------------
Software error:

Can't locate Params/Validate.pm in @INC (@INC contains: . lib/i386-linux-thread-multi lib /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8) at lib/DateTime/Duration.pm line 11.
BEGIN failed--compilation aborted at lib/DateTime/Duration.pm line 11.
Compilation failed in require at lib/DateTime.pm line 45.
BEGIN failed--compilation aborted at lib/DateTime.pm line 45.
Compilation failed in require at Bugzilla/Util.pm line 53.
BEGIN failed--compilation aborted at Bugzilla/Util.pm line 53.
Compilation failed in require at Bugzilla/Hook.pm line 26.
BEGIN failed--compilation aborted at Bugzilla/Hook.pm line 26.
Compilation failed in require at Bugzilla/Config.pm line 37.
BEGIN failed--compilation aborted at Bugzilla/Config.pm line 37.
Compilation failed in require at Bugzilla.pm line 38.
BEGIN failed--compilation aborted at Bugzilla.pm line 38.
Compilation failed in require at /opt/lampp/htdocs/bugzilla/index.cgi line 34.
BEGIN failed--compilation aborted at /opt/lampp/htdocs/bugzilla/index.cgi line 34.

For help, please send mail to the webmaster (you@example.com), giving this error message and the time and date of the error.
baijingjiao
 
Posts: 6
Joined: 09. February 2010 08:17

Re: How to solve two perls problem?

Postby Wiedmann » 15. February 2010 16:45

Seems the old perl is used (5.8.8), but I need the perl 5.10.1 at /opt/lampp/...
How can I indicate this /opt/lampp/bin/perl to be used by Apache?

http://en.wikipedia.org/wiki/Shebang_%28Unix%29
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to Perl

Who is online

Users browsing this forum: No registered users and 2 guests