require-Anweisung wird nicht ausgeführt.

Alles, was Perl betrifft, kann hier besprochen werden.

require-Anweisung wird nicht ausgeführt.

Postby Murray » 04. January 2004 15:18

Hallo erstmal @all!
Ich habe ein grosses Problem.
Ich habe mehrere Skripte in Perl geschrieben, worin ich aber sehr oft (sollte oop-mässig aussehen) mittels der require - Anweisung externe *.pl-Dateien einbinde. Nun, Skripte die vollkommen ohne diese Anweisung sind funktionieren ohne Probleme. Sobald ich aber den require benutze kommt immer folgende Fehlermeldung:

Code: Select all
Serverfehler!
Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist.

Fehlermeldung:
Can't locate header.pl in @INC (@INC contains: C:/wampp2/perl/site/lib/Apache2 C:/wampp2/perl/lib C:/wampp2/perl/site/lib . C:/wampp2/apache/ C:/wampp2/apache/lib/perl) at C:/wampp2/cgi-bin/cmgb.pl line 3.


Leider habe ich nun keinen Plan mehr, wie ich das configurieren muss bzw. was da bei mir falsch ist.

Bin für jede schnelle Hilfe sehr dankbar!

Meine Apache-Daten:
Apache/2.0.46 (Win32) mod_perl/1.99_10-dev Perl/v5.8.0 mod_ssl/2.0.46 OpenSSL/0.9.7b PHP/4.3.2
(Das ist ein Packed von wampp2)

Grüsse und danke für Hilfe.
Murray
Murray
 
Posts: 2
Joined: 04. January 2004 15:11

Postby Straffi » 05. January 2004 11:00

Moin Murray,

ganz kurz:
http://perl-seiten.bei.t-online.de/perl/perl_perl.html


mfg straffi
User avatar
Straffi
 
Posts: 120
Joined: 07. October 2003 17:48


Return to Perl

Who is online

Users browsing this forum: No registered users and 5 guests

cron