Bugzilla

Alles, was Perl betrifft, kann hier besprochen werden.

Bugzilla

Postby ilsaul » 09. October 2009 12:44

Hi,
i want to install bugzilla but the installation ask me to install some module on perl.

i need to add a repository and bugzilla sugest me to use this command:
ppm repo add theory58S http://cpan.uwinnipeg.ca/PPMPackages/10xx/
i try and the result is:
Unknown or ambiguous command 'repo'; type 'help' for commands.
then i see the help but i cann't find a mode to add a repo.

what can i do?

NB.: i use xampp 1.7.2

bye
ilsaul
 
Posts: 3
Joined: 10. September 2009 16:30

Re: Bugzilla

Postby Wiedmann » 09. October 2009 13:14

to install some module on perl.

Which modules?

i need to add a repository and bugzilla sugest me to use this command:

You can install packages in ppm with:
Code: Select all
install http://cpan.uwinnipeg.ca/PPMPackages/10xx/packagename.ppd

(just replace packagename with the package you want)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Bugzilla

Postby ilsaul » 09. October 2009 13:45

Hi,

thx for your answer. With your suggest I install half modules, but unfortunately I have some problem to install the following modules:

COMMANDS TO INSTALL OPTIONAL MODULES:

Chart: ppm install Chart
PatchReader: ppm install PatchReader
PerlMagick: ppm install PerlMagick
perl-ldap: ppm install perl-ldap
RadiusPerl: ppm install RadiusPerl
HTML-Scrubber: ppm install HTML-Scrubber
Email-MIME-Attachment-Stripper: ppm install Email-MIME-Attachment-Stripper
TheSchwartz: ppm install TheSchwartz
Daemon-Generic: ppm install Daemon-Generic

COMMANDS TO INSTALL REQUIRED MODULES (You *must* run all these commands
and then re-run checksetup.pl):

ppm install DateTime
ppm install DateTime-TimeZone
ppm install Template-Toolkit

more of the module that i can't install have the follow error:
Installing package 'http://cpan.uwinnipeg.ca/PPMPackages/10xx/Chart.ppd'...
Element 'IMPLEMENTATION' cannot contain a child element 'REQUIRE' at D:/xampp/perl/site/lib/PPM.pm line 1677.
Can't locate object method "rvalidate" via package "PPM::XML::PPD::REQUIRE" at D:/xampp/perl/site/lib/PPM/XML/ValidatingElement.pm line 38.

bye
ilsaul
 
Posts: 3
Joined: 10. September 2009 16:30

Re: Bugzilla

Postby beuy » 14. December 2009 03:06

Hi ilsual,

This is probably to late but the problem is that the supplied PPM application with XAMPP is out of date (version 2), and doesn't include support for the child element "REQUIRE".

I am currently trying to work out a workaround for this myself. Besides already raising a bug on the XAMPP bugtracker, I am doing a bit of research into how to get a later version of PPM up and running within the XAMPP enviroment (only solution I have found thus far is to install a later version of ActivePerl but that causes a number of the pre complied configuration files within XAMPP to become incorrect).

Regards,
beuy
 
Posts: 1
Joined: 25. November 2009 07:13

Re: Bugzilla

Postby ilsaul » 24. January 2010 19:35

I found a workaround ... use Mantis :D

It's make in PHP and it's very beautiful!

But i find some problem with the http (Apache) some time frize.

bye
ilsaul
 
Posts: 3
Joined: 10. September 2009 16:30


Return to Perl

Who is online

Users browsing this forum: No registered users and 1 guest