problem mit CGIProxy

Alles, was Perl betrifft, kann hier besprochen werden.

problem mit CGIProxy

Postby Hanjo » 30. November 2003 11:55

Hi,

ich wollte auf meinem Windows XAMPP dieses Skript installieren: http://www.jmarshall.com/tools/cgiproxy/ , aber bekomme immer den Fehler "500 Internal Server Error": http://hanjo.is-a-geek.net/cgi-bin/nph-proxy.pl
An dem Skript liegt es jedoch nicht, das läuft auf einem anderen Rechner (allerdings Linux) ganz flott. Ich hoffe ihr könnt mir da helfen, ich habe von Perl nämlich Keine AHnung :-P

Vielen Dank

Hanjo

PS: Sonst funktioniert Perl natürlich: http://hanjo.is-a-geek.net/cgi-bin/perltest.cgi
Hanjo
 
Posts: 18
Joined: 30. November 2003 11:01

Postby TTP » 30. November 2003 15:14

danke so n Script hab ich schon imma gesucht xD

Bei mir funktioniert es wunderbar!


Haste in der ersten reihe vom Script den Perl Pfard eingegeben?

meiner ist z.B. #!F:\xampp1.1\xampp\perl\bin\perl.exe ;)
User avatar
TTP
 
Posts: 310
Joined: 30. August 2003 19:38
Location: Wolfsburg

Postby Hanjo » 30. November 2003 18:22

Ja, habe ich eingegeben (#!C:\Programme\XAMPP\perl\bin\perl.exe), funktioniert aber nicht...
Hanjo
 
Posts: 18
Joined: 30. November 2003 11:01

Postby Hanjo » 30. November 2003 18:26

Muss mich korrigieren, habe die Datei umbenannt (pl -> cgi) und jetzt geht's

aber danke trotzdem...
Hanjo
 
Posts: 18
Joined: 30. November 2003 11:01

Bei mir läufts nicht! :-(

Postby CDrewing » 17. July 2004 00:52

Also:

Perl-Interpreter in C:\Programme\apachefriends\xampp\perl\bin\perl.exe
CgiProxy in C:\Programme\apachefriends\xampp\cgi-bin\nph-proxy.cgi

In der cgi Datei steht mein Interpreter:
#!C:\Programme\apachefriends\xampp\perl\bin\perl.exe#

Und dennoch erhalte ich den 500er Fehler.


Was mache ich falsch?

Auch wenn ich die Datei in cgi-proxy.cgi umbenenne, ändert sich nichts.

Danke, Christian.
CDrewing
 
Posts: 3
Joined: 17. July 2004 00:26
Location: Berlin

Postby Wiedmann » 17. July 2004 09:53

#!C:\Programme\apachefriends\xampp\perl\bin\perl.exe#

Das letzte "#" ist zuviel.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby CDrewing » 17. July 2004 10:13

Das letzte "#" ist zuviel.



Steht da aber so:

#!C:\Programme\apachefriends\xampp\perl\bin\perl.exe#
# CGIProxy 2.0.1
#
# nph-proxy.cgi-- CGIProxy 2.0.1: a proxy in the form of a CGI script.
# Retrieves the resource at any HTTP or FTP URL, updating embedded URLs
# in HTML resources to point back through this script. By default, no
# user info is sent to the server. Options include text-only proxying
# to save bandwidth, cookie filtering, ad filtering, script removal,
# user-defined encoding of the target URL, and more. Requires Perl 5.
#
# Copyright (C) 1996, 1998-2002 by James Marshall, james@jmarshall.com
# All rights reserved.
#
# For the latest, see http://www.jmarshall.com/tools/cgiproxy/
#
# ...



Und nun?

[/i]
CDrewing
 
Posts: 3
Joined: 17. July 2004 00:26
Location: Berlin

Hilft auch nichts

Postby CDrewing » 19. July 2004 18:34

Hier ist übrigens das Errorlog:

| [Sat Jul 17 14:37:49 2004] [error] [client 127.0.0.1] BEGIN
failed--compilation aborted at
C:/Programme/apachefriends/xampp/cgi-bin/nph-proxy.cgi line 149.\r
| [Sat Jul 17 14:37:50 2004] [error] [client 127.0.0.1] Can't locate
strict.pm in @INC (@INC contains: .) at
C:/Programme/apachefriends/xampp/cgi-bin/nph-proxy.cgi line 149.\r

Und in Line 149 steht:

use strict ;

Und jetzt?
CDrewing
 
Posts: 3
Joined: 17. July 2004 00:26
Location: Berlin

Postby Saxman25 » 29. July 2004 15:29

ja, das problem hab ich auch.

perl hat ne variable @INC (also das ist eigentlich ein hash, aber das tut nix zur sache).

darin stehen alle pfade, die der interpreter durchsucht, um angeforderte ("use") module zu finden.

vielleicht steht das verzeichnis, in dem XAMPP seine perlmodule hat, da nicht drin?!

ich fahre LAMPP unter linux (mandrake.X) und habe ein ähnliches problem: nachträglich per CPAN (ja, ich habe das cpan aus dem %LAMPPROOT%/bin/ genommen) installierte module werden nicht gefunden.

ein blick auf die (glücklicherweise mit dem fehler angezeigte) @INC zeigte, daß nur die linux-eignen perl-pfade darin stehen, aber kein verweis auf LAMPP.

eine weitere suche im LAMPPverzeichnis zeigte dann, daß die angeblich nicht vorhandenen module schon da sind. selbst die, die ich noch gar nicht mit CPAN installiert hatte.

ich habe aber keine ahnung, wie man die @INC ändert.
Saxman25
 
Posts: 3
Joined: 29. July 2004 14:30

UPDATED INFORMATION !!

Postby Saxman25 » 29. July 2004 16:05

also wie man @INC ändert, weiß ich immer noch nicht, aber mein problem ist gelöst und lag an was anderem:

der fehler kam bei "perl xyz.pl".
offenbar griff das auf das "linux-perl" zu.

bei eingabe von %LAMPROOT%/bin/perl xyz.pl gabs keine beschwerden mehr über fehlende pakete.
Saxman25
 
Posts: 3
Joined: 29. July 2004 14:30


Return to Perl

Who is online

Users browsing this forum: No registered users and 2 guests