mod_perl Problem, Apache2 startet nicht mehr

Alles, was Perl betrifft, kann hier besprochen werden.

mod_perl Problem, Apache2 startet nicht mehr

Postby ArcVieh » 24. February 2008 18:22

Guten Abend,
ich verwende auf einem Ubuntu 6.06 System einen selbstkompilierten Apachen mit der Apache Konfiguration (/usr/local/apache2) und habe ebenfalls das mod_perl Module selbstkompiliert und eingebunden.
Doch nun startet der Apache nicht mehr, aus den Errorlogs lässt sich folgendes entnehmen:

[Sun Feb 24 18:17:46 2008] [error] Can't load module APR::Request : wrong libapr major version (expected 0, saw 1) at /usr/lib/perl/5.8/DynaLoader.pm line 245.\nCompilation failed in require at /usr/lib/perl5/Apache2.pm line 26.\nBEGIN failed--compilation aborted at /usr/lib/perl5/Apache2.pm line 26.\nCompilation failed in require at (eval 2) line 3.\n
[Sun Feb 24 18:17:46 2008] [error] Can't load Perl module Apache2 for server blubb:0, exiting...


Ich kann damit nichts anfangen und fühl mich auch nicht mächtig das Problem zu beheben. Kann mir hier jemand weiterhelfen?


Grüße,
ArcVieh
ArcVieh
 
Posts: 1
Joined: 24. February 2008 18:20

Postby Scory » 04. March 2008 21:35

Mache es rückgängig und benutze Perl ganz normal im CGI-Modus.
Scory
 


Return to Perl

Who is online

Users browsing this forum: No registered users and 3 guests