Perl und XJ!

Alles, was Perl betrifft, kann hier besprochen werden.

Perl und XJ!

Postby apachetom » 04. November 2007 19:59

Hello 2gether,

ich habe eine XJ! Installation, also eine "Sonderversion" von XAMPP Lite incl. Joomla 1.0.12 auf meinem Win XP- PC und soweit läuft die Software auch prima.

Hier übrigens nochmal Danke an die Entwickler, Ihr habt damit eine Super Vereinfachung für Joomla- Leute geschaffen!

Nun wollte ich mal ein anderes Projekt bearbeiten, wofür ich Perl bräuchte und habe zum ausprobieren die pertest.cgi im cgi-bin aufgerufen, die einen einfachen perlcode enthält.

Dieses Script läuft aber nicht, d.h. es wird nicht der beabsichtigte Code sondern alle Scriptinhalte als text ausgegeben.
Offenbar arbeitet der Interpreter nicht wie er soll oder die perl.exe (der Pfad dorthin stimmt im Script) hat ein Problem.

Da ich ohnehin wohl nicht auf Dauer mit einem MiniPerl auskomme, möchte ich nun eine komplette Perl- Installation auf dem PC durchführen, die später mit dem ja bereits vorhandenen Apache läuft.

Meine Frage: Gibts dazu ein Paket oder eine Anleitung oder kann ich ggf ein anderes Paket (aus einer XAMPP- Inst.) verwenden?

Ggf hatte mal jemand das gleiche Problem und kann mir helfen.

Ansonsten bliebe nur eine Deinstallation von XJ! und eine WAMP - Installation übrig, oder?

Für Eure Antwort wäre ich Euch echt dankbar,

LG

Tom
apachetom
 
Posts: 2
Joined: 04. November 2007 19:39

Postby Scory » 07. November 2007 12:30

Nein, brauchst nichts zu löschen.

Du kannst jedes Perl benutzen (es gibt einige inzwischen), das angeblich portabelste ist von ActiveState http://www.activestate.com/Products/activeperl/

Das installierst Du einfach, dann schaust Du nach, WO es gelandet ist (beispielsweise in c:\programme\activestate\perl, oder auch nur c:\perl), das legst Du wahrscheinlich bei der Installation fest.

Dort mußt Du das Modul perl.exe finden (das wahrscheinlich im Unterordner bin liegt - aber das weiss ich nicht). Vielleicht heißt es auch perlw.exe (für Windows) oder so - aber das findest Du sicher sehr schnell.

Dann editierst Du Deine Apache Konfigurationsdatei httpd.conf (wo die liegt - musst Du selbst suchen!) und suchst dort mal nach "cgi" bzw. "cgi-bin". Wahrscheinlich sind die Zeilen vorhanden, aber mit "#" auskommentiert. Aktiviere diese Zeilen, anschließend starte Apache neu (wichtig!).

Zum Schluss editierst Du noch perltest.cgi und änderst die erste Zeile ab (die heißt "Shebang"-Zeile"), wo ungefähr so etwas drin stehen könnte:

#!"C:\Programme\xampp\perl\perl.exe"

Dort schreibst Du stattdessen den ganzen Pfadnamen von dem ActiveState-Perl hinein, was Du als erstes installiert hast.

Wenn Du alles richtig gemacht hast, sollte via http://www.deinrechner.de/cgi-bin/perltest.cgi das Script funktionieren.

Wenn Fehler auftauchen, frag hier wieder nach (wenn Du die Lösung nicht selbst findest).

Falls Du aber schon irgendwo ein perl.exe hast (bei Xampp Lite ist es eigentlich NICHT dabei), kannst Du auch diese benutzen. Das Problem, was Du momentan hast (der Quelltext von Perl im Browser), liegt nur daran, dass in der httpd.conf cgi-Scripte nicht richtig aktiviert sind (weil nur PHP aktiv ist).

Grüße
Scory
Scory
 

Postby apachetom » 07. November 2007 15:26

Hi Scory,

erstmal vielen Dank für Deine Antwort, und...

GCI with MiniPerl
CGI with MiniPerl is ready ...


Yipiieh, das war ja einfach :D

Ich hatte sogar schon die httpd.conf bearbeitet, aber scheinbar nicht alles richtig.

Super, dass es klappt, Merci.

Die nächste Herausforderung werden nun sicher einige Module sein, die ich brauche, zB DBI etc.

Dazu werd ich dann mal eine activestate - Installation machen, die sollte das mitbringen.

Liebe Grüße

Tom
apachetom
 
Posts: 2
Joined: 04. November 2007 19:39


Return to Perl

Who is online

Users browsing this forum: No registered users and 1 guest

cron