Perl funktioniert nicht mehr

Alles, was Perl betrifft, kann hier besprochen werden.

Perl funktioniert nicht mehr

Postby wneudeck » 11. October 2007 07:45

Hallo,
ich hatte (nach Hilfestellung im Forum hier) eine einwandfrei funktionierende Installation von Xampp und Perl (addon).
Nun habe ich ein Update von 1.6.3 auf Xampp 1.6.4 gemacht und stelle folgendes fest:
- mysql, PHP und phpmyadmin funktionieren einwandfrei
- was nicht mehr geht, ist Perl
Wenn ich ein Perl-Test Skript auf rufe (aus dem Programm mysqldumper) kommt nur noch "warten auf localhost" und dann "Fehler: Verbindung unterbrochen...."
Wenn ich das xampp Control-Panel aufrufe und dort bei Apache den Admin, so kann ich den Menüpunkt "Status" nicht mehr aufrufen, es ist genauso wie beim Perl-Test.
Wenn ich dagegen unter "Demos" den Punkt Perl aufrufe, so wird mir angezeigt "Perl 5.8.8"
Dort ist ja auch ein Link
http://localhost/perl/modperl.pl
angegeben, der ebenso wenig geht wie mein eigenes perl-test-Skript.
Wie gehe ich nun am besten vor, um das Problem zu lösen?
Soll ich das Perl-Addon 5.8.8.-2.2.4 einfach nochmals installieren und ist es überhaupt ein perl-Problem oder stimmt doch mit xampp selbst etwas nicht mehr?
Tschüss Werner
Nachtrag:
Habe gerade folgendes gelesen:
MOD_PERL Warnung: Aufgrund diverser Anpassungen in der Source des Apache 2.2.6 funktioniert hiermit NICHT mehr mod_perl (win32). Dem Apache httpd Entwickler-Team scheint das Problem bekannt zu sein. Sie wollen das Problem mit der Version 2.2.7 fixen. Übrigens: Mod_JK (Tomcat 6.0.13 Addons) funktioniert mit Apache 2.2.6 problemlos.

Kann das der Grund sein? Und was dann? Abwarten?
wneudeck
 
Posts: 95
Joined: 31. July 2006 11:04

Postby Wiedmann » 11. October 2007 10:34

Und was dann?

Du kannst mod_perl ja mit der "setup_xampp.bat" abschalten. (Damit wird Perl dann als CGI ausgeführt).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby wneudeck » 11. October 2007 11:56

Hallo,
jetzt setzt wieder mal mein Verständnisproblemein.
Habe mit setup_xampp.bat die Konfiguration mit mod_perl abgeschaltet (2) --> Ergebnis: Ich kann im ControlPanel den Status wieder abrufen (hurra) und sehe: Die ersten 5 Menüpunkte (mysqlDatenbank bis serverSideIncludes) sind aktiviert (perl mit mod_perl ist deaktiviert).
Nun kann ich aber das perlskript nicht mehr aufrufen, das ich aber für eine Datensicherung bräuchte.
Daraufhin habe ich nochmals aufgerufen "configure with mod_perl (1), aber im Statusfenster ändert sich nichts (mod_perl bleibt deaktiviert)
Und wenn ich nun versuchsweise nochmal das Perl-Addon installieren will, sagt das Installationsprogramm:
Apache Version 2.2.4 not found (klar, ich habe ja auch 2.2.6) Need Xampp Version 1.6 (ich habe aber 1.6)
Wenn ich das richtig sehe, wäre ich besser bei xampp 1.6.3 geblieben, oder?
Bleibt also immer noch die Frage, was ich jetzt machen kann, um mein perl wieder zum Laufen zu bringen.
Tut mir leid, wenn das posting so lang wird, aber ich denke, diese Infos sind nötig.
wneudeck
 
Posts: 95
Joined: 31. July 2006 11:04

Postby Wiedmann » 11. October 2007 12:02

Nun kann ich aber das perlskript nicht mehr aufrufen, das ich aber für eine Datensicherung bräuchte.

Wieso nicht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby wneudeck » 11. October 2007 12:40

Hallo,
es kommt nach Aufruf im Browser die Meldung:
Serverfehler!
Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist.
Fehlermeldung:
couldn't create child process: 720003: perltest.pl
Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
wneudeck
 
Posts: 95
Joined: 31. July 2006 11:04

Postby Wiedmann » 11. October 2007 12:55

Serverfehler!

Was steht im "error.log"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby wneudeck » 11. October 2007 13:07

Hallo,
[Thu Oct 11 13:11:00 2007] [notice] Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.4 configured -- resuming normal operations
[Thu Oct 11 13:11:00 2007] [notice] Server built: Sep 21 2007 00:29:38
[Thu Oct 11 13:11:00 2007] [notice] Parent: Created child process 3236
[Thu Oct 11 13:11:01 2007] [notice] Child 3236: Child process is running
[Thu Oct 11 13:11:01 2007] [notice] Child 3236: Acquired the start mutex.
[Thu Oct 11 13:11:01 2007] [notice] Child 3236: Starting 250 worker threads.
[Thu Oct 11 13:11:01 2007] [notice] Child 3236: Starting thread to listen on port 443.
[Thu Oct 11 13:11:01 2007] [notice] Child 3236: Starting thread to listen on port 80.
[Thu Oct 11 13:32:33 2007] [error] [client 127.0.0.1] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't create child process: 720003: perltest.pl, referer: http://localhost/mysqldumper/filemanage ... ction=dump
[Thu Oct 11 13:32:33 2007] [error] [client 127.0.0.1] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't spawn child process: C:/xampp/cgi-bin/perltest.pl, referer: http://localhost/mysqldumper/filemanage ... ction=dump
[Thu Oct 11 13:39:34 2007] [error] [client 127.0.0.1] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't create child process: 720003: simpletest.pl, referer: http://localhost/mysqldumper/filemanage ... ction=dump
[Thu Oct 11 13:39:34 2007] [error] [client 127.0.0.1] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't spawn child process: C:/xampp/cgi-bin/simpletest.pl, referer: http://localhost/mysqldumper/filemanage ... ction=dump
[Thu Oct 11 13:43:33 2007] [error] [client 127.0.0.1] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't create child process: 720003: perltest.pl, referer: http://localhost/mysqldumper/filemanage ... ction=dump
[Thu Oct 11 13:43:33 2007] [error] [client 127.0.0.1] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't spawn child process: C:/xampp/cgi-bin/perltest.pl, referer: http://localhost/mysqldumper/filemanage ... ction=dump

Muss dazu bemerken, dass ich im aufrufenden Programm mysqldumper als Pfad
../../cgi-bin/
angegeben habe, da sich der mysqldumper in
c:\xampp\htdocs\mysqldumper
befindet. (hatte zuvor jedenfalls funktioniert)
wneudeck
 
Posts: 95
Joined: 31. July 2006 11:04

Postby Wiedmann » 11. October 2007 13:54

Code: Select all
[Thu Oct 11 13:32:33 2007] [error] [client 127.0.0.1] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't create child process: 720003: perltest.pl

Was steht in der ersten Zeile der "perltest.pl"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby wneudeck » 11. October 2007 14:03

Hallo,
#!/usr/bin/perl -w
und natürlich auch in der Datei, die ich eigentlich brauche, nämlich crondump.pl
wneudeck
 
Posts: 95
Joined: 31. July 2006 11:04

Postby Wiedmann » 11. October 2007 14:22

Code: Select all
#!/usr/bin/perl -w

Wie man es schon vermuten könnte, steht dort der Pfad zum Perl das benutzt werden soll. Auf deinem System gibt es dann also wohl keine "perl.exe" im Verzeichnis "C:\usr\bin\".

Bei deinem XAMPP sollte das dann IMHO so aussehen:
Code: Select all
#!"C:\xampp\perl\bin\perl.exe"


BTW: In der "perltest.cgi", die beim XAMPP dabei ist, sollte das aber schon so vorgemacht sein.

und natürlich auch in der Datei, die ich eigentlich brauche, nämlich crondump.pl

Das man diese Zeile anpassen muss, sollte eigentlich in der Doku zu diesem Programm stehen...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby wneudeck » 11. October 2007 14:37

Hallo,
ja, danach ist man immer schlauer. Es funktioniert, wieder mal herzlichen Dank.
Muss sagen, ich bin gar nicht auf den Einfall gekommen, in die perltest.cgi zu sehen (dort steht der Pfand natürlich drin, wie Du gesagt hast), denn bisher hat es immer funktioniert, obwohl ich noch nie ein Verzeichnis "C:\usr\bin\" hatte.
Nachtrag:

Das man diese Zeile anpassen muss, sollte eigentlich in der Doku zu diesem Programm stehen.

Nein, habe ich nichts gefunden, die Doku dieses eigentlich vorzüglichen Programms ist in meinen Augen etwas unübersichtlich.
wneudeck
 
Posts: 95
Joined: 31. July 2006 11:04


Return to Perl

Who is online

Users browsing this forum: No registered users and 1 guest