kann keine cgi Scripte ausführen

Alles, was Perl betrifft, kann hier besprochen werden.

kann keine cgi Scripte ausführen

Postby horstschulz » 14. February 2007 13:32

System Win2000 Prof, Sp4
xampp 1.5.5

von der Startseite xampp kann ich nicht unter den Punkt CGI / perltest.cgi ausführen, und auch keine anderen Programm mit .cgi

es folgt die Fehlermeldung:
"Serverfehler!
Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist.

Fehlermeldung:
couldn't create child process: 720193: env.cgi

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

Error 500
localhost
02/14/07 13:12:11
Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.0 mod_perl/2.0.2 Perl/v5.8.8
"

in error.log finde ich :
"[Wed Feb 14 13:07:22 2007] [error] [client 127.0.0.1] (OS 193)%1 ist keine zulässige Win32-Anwendung. : couldn't spawn child process: D:/programme/xampp/cgi-bin/perltest.cgi
[Wed Feb 14 13:07:27 2007] [error] [client 127.0.0.1] (OS 193)%1 ist keine zulässige Win32-Anwendung. : couldn't create child process: 720193: perltest.cgi
[Wed Feb 14 13:07:27 2007] [error] [client 127.0.0.1] (OS 193)%1 ist keine zulässige Win32-Anwendung. : couldn't spawn child process: D:/programme/xampp/cgi-bin/perltest.cgi
[Wed Feb 14 13:07:34 2007] [error] [client 127.0.0.1] (OS 193)%1 ist keine zulässige Win32-Anwendung. : couldn't create child process: 720193: perltest.cgi
[Wed Feb 14 13:07:34 2007] [error] [client 127.0.0.1] (OS 193)%1 ist keine zulässige Win32-Anwendung. : couldn't spawn child process: D:/programme/xampp/cgi-bin/perltest.cgi
[Wed Feb 14 13:07:35 2007] [error] [client 127.0.0.1] (OS 193)%1 ist keine zulässige Win32-Anwendung. : couldn't create child process: 720193: perltest.cgi
[Wed Feb 14 13:07:35 2007] [error] [client 127.0.0.1] (OS 193)%1 ist keine zulässige Win32-Anwendung. : couldn't spawn child process: D:/programme/xampp/cgi-bin/perltest.cgi
[Wed Feb 14 13:12:11 2007] [error] [client 127.0.0.1] (OS 193)%1 ist keine zulässige Win32-Anwendung. : couldn't create child process: 720193: env.cgi
[Wed Feb 14 13:12:11 2007] [error] [client 127.0.0.1] (OS 193)%1 ist keine zulässige Win32-Anwendung. : couldn't spawn child process: D:/programme/xampp/htdocs/env.cgi
"

und bei Status:
"Common Gateway Interface (CGI) DEAKTIVIERT "

ich habe keine Ahnung wie ich darüber weg komme!
ich hasse Streß
Horst
horstschulz
 
Posts: 71
Joined: 29. December 2002 11:38
Location: Stade

couldn't create child process

Postby stonycom » 18. March 2007 11:20

hab soeben folgendes installiert:
xampp 1.6.0a
perl 5.8.8-2.2.4

perltest.cgi sagt folgendes:
GCI with MiniPerl
CGI with MiniPerl is ready ...

führe ich andere cgi's in xampp-unterordnern aus, passiert das:

Serverfehler!
Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist.

Fehlermeldung:
couldn't create child process: 720003: admin.cgi


Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

Error 500
localhost
03/18/07 17:15:14
Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.1 mod_perl/2.0.3 Perl/v5.8.8



XAMPP-Status:
MySQL-Datenbank AKTIVIERT
PHP AKTIVIERT
HTTPS (SSL) AKTIVIERT
Common Gateway Interface (CGI) AKTIVIERT
Server Side Includes (SSI) AKTIVIERT
Perl mit mod_perl AKTIVIERT
SMTP Server AKTIVIERT
FTP Server AKTIVIERT



hoffe auf baldige hilfe / unterstützung. danke im voraus

bruno

p.s.: xampp ist ganz tolle sache!
stonycom
 
Posts: 1
Joined: 18. March 2007 07:06


Return to Perl

Who is online

Users browsing this forum: No registered users and 2 guests