Perl-Script wird bei erneutem Aufruf nicht neu geladen

Alles, was Perl betrifft, kann hier besprochen werden.

Perl-Script wird bei erneutem Aufruf nicht neu geladen

Postby kruemelchen » 06. July 2006 12:32

Hallo zusammen,

nach intensivem Studium eures Forums habe ich leider nichts passendes zu meinem Problem gefunden und muss nun wohl doch selber posten. :wink:

Folgendes habe ich versucht:
Ein Link im Perl-Script ruft das gleiche Perl-Script wieder auf, jedoch hat sich der Wert des Übergabe-Parameters geändert.
Lass ich dies auf dem Server meines Hosters laufen, funktioniert das ganze (also der geändert Wert wird erkannt).
Lass ich das ganze lokal laufen, wird der geändert Parameter-Wert NICHT erkannt.
Konkretes Beispiel:
Link auf der Seite ruft folgende Adresse auf:
Code: Select all
http://localhost/cgi-bin/gb/gaestebuch.pl?seite=1

Ursprungs-Link war der folgende:
Code: Select all
http://localhost/cgi-bin/gb/gaestebuch.pl?seite=2


Ich lass mir auf der Seite momentan nur die URL ausgeben. Diese ändert sich jedoch nicht. Es wird also auch nach Aufruf des Links
Code: Select all
http://localhost/cgi-bin/gb/gaestebuch.pl?seite=1

immer noch die URL
Code: Select all
http://localhost/cgi-bin/gb/gaestebuch.pl?seite=2

ausgegeben.

Meine Vermutung ist, dass mein Apache nicht korrekt konfiguriert ist, da bei meinem Hoster das ganze wie gewünscht funktioniert...
Wie muss ich meinen Apache konfigurieren, dass er die *.pl-Dateien jedesmal neu erzeugt, und mir nicht eine Seite aus dem Cache gibt?
Meine Versuche, die *.conf-Dateien entsprechend anzupassen, waren bis jetzt erfolglos... :cry:

Danke und Gruß
kruemelchen
kruemelchen
 
Posts: 2
Joined: 06. July 2006 11:50

Postby kruemelchen » 07. July 2006 08:00

Nachtrag zu meinem verwendeten XAMPP und Perl:

Bei mir läuft XAMPP 1.5.3a mit Perl 5.8.7-2.2.2
kruemelchen
 
Posts: 2
Joined: 06. July 2006 11:50


Return to Perl

Who is online

Users browsing this forum: No registered users and 1 guest