Nach Perl AddOn funtzt Apache nicht mehr !!!!!

Alles, was Perl betrifft, kann hier besprochen werden.

Nach Perl AddOn funtzt Apache nicht mehr !!!!!

Postby TrippleEx » 18. February 2006 21:02

Hallo Leute,

nach Perl AddOn installtion started Apache nicht mehr.

Habe nach der installation "setup_xampp.bat" für die Aktualisierung der Konfiguration (1) gestartet.

Nun startet Apache nicht mehr, ich bekomme folgende fehlermeldung:

Image


Das mod_perl.so ist jedoch in dem entsprechnen Verzeinis vorhanden.

Was stimmt hier nicht ?! Was mache ich falsch.
TrippleEx
 
Posts: 13
Joined: 19. June 2005 13:35

Postby kvo » 04. March 2006 20:50

Hallo!

ja, deshalb gab es eine pl3-Version. Ich hatte das falsche Modul integriert. Und zwar eines von meiner Apache2-Kompilation, vergaß aber, das im 1.5.1 XAMPP die Übersetzung von Wiedmann enhalten ist.

Die Lösung zum Problem:
1) mod-perl.so von http://www.cvs-for-all.de/xampp/modperl/220-587815/
downloaden und mit xampp/apache/modules/mod_perl.so ersetzen
2) Apache Neustart

Wie "Bruce" von Germanys Next Topmodel treffend sagte:
"Ich bin nisch glucklisch!".
User avatar
kvo
Apache Friends
 
Posts: 184
Joined: 24. January 2003 14:03
Location: Berlin

Postby TrippleEx » 05. March 2006 12:38

Kanns immer noch nicht Starten !!!!

inder der error.log von apache steht drin:

Code: Select all
[Sun Mar 05 12:36:12 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sun Mar 05 12:36:12 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sun Mar 05 12:36:12 2006] [error] Can't load Perl file: G:/xampp/apache/conf/extra/startup.pl for server localhost:80, exiting...


Hab jetzt allerding das gezippte XAMMP auf Laufwerk G. Kanns damit zusammenhängen, das der Pfad irgendwie nicht stimmt ?
TrippleEx
 
Posts: 13
Joined: 19. June 2005 13:35

Postby Mr. Death » 07. March 2006 21:15

Habe jetzt leider das selbe Problem.

Habe xampp 1.5.1 und gerade die "xampp-perl-addon-5.8.7-2.2.0-pl2-installer.exe" ausgführt. Soweit alles klar. Jetzt startet der Apache nicht mehr. Habe die mod_perl.so auch schon ausgetauscht. Keine Änderung. Nach mehrmaligen Startversuchen bringt er mir folgende Meldung:

Image

Die Datei gibt es aber im Verzeichnis C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322

Hier noch das apache error.log

Hier auch noch die startup.pl die er nicht laden kann:

Code: Select all
#file:startup.pl
#---------------

# enable if the mod_perl 1.0 compatibility is needed
# use Apache2::compat ();

# preload all mp2 modules
# use ModPerl::MethodLookup;
# ModPerl::MethodLookup::preload_all_modules();

use ModPerl::Util (); #for CORE::GLOBAL::exit

use Apache2::RequestRec ();
use Apache2::RequestIO ();
use Apache2::RequestUtil ();

use Apache2::ServerRec ();
use Apache2::ServerUtil ();
use Apache2::Connection ();
use Apache2::Log ();

use APR::Table ();

use ModPerl::Registry ();

use Apache2::Const -compile => ':common';
use APR::Const -compile => ':common';

use CGI ();

1;


Was habe ich falsch gemacht?

OS: Windows 2003 Server

Gruss
Markus
Es gibt keine dummen Fragen, nur dumme Antworten.
User avatar
Mr. Death
 
Posts: 30
Joined: 11. January 2006 13:17
Location: Bayern

Echt Sch**ß Support !!!!!!

Postby TrippleEx » 12. March 2006 01:54

Hey Leute ich muss das jetzt einfachmal loswerden !!!

Ich finde den Support einfach Sch**ße, hier wird einem so gut wie garnicht geholfen.

Keine ahnung ob das die Aroganz gegenüber den Anfängern ist, oder es mangelt an eigenwissen der Moderatoren hier !!!!
TrippleEx
 
Posts: 13
Joined: 19. June 2005 13:35

Postby Mr. Death » 12. March 2006 12:38

:?

Na ja, an sich wurde mir hier immer gut weitergeholfen.

Anscheinend ist dieses Problem aber im Moment nicht lösbar.

Ich für meinen Teil habe den xampp neu installiert und hab mir als Übergang ein PHP Script als Ersatz programmiert.

Das ist zwar nicht so toll aber als übergang gehts schon. Ich hoffe aber, dass es noch eine Antwort auf unser Problem gibt.


Gruss
Markus :wink:
Es gibt keine dummen Fragen, nur dumme Antworten.
User avatar
Mr. Death
 
Posts: 30
Joined: 11. January 2006 13:17
Location: Bayern


Return to Perl

Who is online

Users browsing this forum: No registered users and 1 guest