Perlpfad und Error auf Seite

Alles, was Perl betrifft, kann hier besprochen werden.

Perlpfad und Error auf Seite

Postby RomeoMuc » 19. January 2006 23:45

Hallo,

ich weiß jetzt leider nicht ob ich hier im Forum richtig bin oder ob man mir helfen kann. Ich bin ziemlich neu auf dem Gebiet und komme nicht ganz klar. Bin seit kurzem bei 1blu und wollte jetzt mal ein paar eigene Scripte einspielen. Für ein Script brauche ich den Pfad zu Perl. Wie kann ich den rausfinden ? Jemand hatte mir gesagt das sollte in der PHPinfo.php stehen ? Da finde ich nur leider nichts. Wo finde ich diesen Pfad ?
Außerdem habe ich noch ein anderes Problem mit dem Script. Ist aber wohl etwas verzwickt. Habe die Domain auf /www/alexweb/ geleitet. Im verzeichniss habe ich dann cgi-bin und unterverzeichniss perlsoft (gästebuch) angelegt. Man muß die install.cgi zur installation starten. Also sollte doch dann www.alexweb.de/cgi-bin/perlsoft/install.cgi gehen, oder ? Leider zeigt er mir hier immer an das er das Objekt nicht gefunden hat. Die Datei sollte aber in jedem Fall da sein ? Was kann der Error 404 noch bei Apache heissen ?

Hoffe auf Hilfe

Vielen Dank

Alex
RomeoMuc
 
Posts: 5
Joined: 19. January 2006 23:23

Postby Wiedmann » 20. January 2006 01:02

Für ein Script brauche ich den Pfad zu Perl.

normal:
/usr/bin/perl

Was kann der Error 404 noch bei Apache heissen ?

"Nicht gefunden"...

Im verzeichniss habe ich dann cgi-bin und unterverzeichniss perlsoft (gästebuch) angelegt.

Es könnte sein, dass es in der Serverkonfiguration schon einen Alias "cgi-bin" für ein anderes Verzeichnis gibt. Dort gibt es dann natürlich kein Unterverzeichnis "perlsoft" mit deiner Datei.

In beiden Fällen sollte dir aber eigentlich der Support von 1blu helfen können...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RomeoMuc » 20. January 2006 12:46

Vielen Dank die Tipps waren schon mal ganz gut. Jetzt habe ich alles angepasst und bekomme einen anderen Fehler:

Fehlermeldung:
Premature end of script headers: install.cgi

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 500


Was kann der bedeuten ? Wo kann ich hier Ursachenforschung betreiben ?
RomeoMuc
 
Posts: 5
Joined: 19. January 2006 23:23

Postby AppleUser » 16. February 2006 00:59

Das gleiche Problem habe ich und mein Kumpel auch. Ich habe bereits mit der Hotline telefoniert, angeblich wird das an die Technik weitergeleitet. So wie ich das sehe, ist CGI / Perl noch nicht freigeschaltet bei 1blu. Ziemlich ätzend das ganze! :evil:
AppleUser
 
Posts: 1
Joined: 16. February 2006 00:07

Postby RomeoMuc » 20. February 2006 12:41

Das ist ja interessant. Habe da ja auch schon hunderte mal angerufe. Und da bringt man mir immer die tollsten ausreden. Da heißt es ich bin ein Einzelfall und es läuft überall. Man stellt mich da etwas zu doof zum einstellen hin. Außerdem sagt man einfach das man für selbergeschriebene Scripten keinen Support macht und Perl läuft einfach super. Das tolle ist ja das es über SSL teilweise läuft Probiert das doch mal. Also ich verzweifel langsam an 1blu. Da läuft einfach vieles noch nicht. Das einzige was perfekt läuft ist der Bankeinzug von meinen Bankkonto. Bekomme auch immer wieder Termeine gesagt wo was fertig sein soll und dann wird es wieder nichts. Es läuft ja immer noch im SafeMode und der sollte längst abgeschaltet sein. Die können mir aber auch nicht sagen ob das eventuell die Ursache für den Fehler sein könnte. Jedenfalls haben die da so ein kleines cgi sctipt das sich servertest nennt und der sagt perl wäre okay. Ich glaub das jedoch jetzt nicht mehr das es an uns liegt. Auf keinen Fall bin ich ein Einzelfall.
RomeoMuc
 
Posts: 5
Joined: 19. January 2006 23:23

Postby deepsurfer » 20. February 2006 16:09

hhhmmmmm ich hab mir mal die Meldungen über 1blu angeschaut.
Und wenn nur ein drittel davon war ist, dann rate ich dir dort weg zu gehen.
Der Preis ist verlockend, aber was nützt der Preis wenn der rest nicht geht.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian


Return to Perl

Who is online

Users browsing this forum: No registered users and 1 guest