Kompatibilität von Zusatzmodulen (Version)

Alles, was Perl betrifft, kann hier besprochen werden.

Kompatibilität von Zusatzmodulen (Version)

Postby baerli » 07. June 2005 12:17

Hallo,

um CGI mit Perl zu lernen, hatte ich voriges Jahr den Server XITAMI und ActivePerl installiert. Diverse Zusatzmodule habe ich mir von CPAN heruntergeladen. War alles für einen Anfänger sehr zeitraubend, bis es gepasst hat.

Jetzt bin ich auf Euer Angebot gestossen, das ich prima finde, da ich auch angefangen habe, PHP zu lernen.

Jetzt taucht folgendes Problem auf. Ich will das Modul WWW::Mechanize installieren. Das "alte" passt wohl nicht mehr, aber auch die neueste Version nicht. Ich erhalte stets die Fehlermeldung
Code: Select all
HTML::Parser object version 3.38 does not match bootstrap parameter 3.43 at C:/apachefriends/xampp/perl/lib/DynaLoader.pm line 253
ausgelöst durch "use WWW::Mechanize;"

Da es Dutzende von Versionen von WWW::Mechanize gibt, wie kann ich feststellen, welche Version zu XAMPP mit Addon Perl passt ?

Danke für Eure Hilfe
baerli
 
Posts: 6
Joined: 07. June 2005 11:58
Location: Stuttgart

Return to Perl

Who is online

Users browsing this forum: No registered users and 1 guest