Perl + CGI Nachinstallieren

Alles, was Perl betrifft, kann hier besprochen werden.

Perl + CGI Nachinstallieren

Postby Punkt » 12. May 2005 21:50

Hallo,
heute komme ich (als immer noch dummer) Anwender mit einer neuen Frage: Kann man Perl und CGI nachinstallieren, denn beim Status werden beide Proggis als Deaktiviert angezeigt!

Mein IP-Updater lief die ganze Zeit unter Perl!!

Meine Anwendung (PHPKIT) läuft unter Suse 9.1 Pure-Ftp, Apache + MySQL- alles funktioniert! Wenn ich es richtig verstanden habe, gibt es ein Add On doch nur bei Windows ??? Also was wäre zu tun ??

Es würde mir die Sache erleichtern, wenn es eine Möglichkeit gäbe, ansonsten bleibt mir eine Neuinstallation nicht erspart.

Liebe Grüsse und Danke

Punkt
User avatar
Punkt
 
Posts: 13
Joined: 11. April 2005 18:56
Location: Müllrose

Postby Wiedmann » 12. May 2005 23:37

Kann man Perl und CGI nachinstallieren,

Nicht wirklich, da man es ja auch nicht deinstallieren kann.

Hast du irgendwie in der "httpd.conf" rumgespielt?

denn beim Status werden beide Proggis als Deaktiviert angezeigt!

Zeigt der nur deaktiviert an, oder tut es wirklich nicht?:
http://localhost/cgi-bin/printenv
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Punkt » 13. May 2005 09:44

Hallo wie schon geschrieben, läuft mein IP Updater (Perl-script- alles andere läuft unter PHP)nicht mehr seit 2 Tagen, sonst hätte ich es ja nicht bemerkt. Auch beim Neustart des Servers wird das Programm nicht gestartet.

Also, Perl muss irgendwie ausgeschaltet sein!!! Eine Erklärung habe ich leider nicht, bin mir keiner Schuld bewusst. An der "httpd.conf" lasse ich die Finger grundsätzlich davon, ausser es sagt mir einer genau, was ich tun soll.

Frage: Welche Perl Ordner müssen denn überhaupt vorhanden sein ?
Bei mir sehe ich in den Ordnern nix von Perl ??

Danke für die Hilfe

Punkt
User avatar
Punkt
 
Posts: 13
Joined: 11. April 2005 18:56
Location: Müllrose

Postby deepsurfer » 13. May 2005 14:48

was sagen denn die error-logs auf deiner linuxkiste ???

Biste du dir sicher das dein IP-Script nicht läuft, oder kann es nur seine funktion (Ip updaten) nicht durchführen, denn dann tippe ich auf umbauten ausserhalb deiner linuxkiste..... etwa neuer router/firewall/switch/etc.etc.etc
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby Punkt » 13. May 2005 16:09

Hallo Deep, Hallo Wiedmann

Danke für den Hinweis, in der Log Datei nachzuschauen. Hätte ich eigentlich selber drauf kommen können.

Also zum Thema: Protokolliert wird leider nur von heute Nacht, also alles nach dem letzten Neustart! (Kann ja so gewollt sein )

Fakt ist, das seit dem IP Wechsel heute 10:45 der Updater ( Perl script) wieder seinen Dienst aufgenommen hat?? Vorher war nix. Verändert habe ich nichts, ausser etliche Startversuche !!!

Fehler auf der Flucht entkommen ??? :D

Oder der Fehler liegt bei dem DDNS Provider, obwohl ich an die Leutchen's eine E-mail geschrieben habe, leider ohne Rückantwort.

Um den Serverbetrieb aufrecht zu erhalten, hatte ich mich mit einem Windows IP Updater beholfen.

Was jetzt noch bleibt ist zu klären, warum in der Status Anzeige Perl+ CGI als deaktiviert markiert sind. Es kann durchaus sein, dass ich dieses Problem seit dem letzten Update habe.( So geschehen am 14.04.05 - seit dem die Probs angefangen haben - siehe meine erste Anfrage)

Ok--- Danke für euere Unterstützung, ihr seid Spitze!

Lieben Gruss aus Brandenburg

Punkt
User avatar
Punkt
 
Posts: 13
Joined: 11. April 2005 18:56
Location: Müllrose


Return to Perl

Who is online

Users browsing this forum: No registered users and 2 guests