Module HTML::Entities und Crypt::DSA - woher?

Alles, was Perl betrifft, kann hier besprochen werden.

Module HTML::Entities und Crypt::DSA - woher?

Postby petitprince » 10. March 2005 17:49

Hallo,

zum Betreiben von Movable Type 3.15 auf XAMPP 1.4.12 + Perl-AddOn 1.4.12 (Win32) benötige ich die Perl-Module HTML::Entities und Crypt::DSA, die laut Movable Type auf dem installierten XAMPP-Server noch nicht vorliegen. Ich habe bereits gegoogelt aber keine Quelle für die Module gefunden. Kann mir jemand sagen, woher ich sie bekomme? - Herzlichen Dank! :-)

petitprince
petitprince
 
Posts: 74
Joined: 10. January 2005 22:31

Postby deepsurfer » 10. March 2005 18:01

http://search.cpan.org/~btrott/Crypt-DS ... ypt/DSA.pm

http://search.cpan.org/~gaas/HTML-Parse ... ntities.pm

bei beiden kannst du hinter "Module Version" auf Source klicken.

hope that help
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby petitprince » 10. March 2005 18:25

Hallo 'deepsurfer',

vielen Dank für die schnelle Antwort! - Die beiden Seiten hatte ich auch schon gefunden, aber ich hatte den Link auf den Quelltext tatsächlich übersehen.

Ich habe mir beide Quellen jetzt in zwei Textdateien mit den Namen "Entities.pm" und "DSA.pm" gespeichert. Installiere ich sie mit

Code: Select all
ppm install entities.pm


bzw.

Code: Select all
ppm install dsa.pm


?

- Noch einmal herzlichen Dank!

petitprince
petitprince
 
Posts: 74
Joined: 10. January 2005 22:31

Postby deepsurfer » 10. March 2005 19:05

nö....einfach ins verzeinis kopieren...


saug grad das addon damit ich dir den richtigen pfad gebe..



ins \xampp\perl\lib verzeichnis ablegen, dann sollte es gehen



Mit diesem CGI-Script kannst du dir alle Module anzeigen lassen und noch einige Informationen zu CGI.
Benutze dieses Script immer um zu testen ob CGI funtkioniert und was für module zur verfügung stehen.
http://cologne-predators.de/deepsurfer/sysinfoxampp.rar

ist eine sysinfoxampp.cgi datei (reiner text) einfach ins CGI verzeichnis und über URL aufrufen.
Gegebenenfalls Editieren falls du andere XAMPPpfade benutzt.
derzeit steht das script auf
Code: Select all
#!\xampp\perl\bin\perl.exe


Beim perl-addon von xampp braucht das bis zu 30 sekunden um alle module anzuzeigen
Last edited by deepsurfer on 10. March 2005 19:27, edited 2 times in total.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby petitprince » 10. March 2005 19:16

deepsurfer wrote:nö....einfach ins verzeinis kopieren...


saug grad das addon damit ich dir den richtigen pfad gebe..



ins \xampp\perl\lib verzeichnis ablegen, dann sollte es gehen


Hallo 'deepsurfer',

noch einmal vielen Dank für die Hilfe! Ich bewege ich gerade selbst durch die Verzeichnisstruktur und vermute DSA.pm muss nach perl\lib\Crypt und Entities.pm nach perl\lib\HTML (jetzt begreife ich auch endlich die Namenskonvention! :-)).

Was mich aber irritiert: Die Pakete sind schon vorhanden, ohne dass ich sie installiert habe (also wahrscheinlich im Perl-AddOn 1.4.12 schon enthalten)! - Gibt es einen Grund, warum Movable Type sie nicht findet (oder genereller: "sie von CGI-Skripten vielleicht nicht gefunden werden können"?)? - Das Perl-AddOn ist wie gesagt ordnungsgemäß installiert, Movable Type scheint soweit auch zu laufen, nur mt-check.cgi meldet in der fraglichen Kategorie immer noch:

Code: Select all
HTML::Entities
HTML::Entities ist auf Ihrem Server nicht installiert, oder HTML::Entities erfordert ein anderes Modul, das nicht installiert ist. HTML::Entities ist zur Codierung einiger Zeichen erforderlich. Diese Funktion kann jedoch mit der Option NoHTMLEntities in mt.cfg deaktiviert werden. Bitte ziehen Sie die Installationsanweisungen zur Installation von HTML::Entities zu Rate.

LWP::UserAgent
LWP::UserAgent ist auf Ihrem Server installiert (Version 2.001).

SOAP::Lite (version >= 0.5)
SOAP::Lite ist auf Ihrem Server installiert (Version 0.52).

File::Temp
File::Temp ist auf Ihrem Server installiert (Version 0.12).

Image::Magick
Image::Magick ist auf Ihrem Server nicht installiert, oder Image::Magick erfordert ein anderes Modul, das nicht installiert ist. Image::Magick ist optional, und nur erforderlich, wenn Sie Miniaturansichten von hochgeladenen Bildern erstellen können möchten. Bitte ziehen Sie die Installationsanweisungen zur Installation von Image::Magick zu Rate.

Storable
Storable ist auf Ihrem Server installiert (Version 2.13).

Crypt::DSA
Crypt::DSA ist auf Ihrem Server nicht installiert, oder Crypt::DSA erfordert ein anderes Modul, das nicht installiert ist. Crypt::DSA ist optional. Durch dessen Installation wird der Anmeldevorgang für die Kommentarregistrierung beschleunigt. Bitte ziehen Sie die Installationsanweisungen zur Installation von Crypt::DSA zu Rate.

MIME::Base64
MIME::Base64 ist auf Ihrem Server installiert (Version 3.05).

XML::Atom
XML::Atom ist auf Ihrem Server installiert (Version 0.07).


Vielen Dank noch einmal! :-)

petitprince
petitprince
 
Posts: 74
Joined: 10. January 2005 22:31

Postby deepsurfer » 10. March 2005 19:21

nachdem ich so darüber nachgeschaut habe, habe ich bei CPAN gelesen (da wo die links her sind) das zu diesen Modules etwaige zusatzkomponenten benutzt werden.

Bin aber nicht weiter da nach gegangen.. hätte jetzt auch keine konkrete hilfstellung mehr zur Verfügung....sorry....


@Wiedmann[Oracle] ! hättest du einen vorschlag ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby petitprince » 10. March 2005 19:24

Hmm, es sieht so langsam nach einem Fall aus, der eher ins Movable Type-Support-Forum passt. :-) - Ich werde dort einmal nachfragen und die Antwort, sollte ich eine bekommen, hier posten.

petitprince
petitprince
 
Posts: 74
Joined: 10. January 2005 22:31

Postby petitprince » 10. March 2005 19:53

Noch nichts von meiner Nachfrage im Movable Type-Support-Forum, allerdings die Ergebnisse des obigen CGI-Skripts (da ich nur eine DSL-Anbindung habe und nicht weiß, wieviel Forums-Besucher sie im Zweifel verkraftet, habe ich die Server-Adresse unkenntlich gemacht).

Was mich als Laien irritiert, ist die fehlende "Perl befindet sich in:"-Angabe. SERVER_ADMIN werde ich demnächst auch einmal korrekt setzen ...

petitprince

Code: Select all
SysInfo
v1.0 vom 28.03.2000

Server Pfade

Perl:   C:\Programme\xampp\xampp\perl\bin\perl.exe
Perl-Version:   5.008006
Betriebssystem:    MSWin32
Perl befindet sich in:   
Sendmail:    
Verzeichnisse, die nach Perl durchsucht wurden   C:/Programme/xampp/xampp/perl/lib
C:/Programme/xampp/xampp/perl/site/lib
.

Umgebungsvariablen

SCRIPT_NAME    /cgi-bin/sysinfoxampp.cgi
SERVER_NAME    XXXXXXXXXXXX
SERVER_ADMIN    admin@localhost
HTTP_CONNECTION    keep-alive
REQUEST_METHOD    GET
SYSTEMROOT    C:\WINNT
HTTP_ACCEPT    text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
SCRIPT_FILENAME    C:/Programme/xampp/xampp/cgi-bin/sysinfoxampp.cgi
COMSPEC    C:\WINNT\system32\cmd.exe
SERVER_SOFTWARE    Apache/2.0.53 (Win32) PHP/5.0.3 mod_ssl/2.0.53 OpenSSL/0.9.7e mod_perl/1.999.21 Perl/v5.8.6
HTTP_ACCEPT_CHARSET    ISO-8859-1,utf-8;q=0.7,*;q=0.7
WINDIR    C:\WINNT
QUERY_STRING    
REMOTE_PORT    3764
PATHEXT    .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
HTTP_USER_AGENT    Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.6) Gecko/20050226 Firefox/1.0.1
SERVER_PORT    80
SERVER_SIGNATURE    
Apache/2.0.53 (Win32) PHP/5.0.3 mod_ssl/2.0.53 OpenSSL/0.9.7e mod_perl/1.999.21 Perl/v5.8.6 Server at XXXXXXXX Port 80
HTTP_ACCEPT_LANGUAGE    de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
HTTP_COOKIE    phpbb2mysql_t=a%3A2%3A%7Bi%3A29%3Bi%3A1110476244%3Bi%3A30%3Bi%3A1110477370%3B%7D; phpbb2mysql_data=a%3A0%3A%7B%7D; phpbb2mysql_sid=f0605c819173f9f77e1402a419a1f6c9
REMOTE_ADDR    192.168.0.34
HTTP_KEEP_ALIVE    300
SERVER_PROTOCOL    HTTP/1.1
HTTP________________    ------------
PATH    c:\programme\imagemagick\imagemagick;C:\Perl\bin\;C:\WINNT\system32;C:\WINNT;C:\WINNT\system32\WBEM
REQUEST_URI    /cgi-bin/sysinfoxampp.cgi
GATEWAY_INTERFACE    CGI/1.1
SERVER_ADDR    192.168.0.33
DOCUMENT_ROOT    C:/Programme/xampp/xampp/htdocs
REMOTE_HOST    XXXXXXXX
HTTP_HOST    XXXXXXXX

Installierte Module

[...]

Crypt::DSA
Crypt::DSA::Key
Crypt::DSA::Key::PEM
Crypt::DSA::Key::SSH2
Crypt::DSA::KeyChain
Crypt::DSA::Signature
Crypt::DSA::Util

[...]

HTML::AsSubs
HTML::Clean
HTML::Element
HTML::Element::traverse
HTML::Entities
HTML::Filter
HTML::Form
HTML::FormParser
HTML::HeadParser
HTML::LinkExtor
HTML::Mason
HTML::Mason::ApacheHandler
HTML::Mason::Buffer
HTML::Mason::Cache::BaseCache
HTML::Mason::CGIHandler
HTML::Mason::Compiler
HTML::Mason::Compiler::ToObject
HTML::Mason::Component
HTML::Mason::Component::FileBased
HTML::Mason::Component::Subcomponent
HTML::Mason::ComponentSource
HTML::Mason::Escapes
HTML::Mason::Exceptions
HTML::Mason::FakeApache
HTML::Mason::Interp
HTML::Mason::Lexer
HTML::Mason::MethodMaker
HTML::Mason::Request
HTML::Mason::Request::ApacheHandler2
HTML::Mason::Resolver
HTML::Mason::Resolver::File
HTML::Mason::Resolver::Null
HTML::Mason::Tests
HTML::Mason::Tools
HTML::Mason::Utils
HTML::Parse
HTML::Parser
HTML::PullParser
HTML::Strip
HTML::TableContentParser
HTML::TableExtract
HTML::TableExtractor
HTML::Tagset
HTML::TextToHTML
HTML::TokeParser
HTML::Tree
HTML::TreeBuilder
petitprince
 
Posts: 74
Joined: 10. January 2005 22:31

Postby deepsurfer » 11. March 2005 08:43

Was mich als Laien irritiert, ist die fehlende "Perl befindet sich in:"-Angabe. SERVER_ADMIN werde ich demnächst auch einmal korrekt setzen ...


Keine Panik, das Sysinfoscript ist schon etwas älter und wurde für Unixsystem geschrieben, die parameter für diesen Eintrag werden in der Windowsumgebung falsch gelesen (weil nicht interpretierbar = unixpfade) und daher erscheint kein Eintrag.

CoderWorld (Stefanos) hat auch eine neuere Version des Scriptes, aber die ist noch unbrauchbarer, da dort parameter benutzt werden die eine windowsumgebung gar nicht kennt und mehr als die hälfte wird als Fehler angezeigt.


PS: Für diejenigen die jetzt gleich Aufschrecken und meinen Anzumerken das die Pfadeinträge mit slash bzw. backslash lauten sollen, so muss ich hier sagen das dieses Script ein Ergebnisfenster aufbaut und die Einträge zum teil im Speicher Windowskonform gestossen werden.

Besser zu verstehen wäre es so.
- Die Einträge mit Backslash sind aus Systemparameter angezeigt.
- Die Einträge mit Slash sind aus der Übergabe vom Browser (bekanntlich wird dort mit slash gearbeitet) übernommen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby petitprince » 11. March 2005 16:31

ich wrote:Was mich als Laien irritiert, ist die fehlende "Perl befindet sich in:"-Angabe. SERVER_ADMIN werde ich demnächst auch einmal korrekt setzen ...


deepsurfer wrote:Keine Panik, das Sysinfoscript ist schon etwas älter und wurde für Unixsystem geschrieben, die parameter für diesen Eintrag werden in der Windowsumgebung falsch gelesen (weil nicht interpretierbar = unixpfade) und daher erscheint kein Eintrag.


Alles klar. Nach einigen Tagen Beschäftigung mit der Perl-Installation auf XAMPP werde ich eigentlich nur noch stutzig, wenn beide Arten von Slashes in einem einzigen Pfad auftauchen ... :-)

Übrigens: Gehe ich richtig in der Annahme, dass das obige Output des CGI-Skripts nichts enthält, was geradezu auf einen Fehler hindeutet?

Ich habe meine Fragen bereits im Movable Type-Support-Forum gestellt: http://www.movabletype.org/support/index.php?act=ST&f=7&t=50527.
Bis jetzt gibt es leider keine Antwort und der Thread ist auch gerade einmal achtmal angesehen worden. - Vielleicht sollte ich mich langsam nach einer Alternative zu Movable Type (WordPress, Sunlog, ...) umsehen?

petitprince
petitprince
 
Posts: 74
Joined: 10. January 2005 22:31

Postby petitprince » 11. March 2005 23:37

Ich habe das Problem jetzt "umschifft": http://community.apachefriends.org/f/viewtopic.php?p=46260#46260

Vielen Dank noch einmal an 'Deepsurfer' für alle Hinweise! :-)

petitprince
petitprince
 
Posts: 74
Joined: 10. January 2005 22:31


Return to Perl

Who is online

Users browsing this forum: No registered users and 3 guests