Unterstützung bei Reaktivierung eines alten Servers

Alles, was Perl betrifft, kann hier besprochen werden.

Unterstützung bei Reaktivierung eines alten Servers

Postby lhenn » 19. August 2020 18:51

Hallo,

ich habe vor Jahren mal ein Backup eines FTP und MySQL-Servers angelegt und dann den Inhalt überschrieben. Normalerweise ging ich davon aus, jetzt einfach den FTP-Inhalt auf einen Server zu Kopieren und via PHPmyAdmin die MySQL-Datenbank zu importieren.

Das ist das erste Mal, dass ich XAMPP für die Einrichtung eines lokalen Servers benutze (ich habe aktuell keinen Hoster, der Perl/CGI unterstützt). Server ist soweit eingerichtet, Dateien kopiert und wenn ich den Server über localhost:8080 aufrufe, erscheint auch das Inhaltsverzeichnis des htdocs-Ordners. Navigiere ich allerdings zu einer darin befindlichen Datei (z.B. http://localhost:8080/cgi-bin/fwauth.pl), sagt mir mein Browser, die Datei gebe es nicht:

"Objekt nicht gefunden! Der angeforderte URL konnte auf dem Server nicht gefunden werden. Der Link auf der verweisenden Seite scheint falsch oder nicht mehr aktuell zu sein. Bitte informieren Sie den Autor dieser Seite über den Fehler. [...] Error 404"


Dabei existiert Sie genau unter diesem Pfad auf dem Server...

Kann mir jemand weiterhelfen? Derartiges ist für mich Neuland, ich kenne mich sonst 'nur' mit Wordpress und der FTP-Verwaltung aus... Perl sagt mir gar nichts, aber ich benötige nun einmal den Inhalt der alten Seite. ;)

Ich danke Euch!
lhenn
 
Posts: 3
Joined: 24. June 2020 18:09
XAMPP version: 7.4.7
Operating System: macOS Catalina 10.15.5

Re: Unterstützung bei Reaktivierung eines alten Servers

Postby Nobbie » 19. August 2020 19:45

Ich würde vermuten, dass die cgi-bin URL nicht auf htdocs/cgi-bin verweist, sondern auf cgi-bin neben htdocs. Soweit ich in Erinnerung habe, ist Xampp per Default so eingerichtet. Kopiere/Verschiebe mal die entsprechende Datei.
Nobbie
 
Posts: 11673
Joined: 09. March 2008 13:04

Re: Unterstützung bei Reaktivierung eines alten Servers

Postby lhenn » 19. August 2020 21:09

Nobbie wrote:Ich würde vermuten, dass die cgi-bin URL nicht auf htdocs/cgi-bin verweist, sondern auf cgi-bin neben htdocs. Soweit ich in Erinnerung habe, ist Xampp per Default so eingerichtet. Kopiere/Verschiebe mal die entsprechende Datei.


Ich habe leider keine Zugangsrechte, um Dateien in den cgi-bin-Ordner im "Root"-Verzeichnis (aus XAMPP-Sicht, also auf der selben Ebene, wo auch der htdocs-Ordner liegt) zu kopieren. Alles vor dem htdocs-Ordner ist schreibgeschützt und das lässt sich auch nicht über die Finder-Informationen (macOS) ändern... Weitere Ideen? :)
lhenn
 
Posts: 3
Joined: 24. June 2020 18:09
XAMPP version: 7.4.7
Operating System: macOS Catalina 10.15.5


Return to Perl

Who is online

Users browsing this forum: No registered users and 1 guest