Kriege kein MySQL 4.1.8 zum laufen :(

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Kriege kein MySQL 4.1.8 zum laufen :(

Postby ConiKost » 03. January 2005 00:06

Hallo!
Ich habe hier mit Apache2 + PHP4 + PHP5 +MySQL installiert (kein XAMPP, alles einzeln!)

So, Apache läuft mit PHP4 und PHP5 ohne Probleme! Ich habe dies so gelöst :

<IfModule mod_alias.c>
ScriptAlias /PHP4/ "G:\PHP4/"
AddType application/x-httpd-php .php .php4 .php3 .phtml
Action application/x-httpd-php "/PHP4/php.exe"

ScriptAlias /PHP5/ "G:\PHP5/"
AddType application/x-httpd-php5 .php5
Action application/x-httpd-php5 "/PHP5/php-cgi.exe"
</IfModule>


So, dazu habe ich nun MySQL installiert, und den Standard assistenen gekommen und dabei ein passwort für root vergeben :)

Nun wollte ich MySQL testen, indem ich mir phpMyAdmin 2.6.0-pl3 geladen habe!

In der config.inc.php habe ich user root und mein passwort eingegben

wenn ich das nun übern browser abrufe kommt folgender fehler:

#1251 - Client does not support authentication protocol requested by server; consider upgrading MySQL client


Wie kann ich das jetzt beheben?
Ich möchte jetzt bitte keinen Ratschlag ala nim XAMPP!
Ich möchte das nicht, da ich gerne das einzeln haben will und es verstehen will :) Wie wurde den das in XAMPP realisiert?

Danke für eure Antworten

[EDIT]
Wenn root kein psw hat kann sich phpMyAdmin einloggen!
ConiKost
 
Posts: 11
Joined: 02. January 2005 23:56

Postby deepsurfer » 03. January 2005 10:32

Textquelle: http://www.php-homepage.de/forum/ptopic,212.html


Habe das Problem gefunden: MySQL 4.1 verwendet einen neuen Hashingalgorythmus für Userpasswörter, der mit dem alten inkompatibel ist.

Falls noch jemand vor diesem Problem stehen sollte, mehr Info's und Lösung hier: http://dev.mysql.com/doc/mysql/en/Old_client.html



chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ConiKost » 03. January 2005 14:10

Hey super!
Besten Dank!
Alles läuft jetzt :)

Wisst ihr, warum das ganze nicht über die http metode geht ?
also statt config http ...
ConiKost
 
Posts: 11
Joined: 02. January 2005 23:56

Postby ConiKost » 04. January 2005 11:36

*push*
Niemand ne idee ?
ConiKost
 
Posts: 11
Joined: 02. January 2005 23:56


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 3 guests