ERROR 1044: Access denied for user: '@%' to database 'tobi'

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Postby Wiedmann » 07. December 2004 19:33

Die Antwort dazu hattest du schon in meiner ersten Antwort.

Direkt einen Post jetzt über deinem letzten befindet sich sogar ein Link zum MySQL - Manual, wo man das ganz genau nachlesen kann. Auch was man da machen kann. Oder einen entsprechenden Benutzer für so ein Vorhaben einrichten kann.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tobiasl » 08. December 2004 00:10

Wiedmann wrote:Die Antwort dazu hattest du schon in meiner ersten Antwort.

Direkt einen Post jetzt über deinem letzten befindet sich sogar ein Link zum MySQL - Manual, wo man das ganz genau nachlesen kann. Auch was man da machen kann. Oder einen entsprechenden Benutzer für so ein Vorhaben einrichten kann.


ja schon gesehen nur nicht verstanden....

Ich hatte es soweit sogar mal geschafft als ich den rechner jedoch neustarten mußte klappte es wieder nicht...
tobiasl
 
Posts: 22
Joined: 19. June 2004 23:01

Postby Andy R » 08. December 2004 15:20

Hallo zusammen, es geht weiter :)

Das folgende soll selbstverständlich keine Kritik darstellen, lediglich einen Hinweis :)
Heute morgen wollte ich weiterarbeiten und hab auf einmal wieder die Fehler von gestern.

Ich habe heute den ganzen Tag versucht eine Konfiguration ans laufen zu kriegen, es will einfach nicht. Es sieht so aus, als ob MySQL irgend ein Problem hat. Nach JEDEM Neustart hat root kein Kennwort mehr, ausserdem sind sämtliche Rechte entzogen worden.

Folgende Schritte hab ich in diversen Variationen versucht.
Ich beziehe mich jetzt nur auf die ZIP-Version, allerdings habe ich die gleichen Erfahrungen mit der INstaller-Version gemacht. Des weiteren habe ich die "readme_de.txt" befolgt, um jegliche Fehler zu vermeiden.

1.ZIP-Archiv (xampp-win32-1.4.10.zip) geladen, entpackt nach D:\xampp

2. setup_xampp.bat ausgeführt ->Erfolgreich

3. apache_start.bat -> Erfolgreich
3a. http://localhost aufgerufen -> Erfolgreich

4. Wie in Anweisung angegeben Apache-CMD-Fenster geschlossen ->Erfolgreich

5. mysql_start.bat -> Mysql startet, CMD-Fenster geht nicht zu (Erwünscht?)
5a. mysql -u root ->Erfolgreich

6. mysql_stop.bat -> Nicht Erfolgreich: Fehlermeldung, ausserdem mysql-start CMD geht nicht zu.
6a) mysqld.exe Task per Taskmanager abgeschossen

7. xampp_start.exe -> Erfolgreich

8. mysqladmin -u root password meinpasswort -> Erfolgreich

9. mysql -u root -> Nicht erfolgreich: Fehler Wrong Password (so solls ja auch sein)

10. mysql -u root -pmeinpasswort ->Erfolgreich, kann Datenbanken mit "create database" anlegen.

11. xampp_stop.exe -> Erfolgreich

12. xampp_start.exe -> Erfolgreich

13. mysql -u root -pmeinpasswort -> Nicht erfolgreich (Access denied, using password YES)

13. mysql -u root ->Erfolgreich, kann mich einloggen.
13a) create database meinedb; ->Nicht erfolgreich, Fehler: ERROR 1044 (42000): Access denied for user ''@'%' to database 'meinedb'


Es scheint so, als seien die Rechte für MySQL-User root nach jeden Neustart überschrieben worden. Gibt es irgendein Script das beim starten von xampp ausgeführt wird und irgendwelche Rechte umstrickt?

Wenn ich alles stoppe und die Datenbank "mysql" aus dem Backup-Ordner wieder ins Data-Verzeichnis von MySQL kopiere, dann geht das Spielchen wieder von vorne los.

Ich möchte natürlich niemanden auf die Füße treten, aber ist Version 1.4.10 evtl. ein bischen buggy?
Vielleicht bin ich auch einfach zu blöd, das will ich gar nicht ausschliessen :) Aber vielleicht gibt es ja auch einen Trick wie man das Verhalten ändern kann.

Vielen Dank für evtl. Antworten oder workarounds

Andreas
Andy R
 
Posts: 7
Joined: 07. December 2004 14:39

gleiches Problem

Postby micha71 » 08. December 2004 16:35

Hallo Andy,

du bist nicht allein! Ich habe deine Beschreibung gelesen und gedacht, sie wäre von mir... Hab mir deshalb den ganzen Abend gestern um die Ohren gehauen! :cry: Ich habs nur mit der zip-Version 1.4.10 versucht. Meine Vorgehensweise war exakt dieselbe. Passwort ändern mit den 3 Tipps aus den faq http://www.apachefriends.org/de/faq-xampp-windows.html incl. config.inc.php klappt zunächst zwar schon, aber nur solange, wie man mysql nicht beendet und neu startet. Dann kann man sich mit dem user root weder in phpmyadmin einloggen noch mit mysqladmin das Passwort auf Kommandozeile ändern.

Einloggen in phpmyadmin geht dann nur noch mit dem pma-account (ist nicht schön, weiß ich...). Dort könnte man ja theoretisch über "Rechte - root - bearbeiten" das root-Passwort wieder entfernen, dann kommt aber die Fehlermeldung "#1333 - Can't find any matching row in the user table", geht also nicht. Den user root findet man aber durchaus noch in der Datenbank mysql, Tabelle user. Dort lässt sich das Passwort dann auch löschen, und nach dem Neuladen der Benutzertabellen kann man sich auch wieder als root (ohne Passwort) einloggen. Danach kann man das Spielchen wieder von vorne beginnen...

Hat jemand da draußen eine Lösung für unser Problemchen?

Gruß
Micha
micha71
 
Posts: 2
Joined: 08. December 2004 15:42

Postby Andy R » 08. December 2004 17:40

Hi Micha,

ich scheine ja doch nicht bekloppt zu sein :), ein gutes Zeichen :D

Ok, hab mal im mysql/bin Verzeichnis die error-Log angeschaut.
Bin nicht auf der Arbeit, deshalb kann ich jetzt nicht die genaue Meldung posten, kommt morgen nach). Bei mir steht bei jeden Start in etwa sowas:

"Dont updating passwords in user.table". Die Meldung ist länger, aber da steht noch was von nem Script das zuerst laufen muss.

Ach egal, ich zieh die Zip mal hier nach hause auf den Rechner, gucken ob ichs hier reproduzieren kann.

Ach ja, ich hab mir noch die BAT-Dateien angeguckt, konnte da aber auf die schnelle nichts entdecken, was irgendwie nach mysql-Befehlen aussieht, die die Datenbank zurücksetzen. Kann mit aber auch nur schwer vorstellen, das sowas existiert.



UPDATE:

So, habs nun mal zuhasue nachvollzogen, es passiert exakt das gleiche.

Die Log-Datei nennt sich mysql.err und liegt nicht im bin, sondern im data-Verzeichnis. Das hier wird geloggt, wenn man xampp startet und wieder schliesst.


041208 17:47:21 [Warning] mysql.user table is not updated to new password format; Disabling new password usage until mysql_fix_privilege_tables is run
041208 17:47:21 [Warning] Can't open and lock time zone table: Table 'mysql.time_zone_leap_second' doesn't exist trying to live without them
mysql\bin\mysqld.exe: ready for connections.
Version: '4.1.7-log' socket: '' port: 3306 Source distribution
041208 17:48:14 [Note] mysql\bin\mysqld.exe: Normal shutdown

041208 17:48:15 [Note] mysql\bin\mysqld.exe: Shutdown complete


Vielleicht muss man diese mysql_fix_privileges erst laufen lassen, sonst zerschiesst es einem die Datenbank, zumal dieses Warning auch schon beim allerersten Start auftritt. Kann aber auch völlig unwichtig sein die Meldung.

Ich bin kein MySQL-Spezie und hab überhaupt keine Ahnung wie man " mysql_fix_privileges" laufen lassen kann. Warten wir mal ab, vielleicht hat ja noch jemand ne Idee.

Prost, das Krombacher das vor mir steht wird jetzt erstmal genüsslich geplättet :)
Andy R
 
Posts: 7
Joined: 07. December 2004 14:39

Postby micha71 » 08. December 2004 18:45

Hi Andy,

das mit der mysql.err sieht bei mir fast genauso aus, bis auf die zusätzliche Zeile, nachdem ich das Passwort geändert habe und mysql neu gestartet habe:

041208 [Warning] Found invalid password for user: 'root@localhost'; Ignoring user

Das erklärt auch (in meinem begrenzten Verstand :lol:), dass man sich mit root nicht einloggen kann, denn der existiert ja nicht für die Nutzerverwaltung von mysql. Aber wieso invalid password...? Klar, wenn man es von Hand setzt und die Verschlüsselung falsch setzt, klappt nicht, siehe http://dev.mysql.com/doc/ - German - PDF (A4) S. 216. Aber z.B. mit mysqladmin müsste es eigentlich gehen.

Die mysql.err sieht man übrigens auch (etwas komfortabler, aber von unten nach oben) mit WinMySQLAdmin.

Gruß
Micha
micha71
 
Posts: 2
Joined: 08. December 2004 15:42

Postby Petrus » 08. December 2004 20:13

Hallo,

ich hatte das gleiche Problem, 1 1/2 h alles probiert, ohne Erfolg.

Lösung bei mir: XAMPP 1.4.9 komplettversion runtergeladen, und den ordner /mysql über den von 1.4.10 vorhandenen überschrieben (zur Vorsicht ohne /mysql/data)
jetzt gehts wieder ... halt mit der älteren version

Gruß
Petrus
Petrus
 
Posts: 39
Joined: 20. May 2004 07:50

Postby lowrider » 08. December 2004 20:21

Habe exakt das gleiche Problem....

Nur ich habe dem pma User ebenfalls ein PW zugewiesen und da ist es jetzt genau das gleiche wie beim root Acount.
Exakt die gleichen Fehlermeldungen einfach mit dem User pma.....

Brauche dringen hilfe....muss die Daten auf der Sql Datenbank undbedingt erreichen können.

Scheint aber noch niemand eine geigenete Lösung dafür gefunden zu haben?
lowrider
 
Posts: 3
Joined: 08. December 2004 20:10

Postby Petrus » 08. December 2004 21:14

ja bei mir war dann auch der pma user nicht erreichbar...

wie gesagt, den mysql aus der 1.4.9 wieder drauf und es ging (und die daten bleiben)
Petrus
 
Posts: 39
Joined: 20. May 2004 07:50

Postby lowrider » 08. December 2004 21:37

Ja aber dann ist's wieder wie beim alten mit root ohne PW ond pma ebenfalls ohne PW.....
lowrider
 
Posts: 3
Joined: 08. December 2004 20:10

Postby Andy R » 08. December 2004 22:22

Nabend,

@Petrus

Danke für den Tipp, das werd ich morgen früh mal ausprobieren. :)
Andy R
 
Posts: 7
Joined: 07. December 2004 14:39

Previous

Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 2 guests