Probleme mit der Board-Software nach Update der SQL-DB

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Probleme mit der Board-Software nach Update der SQL-DB

Postby MK70 » 26. November 2004 18:48

Hallo,

ich habe im Augenblick, wie es scheint, recht heftige Probleme mit meiner Datenbank.
Mein Webhoster hat letzte Woche die MySQL-DB auf 4.1.7 geupdatet.
Seitdem haben alle Boards von uns gestanden, die bei XPS gehostet sind.
Herausgefunden hat man nun, dass sich das WBB1.2 nicht mehr mit der aktuellen version MySQL verträgt.
Daraufhin habe ich gestern von allen Files ein Backup gemacht.
WOllte dann heute eigentlich das WBB1.2 ins WBBLite konvertieren. Doch bekomme folgenden Fehler schon beim laden der Datenbank meines Boards in Xampp 1.4.9:

Fehler

SQL-Befehl :

CREATE TABLE bar_counter(

id int( 11 ) NOT NULL AUTO_INCREMENT ,
datum varchar( 14 ) NOT NULL default '',
ip varchar( 15 ) NOT NULL default '',
PRIMARY KEY ( id )
)ENGINE = MYISAM DEFAULT CHARSET = latin1

MySQL meldet:

#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1' at line 6


Ich glaube jetzt nicht, dass das Problem selbst mit der Tabelle zu tun hat, sondern eher, das ein zusammenspielen der beiden MySQL-Versionen vorliegt.
Wer hat auch solche Probleme und evtl. eine Lösung parat ???
Ich hoffe hier findet sich jemand, der uns helfen kann...
Gruss MK
Wäre ich ein GENIE, würde ich selbst coden... ;o))
User avatar
MK70
 
Posts: 66
Joined: 26. November 2004 18:13
Location: 47809, Krefeld
XAMPP version: 5.6.24
Operating System: Win10 pro/home 32/64bit

Postby Jan H. Krüger » 26. November 2004 18:53

Öffne die Sicherung in einem Editor und dann ersetze alle Vorkommnisse von "DEFAULT CHARSET = latin1" gegen "".
Also einfach diese Meldung in jeder Tabellendefinition entfernen. Sollte das Problem lösen.
Jan H. Krüger
 
Posts: 152
Joined: 24. October 2004 19:42

Postby MK70 » 26. November 2004 19:18

Hi, des funzt leider net.
Stelle die verschiedenen Fehelermeldungen auch mal hier ein:

Möglicherweise haben Sie einen Bug im SQL-Parser entdeckt. Bitte überprüfen Sie Ihre Abfrage genaustens, insbesondere auf falsch gesetzte oder nicht geschlossene Anführungszeichen. Eine weitere Ursache könnte darin liegen, dass Sie versuchen eine Datei mit binären Daten, welche nicht von Anführungszeichen eingeschlossen sind, hochzuladen. Sie können alternativ versuchen Ihre Abfrage über das MySQL-Kommandozeileninterface zu senden. Die MySQL-Fehlerausgabe, falls vorhanden, kann Ihnen auch bei der Fehleranalyse helfen. Falls Sie weiterhin Probleme haben sollten oder der Parser dort versagt, wo die Kommandozeile erfolgreich ist, so reduzieren Sie bitte Ihre Abfrage auf den Befehl, welcher die Probleme verursacht, und senden Sie uns einen Bugreport mit den Datenausschnitt, den Sie weiter unten auf dieser Seite finden.:
----AUSSCHNITTSANFANG----
eNqdUMtu2zAQvPMr9hA0DmDRovyozaIH1SEcIZLsSoqDnGzJYmwheoWi7Lq/lgI99IP6CyWTuvWl
lxIgsZgdzuwOC4J5QGFKYGqBy3wKBCwYDggKI4W/IDRdhhQunJRC85zXsWi4wHmW4HpXd/dgYasP
lmkOeua4Z07AJNSy6HACOS8mwL7UcIG8Y/jZpTDAJraIkfKk3Rp5tUV3YQDzsAv2jPlRF5ZMGd5n
JTgMRthEC8+mSl+VRp0TtLhZaEp3rsYZaim4d3w/Qq7tzyik3MiayhiPhxNDza79fr58NwxQY3pH
Oy2UrkLhui1qpOA9F01WlX/0LQ3upKxpr3c4HPR2xTHW33DJpW7qe1M1kkJebeJ8p0oNMdFInudt
uW2+8kx1rREGv9rzIuHiNRloCyAjSoimh1woa1i+2etQCH6vG2o94wztY7UHTiup4sL9k/91LHmZ
xOUThXXbiFVjkbY/XJH1K0E/xn8edLKI4kStw8tGivZJtgIef3wTJxTWSSxWm6otJRe/TacBsyMG
kf3JZXDWhg4CyFLIStkh5Ar8eQT+netC3MpqlZUbwQteyq5ipbFUGe1jsdnFokMGZ+SUP8ZtLuHy
UhOz+i9r+E/WInA8O3iAW/YA0MnSK3QFzJ85PvvoHZ3Q9uDdc1vJD2/vL5L31w4=
----AUSSCHNITTSENDE----
----BEGINN DER AUSGABE----

ERROR: C1 C2 LEN: 1 2 541
STR: »

CVS: $Id: sqlparser.lib.php,v 2.23 2004/08/09 01:22:59 lem9 Exp $
MySQL: 4.0.21-debug-log
USR OS, AGENT, VER: Win IE 6.0
PMA: 2.6.0-pl1
PHP VER,OS: 5.0.2 WINNT
LANG: de-iso-8859-1
SQL: -- phpMyAdmin SQL Dump


SQL-Befehl:

-- phpMyAdmin SQL Dump -- version 2.6.0-pl2 -- http://www.phpmyadmin.net -- -- Host: localhost -- Erstellungszeit: 26. November 2004 um 16:11 -- Server Version: 4.1.7 -- PHP-Version: 4.3.9-1.dotdeb.3 -- -- Datenbank: `usr_s21u35_1` -- -- -------------------------------------------------------- -- -- Tabellenstruktur für Tabelle `bar_counter` -- CREATE TABLE bar_counter ( id int(11) NOT NULL auto_increment, datum varchar(14) NOT NULL default '', ip varchar(15) NOT NULL default '', PRIMARY KEY (id) ) ENGINE=MyISAM ""
MySQL meldet:

#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '-- phpMyAdmin SQL Dump
-- version 2.6.0-pl2
-- http://www.


Ich habe auch nochmal geschaut, ob ich vielleicht was falsches angeklickt habe, weil die phpMyAdmin-Version ja auch grafisch völlig neu für mich ist.
Aber habe nichts gefunden, was ich anders gemacht habe, als sonst... :(
Gruss MK
Wäre ich ein GENIE, würde ich selbst coden... ;o))
User avatar
MK70
 
Posts: 66
Joined: 26. November 2004 18:13
Location: 47809, Krefeld
XAMPP version: 5.6.24
Operating System: Win10 pro/home 32/64bit

Postby Jan H. Krüger » 26. November 2004 19:39

Schau dir die Create-Statements nochmal genau an ob du da nicht noch etwas anderes rausgeworfen hast.
Ich handhabe das jetzt schon knapp einen Monat so wenn ich DB-Inhalte von der Arbeit auf der ich MySQL 4.1 einsetze zu Hause unter 4.0 einspielen will und bishe rohne Probleme.

Oder halt, vielleicht hab ich mich undeutlich ausgedrückt. Beim ersetzen natürlich nicht "" eintragen sondern halt einen leeren String. Einfach das DEFAULT CHARSET = latin1 einfach komplett rauswerfen.
Jan H. Krüger
 
Posts: 152
Joined: 24. October 2004 19:42

Postby MK70 » 26. November 2004 19:43

ähm, also den Text raus und nichts einsetzen, ok ???
Dann werde ich das Morgen früh nochmal testen. heut geht net mehr... :?
Gruss MK
Wäre ich ein GENIE, würde ich selbst coden... ;o))
User avatar
MK70
 
Posts: 66
Joined: 26. November 2004 18:13
Location: 47809, Krefeld
XAMPP version: 5.6.24
Operating System: Win10 pro/home 32/64bit

Weitere Rückmeldung:

Postby MK70 » 27. November 2004 12:12

Guten Morgen oder Mahlzeit... :D

Habe gerade mal versucht die DB wieder einzufügen. Mit dem herausnehmen des Defaults...(blablabla). und nicht durch "" ersetzt.
Leider bekomme ich die gleiche Fehlermeldung, wie auch mit den "".

Was nun ?
Noch wer eine Idee ?

@Jan:
Deine Hilfe, bzgl. ERSETZEN war klasse.
Da steht das da im Kontextmenue und ich hab das über Jahre nicht wirklich wahr genommen... :oops: :oops: :oops:
Dank Dir für den guten Tipp. Das wird in Zukunft einiges einfacher machen... :lol:
Gruss MK
Wäre ich ein GENIE, würde ich selbst coden... ;o))
User avatar
MK70
 
Posts: 66
Joined: 26. November 2004 18:13
Location: 47809, Krefeld
XAMPP version: 5.6.24
Operating System: Win10 pro/home 32/64bit

Postby Wiedmann » 27. November 2004 13:02

Mein Webhoster hat letzte Woche die MySQL-DB auf 4.1.7 geupdatet.
Daraufhin habe ich gestern von allen Files ein Backup gemacht.
Doch bekomme folgenden Fehler schon beim laden der Datenbank meines Boards in Xampp 1.4.9 (MySQL 4.0.21)

Du musst beim Export einer 4.1.x Datenbank, dem Tool "mysqldump" den Parameter "--compatible=mysql40" mitgeben, damit du das in eine 4.0.x DB importieren kannst.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby MK70 » 27. November 2004 13:14

- Muss das jedesmal in eine gesicherte Datenbank eingegeben werden?
- Wo genau muss das dann rein gesetzt werden?

- Oder muss das von Seiten des Webhosters noch in phpMyAdmin eingesetzt werden, damit der Kunde damit nichts zu tun hat?
Gruss MK
Wäre ich ein GENIE, würde ich selbst coden... ;o))
User avatar
MK70
 
Posts: 66
Joined: 26. November 2004 18:13
Location: 47809, Krefeld
XAMPP version: 5.6.24
Operating System: Win10 pro/home 32/64bit


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 1 guest