keine verbindung zur datenbank?

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

keine verbindung zur datenbank?

Postby Thuwin » 09. October 2004 16:39

hiho

habe hier folgendes problem:

ich versuche gerade eine Funktion zu schreiben für die datenbank connection, doch ich scheitere schon am beginn der connection.

Code: Select all
$db_name  = "test";
$db_server = "'$db_server_name', '$db_user', '$db_pw'";

db_open($db_server, $db_name);   

function db_open($db_server, $db_name)
{      
   $verbindung = mysql_connect($db_server);
   
   if($verbindung)
   {   
      echo "Verbindung steht jetzt!";
   }
   else
   {
      echo "keine verbindung möglich!";
   }
}


soweit so gut aber irgendwie will er den zusammengebastelten $db_server string nicht haben (hab den schon in allen variationen umgebaut). wenn ich direkt die daten zum server bei connect eintrage funzt es aber.

sieht jemand meinen fehler?

greetz thuwin

ps: sollte doch diese form eigentlich haben oder?
Code: Select all
$verbindung = mysql_connect("host","user","passwort");


über ein kontroll echo auf $db_server zeigt er mir den inhalt entsprechend: 'host','user','passwort'
Thuwin
 
Posts: 4
Joined: 09. October 2004 10:43

Postby Wiedmann » 09. October 2004 18:01

Hmm,

mysql_connect erwartet drei getrennte (String-) Parameter. Du übergibst aber nur einen String. Auch wenn der optisch (beim echo) dem gewünschten ähnlich sieht, ist es trotzdem nur einer...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

hm ok

Postby Thuwin » 09. October 2004 18:22

danke dir für den hinweis, ich dachte er setzt die argumente dann eh zusammen.

dann eben alt hergebracht umsetzen :D

greetz thuwin
Thuwin
 
Posts: 4
Joined: 09. October 2004 10:43


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 5 guests