Apache startet nach MySQL Installation nicht mehr

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

Apache startet nach MySQL Installation nicht mehr

Postby ApacheHä » 10. September 2018 19:25

Hallo Community,
ich hatte mir gestern einen MySQL Server auf meinem Raspberry Pi installiert. Das hat auch soweit geklappt.
Aber seit funktioniert mein Apache2 Server nicht mehr. Ich wollte nämlich mit "sudo a2enmod php7.0" mein PHP Modul aktivieren. Aber dann trat der Fehler auf:
Code: Select all
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit apache2.service has failed.
--
-- The result is failed.
Sep 10 20:22:30 raspberrypi systemd[1]: apache2.service: Unit entered failed sta
Sep 10 20:22:30 raspberrypi sudo[23954]: pam_unix(sudo:session): session closed
Sep 10 20:22:30 raspberrypi systemd[1]: apache2.service: Failed with result 'exi
Sep 10 20:22:31 raspberrypi mysqld[24065]: 2018-09-10 20:22:31 1995915264 [Note]
Sep 10 20:22:31 raspberrypi systemd[1]: mariadb.service: Main process exited, co
Sep 10 20:22:31 raspberrypi systemd[1]: Failed to start MariaDB database server.
-- Subject: Unit mariadb.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit mariadb.service has failed.
--
-- The result is failed.
Sep 10 20:22:31 raspberrypi systemd[1]: mariadb.service: Unit entered failed sta
Sep 10 20:22:31 raspberrypi systemd[1]: mariadb.service: Failed with result 'sig
Sep 10 20:22:35 raspberrypi sudo[24082]:       pi : TTY=pts/0 ; PWD=/home/pi ; U
Sep 10 20:22:35 raspberrypi sudo[24082]: pam_unix(sudo:session): session opened
lines 3004-3026/3026 (END)


Ich weiß wirklich nicht was MariaDB mit meinem Apache Server zu tun hat und was ich machen soll.

Liebe Grüße und Vielen Dank im Vorraus
ApacheHä


PS.:
--------------------Dies war mein allererster Post in diesem Forum! 8) ---------------------------------------
ApacheHä
 
Posts: 2
Joined: 10. September 2018 19:19
XAMPP version: 2.4.25
Operating System: Raspbian

Re: Apache startet nach MySQL Installation nicht mehr

Postby Nobbie » 10. September 2018 20:11

ApacheHä wrote:Hallo Community,


... und zwar "Xampp" Community. Mit Rapberry usw. hat dieses Forum leider nichts zu tun. Wenn ich es KÖNNTE, würde ich wirklich helfen, aber ich KANN es leider nicht, ich habe keinen Rapberry und ohne kann ich nirgends helfen.
Nobbie
 
Posts: 10543
Joined: 09. March 2008 13:04

Re: Apache startet nach MySQL Installation nicht mehr

Postby ApacheHä » 11. September 2018 14:16

Aber es ist doch egal, dass das nen RPi ist!
Es geht doch um den Apache
ApacheHä
 
Posts: 2
Joined: 10. September 2018 19:19
XAMPP version: 2.4.25
Operating System: Raspbian

Re: Apache startet nach MySQL Installation nicht mehr

Postby Nobbie » 11. September 2018 16:07

Ne, ist überhaupt nicht egal, es geht um die Installation im Raspbian und nicht um die Xampp Installation in anderen Linux Distributionen (die wir hier betreuen). Es tut mir Leid, ich kann es nicht erzwingen, ich habe keine Raspbian und kann weder Fehler noch Fehlermeldung nachvollziehen. Ich habe Null Ahnung, was da schief geht. Weil es nicht an Apache "an sich" liegt, sondern um die Umgebung. Der Fehler tritt bei mir (Linux Mint mit Xampp Apache) nicht auf und ich kann es auch nicht konstruieren. Es gibt auch kein ""sudo a2enmod php7.0" in meiner Infrastruktur, es gibt keinen "apache2.service" usw. etc. pp.. das funktioniert alles TOTAL ANDERS in meinem Umfeld und mein Umfeld ist das, was wir HIER unterstützen.
Nobbie
 
Posts: 10543
Joined: 09. March 2008 13:04


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 4 guests