dem system mehr Speicher geben

Alles, was MariaDB und MySQL betrifft, kann hier besprochen werden.

dem system mehr Speicher geben

Postby Babsy Taenzer » 01. September 2018 22:00

Hallo Forum,

in einer MySQl - Tabelle soll eine ca. 5 MB große PDF mit dem Mimetyp "application\octetstream" eingelagert werden. Wird aber nichts, der Server stürzt mit dem Errorcode 2006 ab. Der Speicher reicht nicht, habe 4 GB DDR RAM, sollte doch wohl reichlich sein.
Nehme ich eine kleinere PDF (250 KB) dann klappt's.

Gruß Babsy
Babsy Taenzer
 
Posts: 5
Joined: 26. January 2018 19:35
XAMPP version: 4.7.7
Operating System: Windows 10

Re: dem system mehr Speicher geben

Postby Nobbie » 02. September 2018 15:41

Babsy Taenzer wrote:Hhabe 4 GB DDR RAM, sollte doch wohl reichlich sein.


In der Theorie ja, in der Praxis ist es wichtig, wieviel Speicher davon MySQL zur Verfügung steht. Das wird festgelegt in der Konfigurationsdatei my.ini (oder my.cnf, weiß ich nicht auswendig) im Verzeichnis c:/xampp/mysql/bin (oder in c:/xampp/mysql/data oder direkt in c:/mysql/xampp). Ich habe leider kein Windows mehr um das nachzuschauen. Da gibt es auch ein paar andere Musterkonfigurationen a la "my-large.ini" und "my-huge.ini" usw., die sind für mehr Speicherplatz eingerichtet. Ich glaube die Standardauslieferung ist auf my-small.ini (kopiert auf my.ini). Benenne die my.ini mal um in my-original.ini und dann kopiere die large oder sogar die huge auf my.ini und starte dann MySQL neu. Vielleicht geht es dann besser.
Nobbie
 
Posts: 10611
Joined: 09. March 2008 13:04

Re: dem system mehr Speicher geben

Postby Babsy Taenzer » 02. September 2018 21:08

habe getan wie mir geraten und die my-huge.ini übernommen, doch leider sind anscheinend andere Fehler sichtbar geworden.
das ist meine alte zeile, mit der wurde bisher gearbeitet: ' innodb_data_file_path = ibdata1:50M:autoextend'

wenn ich diese zeile ergänze mit ibdata2: 'innodb_data_file_path = ibdata1:50M:autoextend;ibdata2:10M:autoextend'

müßte auch mein alte MY.INI laufen, unabhängig davon was ich mit PDF's vorhabe. macht es aber nicht. das Xampp blockiert.
meine mysql-error.log ist leer und bleibt auch leer. egal wieviel Fehler ich erzeuge. das scheint ein zweiter fehler zu sein, den ich schon immer drin hatte. habe ich bisher ignoriert, ging ja auch so.

Babsy
Babsy Taenzer
 
Posts: 5
Joined: 26. January 2018 19:35
XAMPP version: 4.7.7
Operating System: Windows 10

Re: dem system mehr Speicher geben

Postby Babsy Taenzer » 02. September 2018 21:16

Ich bin's noch mal. Habe vergessen zu erwähnen, daß die ibdata1 sich nicht vergrößern läßt. Bekomme die ibdata1 auf max. 70 MB hochgeschraubt. darüber hinaus blockiert bereits das Xampp. Also ist hier grundsätzlich etwas faul.

B.
Babsy Taenzer
 
Posts: 5
Joined: 26. January 2018 19:35
XAMPP version: 4.7.7
Operating System: Windows 10

Re: dem system mehr Speicher geben

Postby Nobbie » 03. September 2018 10:34

Babsy Taenzer wrote:das Xampp blockiert.


Was soll das sein, ein kleiner Kobolt oder so? "Das Xampp" ist nur eine Abkürzung für eine Softwaredistribution, da "blockiert" (wenn überhaupt) MariaDB. Ich habe keine Ahnung, was da schief läuft und was nicht, aber vielleicht könnte man die Datenbank auf MyISAM oder so umstellen, wenn das ein Problem von InnoDB ist.

P:S.: Einen Fehler Deinerseits habe ich schon gefunden, die autoextend Klausel kann man NUR auf den letzten Eintrag machen, nicht auf alle:

The autoextend and max attributes can be used only for the data file that is specified last in the innodb_data_file_path setting.


https://dev.mysql.com/doc/refman/5.5/en ... ation.html

Das erklärt natürlich, was da "blockiert". Ich habe keine Ahnung, ob man "autoextended" Dateien im nachhinein auf mehrerer Dateien verteilen kann, also entweder weiterhin nur mit ibdata1 arbeiten (müßte ja eigentlich auch gehen), oder eine neue Installation aufsetzen und die ibdata1 von vorneherein deutlich größer anlegen (falls das das Grundproblem löst). Ob man eine vorhandene InnoDB nachträglich auf mehrere Datenbankendateien aufteilen kann, weiß ich nicht, ich weiß auch nicht, ob man nachträglich autoextend angeben kann. Ich kenne eine vergleichbare Problematik von VirtualBox, da muss man auch von Anfang an eine virtuelle Festplatte erzeugen, auch entweder feste Größe oder autoextend, das ist im Nachhinein nicht mehr so ohne weiteres änderbar. Keine Ahnung, wie das bei InnoDB ist. Steht vielleicht auch irgendwo in der Doku (s.o.).

Last not least: was soll Xampp 4.7.7 sein? So eine Version sagt mir nichts. Aktuell gibt es (mit PHP7) Xampp 7.2.9 und (mit PHP5) Xampp 5.6.37. Eine Version 4.7.7 hat es nie gegeben.
Nobbie
 
Posts: 10611
Joined: 09. March 2008 13:04

Re: dem system mehr Speicher geben

Postby Babsy Taenzer » 03. September 2018 20:32

ich habe mein xampp nocheinmal eingerissen und installierte die 'xampp-win32-7.2.0-0-VC15-installer.exe'.
In der 'mysql_error.log' werden keine Protokolldaten aufgezeichnet und das ließ mir keine Ruhe.

Jetzt befinden sich 4 verschiedene my.ini im Verzeichnis.

1. medium : RAM 32 - 64 MB System startet, aber keine ErrorlogDaten, jedenfalls nicht in der Datei

2. large : = 512 M System startet, dto.
mit zeile: innodb_data_file_path = ibdata1:10M:autoextend dto., kein errorlog

System versucht zu starten, schafft es aber nicht. kein Absturz
innodb_data_file_path = ibdata1:10M;ibdata2:10M:autoextend

damit ist mein mySQl mal gelaufen, jetzt nicht mehr:
innodb_data_file_path = ibdata1:50M:autoextend

3. huge : 1G bis 2G System startet nicht, Server stürzt ab.
innodb_data_file_path = ibdata1:2000M;ibdata2:10M:autoextend Absturz
innodb_data_file_path = ibdata1:50M:autoextend Absturz

ErrrorlogFenster:
21:15:05 [mysql] Fehler: MySQL wurde unerwartet beendet
21:15:05 [mysql] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
21:15:05 [mysql] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
21:15:05 [mysql] Drücke den Logs Button um error logs zu sehen und prüfe
21:15:05 [mysql] im Windows Event Viewer für weitere Hinweise
21:15:05 [mysql] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
21:15:05 [mysql] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.

geht auch nicht : innodb_data_file_path = ibdata1:10M Absturz
zeile läuft in der medium, kein grund warum es in der huge nicht auch funktionieren kann.

4. my.ini von der Erstinstallation erzeugt: RAM < 64M ErrorlogDaten werden in die Datei geschrieben.
Babsy Taenzer
 
Posts: 5
Joined: 26. January 2018 19:35
XAMPP version: 4.7.7
Operating System: Windows 10


Return to MariaDB - MySQL

Who is online

Users browsing this forum: No registered users and 5 guests